Zugriff auf IPv4 Content über IPv6-only System

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von neurex, 28. Nov. 2013.

  1. neurex

    neurex Member

    Ich stehe aktuell etwas auf dem Schlach und hoffe hier hat bereits mal irgendwer mit ähnlichem zu kämpfen gehabt. Folgende Situation:

    Ich habe mehrere Server die nur über IPv6 erreichbar sind. Möchte ich nun auf Content zugreifen welcher ausschließlich über IPv4 erreichbar ist bekomme ich logischerweiße einen "Netzwerk nicht verfügbar" Error. Nun habe ich also nach einer Lösung gesucht von einem IPv6-only System auch auf IPv4-only Systeme zuzugreifen (z. B. zum Download von Updates) und bin auf DNS64 / NAT64 gestoßen.

    Wenn ich das ganze richtig verstanden habe (korrigiert mich wenn ich falsch liege) dann wird bei den IPv6-only Systemen ein zusätzlicher Nameserver hinterlegt auf dem DNS64 / NAT64 läuft hinterlegt. Der DNS64/NAT64 Server wird per IPv6 erreicht, greift dann auf den IPv4 Content zu und leitet diesen zum anfordernden System durch. Soweit so gut...

    Ich versuche nun das ganze per BIND und Tayga aufzubauen. Pakete hierzu stellt das neue openSUSE 13.1 bereit allerdings bekomme ich das ganze nicht richtig zum laufen.

    Die eth0 des DNS64/NAT64 Systems hat folgende Daten:
    - IPv6-Addr (5b03:548:c043:0:a000::3)
    - IPv4-Addr (81.634.274.63)
    - IPv6-Gateway (5b03:548:c043::1)
    - IPv4-Gateway (81.634.274.33)

    In der /etc/named.conf habe ich folgendes ergänzt:
    in der /etc/tayga.conf folgendes:
    und starten tue ich tayga mit folgenden commands:
    Auf dem IPv6-only System gebe ich den DNS64 / NAT64 Server als Nameserver mit der IP 5b03:548:c043:0:a000::3 an. Ich hab Zugriff auf das ganze 5b03:548:c043::/64 Netz, will für diesen Zweck aber ein kleineres Netz bereitstellen.

    Aber... es funktioniert nicht. Wahrscheinlich habe ich bei den IPs was falsch gemacht... aber wo?
     

Diese Seite empfehlen