zugriff auf ispconfig website funktioniert nicht

#1
!!! falsches Forum !!! kann ich aber leider nicht ändern - sorry!.

Hallo *,
bin neu hier.

Habe ispconfig installiert - klar.

der Zugriff auf die website mit port 8080 bringt:

Code:
uses('tpl'); $app->tpl->newTemplate('main.tpl.htm');  // tab change warning? // read misc config $app->uses('getconf'); $sys_config = $app->getconf->get_global_config('misc'); if($sys_config['tab_change_warning'] == 'y') {     $app->tpl->setVar('tabchange_warning_enabled', 'y');     $app->tpl->setVar('global_tabchange_warning_txt', $app->lng('global_tabchange_warning_txt')); } else {     $app->tpl->setVar('tabchange_warning_enabled', 'n'); } $app->tpl->setVar('tabchange_discard_enabled', $sys_config['tab_change_discard']); if($sys_config['tab_change_discard'] == 'y') {     $app->tpl->setVar('global_tabchange_discard_txt', $app->lng('global_tabchange_discard_txt')); }  if(isset($_SESSION['show_info_msg'])) {     $app->tpl->setVar('show_info_msg', $_SESSION['show_info_msg']);     unset($_SESSION['show_info_msg']); } if(isset($_SESSION['show_error_msg'])) {     $app->tpl->setVar('show_error_msg', $_SESSION['show_error_msg']);     unset($_SESSION['show_error_msg']); }   $app->tpl_defaults(); $app->tpl->pparse(); ?>
Da muss irgendwas an der apache config falsch sein.

Ich habe allerdings schon viele websites in dem apache aktiv.

apache definition:

Code:
######################################################
# This virtual host contains the configuration
# for the ISPConfig controlpanel
######################################################

Listen 8080

<VirtualHost *:8080>
  ServerAdmin avadmin@av.loc
  DocumentRoot /var/www/ispconfig/

  <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
  </FilesMatch>

  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
      Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
        <FilesMatch "\.php$">
                SetHandler fcgid-script
        </FilesMatch>
        FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
        Require all granted
        </Directory>
    IPCCommTimeout  7200
        MaxRequestLen 15728640
  </IfModule>

  <IfModule mpm_itk_module>
    DocumentRoot /usr/local/ispconfig/interface/web/
        AssignUserId ispconfig ispconfig
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
      Options +FollowSymLinks
      AllowOverride None
          Require all granted
                  php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>

  # ErrorLog /var/log/apache2/error.log
  # CustomLog /var/log/apache2/access.log combined
  ServerSignature Off

  <IfModule mod_security2.c>
    SecRuleEngine Off
  </IfModule>

  # SSL Configuration
  SSLEngine On
  SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
  SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
  #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle

</VirtualHost>

<Directory /var/www/php-cgi-scripts>
    AllowOverride None
                Require all denied
        </Directory>

<Directory /var/www/php-fcgi-scripts>
    AllowOverride None
        Require all denied
        </Directory>
Für Anregungen dankbar.

Gruß
Kallewirsch
 
Zuletzt bearbeitet:

nowayback

Well-Known Member
#2
hi,

nur zum verständnis: Du hattest schon jede Menge Webseiten am laufen und hast nun nachträglich auch noch ISPConfig installiert?

Grüße
nwb
 
#3
Hi nowayback,

ja, so ises!

gut - ich mach mal einschränkungen: 4-5

Funktionieren auch noch, soweit ich die jetzt mal schnell getestet habe.

Ist kein "produktivsystem" und bin auch nur ich drauf.
 
#4
Hi nowayback,

ja, so ises!

gut - ich mach mal einschränkungen: 4-5

Funktionieren auch noch, soweit ich die jetzt mal schnell getestet habe.

Ist kein "produktivsystem" und bin auch nur ich drauf.
Das funktioniert in der Regel bzw. fast ausnahmslos dann nicht ohne weiteres da ISPC tiefgreifende Änderungen vornimmt und sich das nicht miteinander verträgt. Entweder du lässt alle Webseiten dieses Systems von ISPC konfigurieren oder du machst es manuell und musst dann aber auf ISPC verzichten. Beides geht nicht wirklich gut.
 

nowayback

Well-Known Member
#5
der richtige weg wäre: benötigte unterstützte software installieren, ispconfig installieren (ispconfig nimmt alle nötigen konfigurationseinstellungen vor), webseiten in ispconfig anlegen.

Wenn Anpassungen nötig sind, die du nicht in ispconfig direkt machen kannst, dann kannst du die jetzt vornehmen.

Am besten du hälst dich an eines der "Perfect Server Tutorials". Du findest diese auf howtoforge.de und howtoforge.com
 
#6
Hi,
war ein fehler den ispconfig auf ein existierendes system zu installieren - sehe ich ein.
Habe ihn gelöscht.

Habe ein komplett neues system nach anleitung aufgesetzt. ispconfig3 funktioniert. jetzt kann ich mich schlau machen wie das ding funktioniert.

Danke

Kann man den thread irgendwie löschen oder als "gelöst" kennzeichnen. Habe nix gefunden.
 

Werbung