Zugriff auf Öffentliche IP innerhalb des Netzwerkes

Dieses Thema im Forum "Server Administration" wurde erstellt von mallmis, 9. Feb. 2015.

  1. mallmis

    mallmis New Member

    Hallo liebe Forengemeinde,
    habe einen Ubuntu Server 14.04 aufgesetzt mit ISPConfig gemäß Anleitung. Meine Frage ist, wie kann ich es einstellen, das ich innerhalb des Netzwerkes in dem sich auch der Server befindet auf die erstellten Domains wie auch IP zugreifen kann und der entsprechende Inhalt erscheint. Im Moment findet der Browser nichts --> Fehler: Verbindung fehlgeschlagen....

    Konfiguration:
    Server hat: 192.168.1.11 <-- kann ich im Lan zugreifen und es erscheint die Apache Startseite --> Apache2 Ubuntu Default Page
    DNS mit öffentlicher ip konfiguriert, auch Webseiten
    Webseiten sind von aussen erreichbar
    Email funktioniert nur Versand bis jetzt, Empfang noch nicht
    EDIT: Empfang funktioniert auch, aber nur wenn ich meinen Client auf die interne Server IP stelle.

    Ports sind alle von Router auf Server geleitet.
    Natürlich ist eine statische IP vorhanden.
    Eine der Domains ist: porto-colom.net

    Wenn ihr noch mehr Details braucht, bitte gerne bescheid sagen.

    Gruß,

    mallmis
     
    Zuletzt bearbeitet: 9. Feb. 2015
  2. Till

    Till Administrator

    Du kannst z.B. die Domains in die hosts Datei Deines Desktop eintragen (gibt es unter win, Linux und Mac) und zwar mit der internen IP des Servers. Dann kannst Du die Domain einfach im Browser eingeben.
     
  3. mallmis

    mallmis New Member

    Schönen Guten Morgen Till,
    vielen Dank für die schnelle Antwort.
    Diese Lösung ist mir schon bekannt, Entschuldigung, das hatte ich nicht erwähnt.
    Ich dachte nur ob es noch eine andere Lösung dafür gibt, möglicherweise eine Dns Datei die Anfragen innerhalb des Netzwerkes korrekt weiterleitet oder vielleicht eine Einstellung im Router(FritzBox).
    Wenn jemand damit Erfahrungen hat bitte gerne posten.
    Eine Kleinigkeit hätte ich noch für die ich keinen neuen Beitrag öffnen möchte. Das installierte Bind meckert ein bisschen rum weil es keinen SPF Eintrag bzgl. Mail gibt. Habe dafür aber einen TXT Eintrag erstellt. Den SPF Eintrag habe ich manuell erstellt. Wenn ich aber wieder etwas über ISPConfig ändere ist dieser wieder entfernt. In der DNS Sektion findet sich auch kein Eintrag bzgl SPF.

    Gruß und vielen Dank schon mal,

    Mallmis
     
  4. Till

    Till Administrator

    Du brauchst keinen eintrag vom typ spf. die spf einträge sind txt records, der typ spf ist veraltet und sollte nicht mehr verwendet werden
     
  5. mallmis

    mallmis New Member

    Hallo Till,

    vielen Dank.
     
  6. wjaa45

    wjaa45 New Member

    Wenn jemand damit Erfahrungen hat bitte gerne posten?
     

Diese Seite empfehlen