AllowOverride All - Apache Direktiven

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von sven, 29. Jan. 2010.

  1. sven

    sven New Member

    Ich möchte 'allow_url_fopen' für ein Web aktivieren, was mir leider noch nicht gelingt...

    So bin ich vorgegangen:

    Unter Optionen: - Apache Direktiven: "AllowOverride All" eingetragen und in der .htaccess die folgende Zeile hinzugefügt: "php_value allow_url_fopen 1".

    Doch leider brachte das nicht den gewünschten Erfolg. Wie kann man 'allow_url_fopen' für ein Web auf 'ON' stellen?

    Danke.
     
  2. Till

    Till Administrator

    Denk bitte daran, dass "php_value" Einstellungen nur mit mod_php funktionieren. und dass es ca. 1 - 2 Minuten dauert, bis eine neue Config übernommen wurde (kannst Du im Monitor in der jobqueue sehen).
     
  3. sven

    sven New Member

    Das Web läuft mit "mod_php" und laut Monitor sind die Änderungen vollzogen.

    allow_url_fopen steht jedoch weiterhin auf 'Off'.
     
  4. Till

    Till Administrator

    Schreibe bitte mal:

    php_value allow_url_fopen 1

    direkt in das pache direktiven Feld der website in ispconfig. das AllowOverride All kannst Du dann wieder raus nehmen.
     
  5. sven

    sven New Member

    Funktioniert leider auch nicht, habe auch schon ohne Erfolg das Folgende versucht:

    php_admin_flag allow_url_fopen on
     
  6. Till

    Till Administrator

    Schau im vhost nach, wenn es dort richtig drin steht, liegt es zumindest nicht an ispconfig. Dann müsstest Du schauen, ob das wirklich die richtigen Direktiven sind.
     
  7. sven

    sven New Member

    In der vhost.conf steht Folgendes:

    php_value allow_url_fopen 1
    </VirtualHost>

    Also eigentlich alles ok, leider funktioniert es nicht.


    Das Folgende steht ebenfalls in der vhost:


    <Directory /var/www/domain>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/domain/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    <Directory /var/www/clients/clientx/webx/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
     
  8. Till

    Till Administrator

    Das ist alles ok soweit. Start den apache mal auf der shell neu und dann checke mal mittels phpinfo(); was der wert für allow_url_fopen ist und ob das script das Du aufrufts wirklich mit mod_php läuft und nuct etwa als cgi oder fcgi.
     
  9. Till

    Till Administrator

    Ähhmmmm... Da ist etwas was Du vielleicht vorher mal hättest prüfen können. Allow_url_fopen kann garnicht so konfiguriert werden. Aus Sicherheitsgründen ist diese Einstellung ausschließlich über die php.ini konfigurierbar. Siehe php manual:

    http://php.net/manual/en/filesystem.configuration.php
     
  10. sven

    sven New Member

  11. Till

    Till Administrator

    Dann lies doch bitte nochmal genau die Seite,m die ich verlinkt habe:

    allow_url_fopen:

    Note: This setting can only be set in php.ini due to security reasons.
     
  12. sven

    sven New Member

    Alles klar. Danke für die Hilfe!
     
  13. sven

    sven New Member

    Jetzt habe ich es doch noch hin bekommen: ;-)

    Der entscheidende Tipp war über die shell den apache neu zu starten.

    apache2ctl configtest

    brachte: "AllowOverride not allowed here"

    Also wurde der apache nie neu gestartet, da ja ein Fehler vorlag.

    Mit den folgenden Eintrag klappt es dann doch, ohne die Einstellung in der php.ini global zu setzen:

    php_admin_flag allow_url_fopen on
     

Diese Seite empfehlen