angelegter Cron im ISPC3 wird nicht ausgeführt

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von redi78, 27. Nov. 2009.

  1. redi78

    redi78 Member

    Hallo Leute,

    ich weiss nicht woran es liegt aber wäre toll wenn mir jemand helfen kann. Ich möcht per Cron diesen LINK aufrufen:

    Code:
    http://www.segelcheck.at/portal/index.php?option=com_community&task=cron
    Habe daher in ISPC3 folgenden Befehl eingetragen:

    Code:
    /usr/bin/lynx -source "http://www.segelcheck.at/portal/index.php?option=com_community&task=cron" > /dev/null
    ...jo nur es passiert nix. Habe ich einen Fehler bei der Syntax?

    lg redi78
     

    Anhänge:

  2. redi78

    redi78 Member

    Hat jemand eine Idee? Ich meine im syslog wird der Cron als ausgeführt geloggt. Wenn ich die URL händisch im Browser ausführe dann funktionierts. Mit Cron nicht. Hat jemand eine idee? Hab ich den Cron richtig im ISPC eingetragen?

    lg redi78
     
  3. Till

    Till Administrator

    Schau doch mal auf der shell nach was genau im user crontab des web users steht. Also:

    su web1
    crontab -l

    Du musst web1 Durch den Usernamen des webs ersetzen.
     
  4. redi78

    redi78 Member

    mhh:

    Code:
    root@server:/var/log/apache2# su web10
    root@server:/var/log/apache2# crontab -l
    * * * * * /usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log
    30 00 * * * /usr/local/ispconfig/server/cron_daily.sh > /dev/null 2>> /var/log/ispconfig/cron.log
    
     
  5. redi78

    redi78 Member

    Mhh, jemand eine Idee?
     
  6. Burge

    Burge Member

    PHP:
    root@server:/var/log/apache2# su web10
    ist das denn der username der users vom web10 der den cron angelegt hat?
     
  7. redi78

    redi78 Member

    Jo also laut ISPC ist web10 der entsprechende Benutzer:
     

    Anhänge:

  8. Burge

    Burge Member

    mhm ok, weil der ja nun den job gar nicht in der liste drin hat.
     
  9. redi78

    redi78 Member

    Also das versteh ich jetzt nicht. Eingetragen ist er ja auch, siehe Screenshot. Im Syslog-File habe ich folgenden Eintrag:

    Code:
    Nov 30 07:55:01 server /USR/SBIN/CRON[18816]: (web10) CMD (/usr/bin/lynx 
    -source 
    "http://www.segelcheck.at/portal/index.php?option=com_community&task=cron" 
     > /dev/null)
    Nur dieser Befehl wird nicht ausgeführt. Wenn ich die URL manuell im Browser aufrufe dann klappts.

    lg redi78
     

    Anhänge:

  10. Till

    Till Administrator

    Erstmal zu Deinem Listing in #4, das Listing dort ist vom root User (Zeile beginnt mit root@server und wenn Du web10 wärst dann würde da stehen web10@server), da hat also das mit dem su ausführen irgendwie nicht geklappt. Kommt z.B. manchmal bei vservern vor, wenn Du über die vzctl Konsole eingeloggt bist. Daher wurde der korrekt angelegte Cronjob auch nicht ausgeführt.

    Versuch doch mal wget statt lynx zu nehmen.
     
  11. redi78

    redi78 Member

    So habs jetzt mit wget versucht (siehe Screenshot).

    Code:
    /usr/bin/wget -O /dev/null "http://www.segelcheck.at/portal/index.php?option=com_community&task=cron" > /dev/null
    Hat aber leider auch nicht funktioniert.

    Ich muss das irgendwie zum Laufen bekommen. Jedesmal händisch anstossen ist nicht möglich.

    Hier der Logeintrag:

    Code:
    Nov 30 08:30:01 server /USR/SBIN/CRON[19519]: (web10) CMD (/usr/bin/wget 
    -O /dev/null 
    "http://www.segelcheck.at/portal/index.php?option=com_community&task=cron" 
     > /dev/null)
    Dieser Cronjob soll folgendes machen:
    http://www.jomsocial.com/docs/Cron_Setup
     

    Anhänge:

    Zuletzt bearbeitet: 30. Nov. 2009
  12. redi78

    redi78 Member

    Mhh hat niemand mehr eine Idee?

    lg redi78
     
  13. Till

    Till Administrator

  14. redi78

    redi78 Member

    Hi Till,

    folgendes Ergebniss erhalte ich:


    Code:
    root@server:~# sudo web10 /usr/bin/wget -O /dev/null http://www.segelcheck.at/portal/inde...nity&task=cron
    sudo: web10: command not found
    [1] 13102
    [1]+  Exit 1                  sudo web10 /usr/bin/wget -O /dev/null http://www.segelcheck.at/portal/inde...nity

    Was bedeutet das?

    lg redi78
     
  15. Till

    Till Administrator

    nimm bitte mal:

    Code:
    sudo -u web10 /usr/bin/wget -O /dev/null http://www.segelcheck.at/portal/index.php?option=com_community&task=cron
     
  16. redi78

    redi78 Member

    Hi Till,

    jetzt hab ich folgendes zurückgemeldet bekommen:

    Code:
    root@server:~# sudo -u web10 /usr/bin/wget -O /dev/null http://www.segelcheck.at/portal/index.php?option=com_community&task=cron
    [1] 16380
    root@server:~# --14:20:26--  http://www.segelcheck.at/portal/index.php?option=com_community
               => `/dev/null'
    Resolving www.segelcheck.at... 62.178.246.121
    Connecting to www.segelcheck.at|62.178.246.121|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    
        [ <=>                                 ] 62,005        --.--K/s
    
    14:20:28 (13.72 MB/s) - `/dev/null' saved [62005]
    
    Mhh warum klappts aber nicht wenn ich dies in ISPC eintrage?

    lg redi78
     
  17. redi78

    redi78 Member

    Wie genau muss ich dann den Befehl in ISPC eintragen?

    lg redi78
     
  18. redi78

    redi78 Member

    Jemand eine Idee?
     
  19. Till

    Till Administrator

  20. redi78

    redi78 Member

    Mhh also mit diesem Befehl funktionierts auch nicht. (siehe Screenshot)
    Nein ich habe weder selinux oder apparmor aktiviert.

    Was können wir noch tun?

    lg redi78
     

    Anhänge:

Diese Seite empfehlen