apache startet nicht mehr nachdem ssl zertifikat gelöscht wurde

#1
Hallo :)

ich habe auf das neue ispconfig upgedatet und wollte dann gleich ein ssl zertifikat von cacert.org hinzufügen. leider hab ich nicht ganz verstanden wie das geht und habe etwas herumprobiert.

dann wollte ich ein falsch eingetragenes zertifikat löschen und habe "delete certificate" ausgewählt und auf speichern geklickt. danach war keine seite mehr erreichbar (sämtliche domains, phpmyadmin, roundcube, ispconfig).

Error beim starten von Apache:
* Restarting web server apache2 [Sun Nov 06 22:25:35 2011] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
[Sun Nov 06 22:25:35 2011] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
Action 'start' failed.
The Apache error log may have more information.
Error.log von Apache:
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined index: server_id in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 424, referer: https://213.239.218.20 :8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined offset: 1 in /usr/local/ispconfig/interface/lib/classes/getconf.inc.php on line 38, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 557, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 557, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 558, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 558, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 559, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 559, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined variable: page_form in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 560, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Trying to get property of non-object in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 560, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined index: domain in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 615, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined index: domain in /usr/local/ispconfig/interface/web/sites/web_domain_edit.php on line 634, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:20 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined index: on_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 139, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:24 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined index: sitesn_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 139, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:24 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined index: sites:web_domain_after_update in /usr/local/ispconfig/interface/lib/classes/plugin.inc.php on line 139, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:24:24 2011] [error] [client 82.113.99.XX] PHP Notice: Undefined index: global in /usr/local/ispconfig/interface/lib/classes/getconf.inc.php on line 50, referer: https://213.239.218.XXX:8080/
[Sun Nov 06 21:25:02 2011] [error] [client 127.0.0.1] (13)Permission denied: cannot read directory for multi: /var/www/
[Sun Nov 06 21:25:02 2011] [error] [client 127.0.0.1] (13)Permission denied: cannot read directory for multi: /var/www/
[Sun Nov 06 21:25:02 2011] [error] [client 127.0.0.1] (13)Permission denied: cannot read directory for multi: /var/www/
[Sun Nov 06 21:25:02 2011] [error] [client 127.0.0.1] (13)Permission denied: cannot read directory for multi: /var/www/
[Sun Nov 06 21:25:02 2011] [error] [client 127.0.0.1] (13)Permission denied: cannot read directory for multi: /var/www/
[Sun Nov 06 21:25:02 2011] [error] [client 127.0.0.1] (13)Permission denied: cannot read directory for multi: /var/www/
[Sun Nov 06 21:25:03 2011] [notice] caught SIGTERM, shutting down
netstat -tap:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdo:10024 *:* LISTEN 8127/amavisd (maste
tcp 0 0 localhost.localdo:10025 *:* LISTEN 8002/master
tcp 0 0 *:mysql *:* LISTEN 7799/mysqld
tcp 0 0 localhost.localdo:spamd *:* LISTEN 1184/spamd.pid
tcp 0 0 mail.XX.d:domain *:* LISTEN 8996/named
tcp 0 0 localhost.locald:domain *:* LISTEN 8996/named
tcp 0 0 *:ftp *:* LISTEN 8977/pure-ftpd (SER
tcp 0 0 *:ssh *:* LISTEN 832/sshd
tcp 0 0 localhost.localdoma:953 *:* LISTEN 8996/named
tcp 0 0 *:smtp *:* LISTEN 8002/master
tcp 0 0 localhost.localdo:mysql localhost.localdo:41693 ESTABLISHED 7799/mysqld
tcp 0 300 mail.XX.de:ssh 82.113.99.XX:55975 ESTABLISHED 9557/0
tcp 0 0 localhost.localdo:mysql localhost.localdo:41719 ESTABLISHED 7799/mysqld
tcp 0 0 localhost.localdo:41719 localhost.localdo:mysql ESTABLISHED 8643/amavisd (ch8-a
tcp 0 0 mail.XX.de:ssh 82.113.99.XX:37019 ESTABLISHED 6807/sshd: root@not
tcp 0 0 mail.XX.de:ssh 82.113.99.XX:41422 ESTABLISHED 13526/sshd: root@no
tcp 0 0 localhost.localdo:41693 localhost.localdo:mysql ESTABLISHED 8639/amavisd (ch9-a
tcp6 0 0 [::]:imaps [::]:* LISTEN 8899/couriertcpd
tcp6 0 0 [::]:pop3s [::]:* LISTEN 8927/couriertcpd
tcp6 0 0 [::]:pop3 [::]:* LISTEN 8910/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 8882/couriertcpd
tcp6 0 0 [::]:domain [::]:* LISTEN 8996/named
tcp6 0 0 [::]:ftp [::]:* LISTEN 8977/pure-ftpd (SER
tcp6 0 0 [::]:ssh [::]:* LISTEN 832/sshd
tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 8996/named
 
#2
Dir fehlt wahrscheinlich die Zeile

Code:
NameVirtualHost *:443
oder er findet deine gelöschten Zertifikate nicht die in deinem Vhost stehen und startet desshalb nicht ?!
 
#4
Auf meinem Debian hab ichs zum Beispiel in /etc/apache2/sites-enables/000-ispconfig.conf die Zeilen:

NameVirtualHost MeineIP:80
NameVirtualHost MeineIP:443
 
#7
aaah ich glaub ich habs gleich :)
folgende fehlermeldung in einer domain wenn ich den apache2 starten möchte:
[Sun Nov 06 23:28:25 2011] [warn] RSA server certificate CommonName (CN) `xx.de - Informationen zum Thema Xx. Diese Website steht zum Verkauf!' does NOT match server name!?
[Sun Nov 06 23:28:25 2011] [error] Unable to configure RSA server private key
[Sun Nov 06 23:28:25 2011] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
das problem wird gelöst sein wenn ich ein zertifikat erstelle oder? wie mache ich das?
 
#8
hab im internet jetzt sämtliche seiten durchforstet aber konnte leider nichts zu meinem problem finden. kann man die zertifikate wirklich nur im ispconfig erstellen, welches ich momenten nicht erreichen kann?

gibts keine lösung für mein problem? :-/
 

Till

Administrator
#10
Lösche den Symlink im Verzeichnis /etc/apache2/sites-enabled/ mit dem Namen der Webseite und starte dann apache. Dann kannst Du Dich wiedre in ISPConfig einloggen und erstmal die SSL Checkbox der Seite deaktivieren und dann in ISPConfig ein neues SSL Zertifikat erstellen.
 
#11
Lösche den Symlink im Verzeichnis /etc/apache2/sites-enabled/ mit dem Namen der Webseite und starte dann apache. Dann kannst Du Dich wiedre in ISPConfig einloggen und erstmal die SSL Checkbox der Seite deaktivieren und dann in ISPConfig ein neues SSL Zertifikat erstellen.
problem gelöst:
https (port 443) eintrag für die jeweilige webseite aus der sites-enabled gelöscht und apache2 gestartet. danach ging es.

danke für eure hilfe.
 

Werbung