Apache zerschossen.

Dieses Thema im Forum "Allgemein" wurde erstellt von Timo, 12. Apr. 2013.

  1. Timo

    Timo New Member

    Guten Tag,

    habe vorhin ausversehen, da ich dachte ich sei auf einer VPS den Apache neuinstalliert, gibt es eine möglichkeit dies wiederherzustellen?

    ich bekomme folgende fehlermeldungen:
    Code:
    Reloading web server config: apache2[Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:80 has no VirtualHosts
    [Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:443 has no VirtualHosts
    [Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:80 has no VirtualHosts
    [Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:443 has no VirtualHosts
    [Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:80 has no VirtualHosts
    [Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:443 has no VirtualHosts
    [Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:80 has no VirtualHosts
    [Fri Apr 12 15:57:44 2013] [warn] NameVirtualHost ***.***.***.***:443 has no VirtualHosts
    //EDIT: Nach einem Server restart komme ich auf die login oberfläche von ISPCONFIG, einloggen kann ich mich
    aber trotzdem werden keine Webseiten angezeigt.
     
    Zuletzt bearbeitet: 12. Apr. 2013
  2. mare

    mare Member

    Versuch mal Einstellungen -> Resync -> Webseiten -> OK

    Damit werden die vhosts neu geschrieben.
     
  3. Timo

    Timo New Member

    Hallo Mare,

    vielen dank für deine Antwort,

    Dies ging auch, habe ich getan.
    Firefox bekommt aber keine verbindung.
    Apache restart kein Problem. --> Funktioniert nicht alles tot

    Code:
    Folgenden Code bekomme ich in der Shell ausgegeben:
    Starting web server: apache2[Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:80 has no VirtualHosts
    [Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:443 has no VirtualHosts
    [Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:80 has no VirtualHosts
    [Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:443 has no VirtualHosts
    [Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:80 has no VirtualHosts
    [Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:443 has no VirtualHosts
    [Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:80 has no VirtualHosts
    [Fri Apr 12 18:18:52 2013] [warn] NameVirtualHost *.*.*.*:443 has no VirtualHosts
    (98)Address already in use: make_sock: could not bind to address [::]:80
    (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs
    Action 'start' failed.
    The Apache error log may have more information.
     failed!
    root@server02:~#
    
    Logs:
    Code:
    [Fri Apr 12 18:17:25 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Apr 12 18:17:25 2013] [notice] Apache/2.2.16 (Debian) mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze15 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.1$
    [Fri Apr 12 18:18:33 2013] [notice] caught SIGTERM, shutting down
    

    //EDIT: Firefox lädt sich nen wolf.
     
    Zuletzt bearbeitet: 12. Apr. 2013
  4. Timo

    Timo New Member

    Servus,

    habe das problem gefunden der Apache hat andere Module installiert, mit den ISPConfig nicht klar gekommen ist.

    Einfach Apache mit den selben Modulen wie im HowTo noch mal neuinstalliert,
    Kiste rennt wieder.


    Gruß
    Timo
     

Diese Seite empfehlen