Apache2 startet nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von herophil322, 17. Dez. 2012.

  1. herophil322

    herophil322 Member

    Hallo, ich habe vorhin meinen Apache2 neugestartet, jetzt gibt er den
    Syntax error aus:

    apache2ctl configtest

    Syntax error on line 112 of /etc/apache2/sites-enabled/100-example.de.vhost:
    AuthName takes one argument, The authentication realm (e.g. "Members Only")
    Action 'configtest' failed.
    The Apache error log may have more information.

    Ich hab mit jetzt diesen Vhost genauer angeschaut,

    <IfModule mod_dav_fs.c>
    # Do not execute PHP files in webdav directory
    <Directory /var/www/clients/client1/web2/webdav>
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    </FilesMatch>
    </Directory>
    DavLockDB /var/www/clients/client1/web2/tmp/DavLock
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN

    Alias /webdav/ /var/www/clients/client1/web2/webdav/
    <Location /webdav/>
    DAV On
    BrowserMatch "MSIE" AuthDigestEnableQueryStringHack=On
    AuthType Digest
    AuthName ""
    AuthUserFile /var/www/clients/client1/web2/webdav/.htdigest
    Require valid-user
    Options +Indexes
    Order allow,deny
    Allow from all
    </Location>
    # WEBDAV END
    </IfModule>


    </VirtualHost>



    Ich habe auch versucht die <IfModule mod_dav_fs.c> direktive zu entfernen weil webdav hier nicht wirklich benötigt wird, aber obwoll die Zeile 112 nicht mehr exisitiert schreibt der Apache2 Daemon noch immer die selbe Meldung. Hat vielleicht jemand einen Tipp:( ???

    lg herophil
     
  2. herophil322

    herophil322 Member


    Ín den Logs sehe ich nichts von dem Fehler als würde der Apache nun garnichts mehr loggen...
     
  3. nowayback

    nowayback Well-Known Member

    trag bei AuthName in die Anführungszeichen einfach mal Memberarea oder sowas ein und versuch es dann erneut.

    Grüße
    nwb
     
  4. herophil322

    herophil322 Member

    Hab mal Memberarea eingetragen es kommt nach wie vor die selbe Meldung, wie gesagt auch wenn ich diese Anweisung lösche kommt sogar noch die Meldung obwoll sie garnicht mehr vorhanden ist, sehr kommisch. Ich glaube der Apache2 ist tot^^

    lg herophil
     
  5. Laubie

    Laubie Member

    Du hast aber die richtige Datei editiert?
    Ich hab mich am Anfang auch schon mal bei "sites-available" und "sites-enabled" vertan...
     
  6. herophil322

    herophil322 Member

    Nein, habe es unter sites-available editiert, aber durch den Symlink wird es ja sowieso geändert. Ich habe jetzt versucht, unter /etc/apache2/ports.conf/ die Vhost Funktion zu deaktiviern und mit "a2dissite 100-example.de" alleine nur den einen Vhost zu deaktivieren der Probleme macht, aber es kommt immer die selbe Meldung...

    Syntax error on line 112 of /etc/apache2/sites-enabled/100-example.de.vhost:
    AuthName takes one argument, The authentication realm (e.g. "Members Only")
    Action 'configtest' failed.
    The Apache error log may have more information.
     

Diese Seite empfehlen