Autoresponder will nicht funktionieren

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von win_tho, 7. Nov. 2011.

  1. win_tho

    win_tho Member

    Hallo,

    nutze ISPConfig 3.0.4 unter Debian 6 mit Postfix+Dovecot. Geht alles wunderbar, nur die Autoresponder wollen nicht laufen. Habe jetzt schon ergoogelt, dass für einen aktiven Autoresponder etwas unter /var/vmail/mailfilters stehen muss, aber dort ist bei mir nichts zu finden.

    Das Verschieben von Mails mit einem bestimmten Betreff in ein Ordner funktioniert wunderbar.

    Wo kann es noch klemmen?
     
  2. Till

    Till Administrator

    Ist bekannt und steht bereits im Bugtracker.

    Das ist auch gut so, denn würde da was stehen, dann hättest Du den Server falsch konfiguriert. Das Verzeichnis ist nämlich für Courier Server und nicht Dovecot Server.
     
  3. win_tho

    win_tho Member

    Hallo,

    habe eben den RC1 der 3.0.4.1 installier, die Autoresponder gehen jetzt, aber im Betreff steht nur "Out of office replay". Im Ticket im Bugtracker steht jedoch, dass man den Betreff nun frei wählen kann. Kann aber in den EInstellungen kein entsprechendes Feld finden.
     
  4. Till

    Till Administrator

    Der wählbare Betreff ist ein neues Feature von ISPConfig 3.0.5 den der Entwickler im SVN Trunk hochgeladen hat und nicht der Bugfix des Autoresponders für 3.0.4.1 der im SVN Stable branch steht. Bugfix Releases schließen nur Bugs, sie enthalten keine neuen Funktionen.
     
  5. hanzfranz

    hanzfranz New Member

    Autoresponder funktioniert nicht nach Update auf 3.0.4.3

    Leider funktioniert der Autoresponder nach dem Update auf 3.0.4.3 nicht mehr. Es werden beim Aktivieren des Autoresonders unter /var/vmail/mailfilters/meinedomain.de/user zwar die beiden Dateien *.autoresonder und *.vacation.msg angelegt, es wird aber keine Nachricht verschickt.

    Was mich noch wundert ist, dass die Logdatei unter /var/log/ispconfig/ispconfig.log auch leer ist.

    Der Autoresponder hat vor dem Update funktioniert.
     
  6. hanzfranz

    hanzfranz New Member

    Heute funktioniert der Autoresponder!! Scheinbar wird er aber nicht zur angegebenen Zeit gestartet.

    Nun liegen in dem Ordner auch zwei weitere Dateien .vacation.lst.lock und .vacation.lst.gdbm

    In der MYSQL Datenbank wir unter mail_user auch der Autoresponder Text, die Start und Endzeit richtig eingetragen.

    Ich habe jetzt einen weiteres Test Mailkonto angelegt. Hier das selbe Problem. Das Konto wird korrekt angelegt, der Autoresponder funktioniert aber eine Stunde später immer noch nicht.
     
  7. Till

    Till Administrator

    Dann schau mal nach ob im Linux System und in der ispconfig config.inc.php die gleiche Zeitzone eingestellt ist.
     
  8. hanzfranz

    hanzfranz New Member

    Debian Squeeze zeigt folgendes an:

    Current default time zone: 'Europe/Berlin'
    Local time is now: Mon Feb 27 10:47:18 CET 2012.
    Universal Time is now: Mon Feb 27 09:47:18 UTC 2012.

    Unter /usr/local/ispconfig/interface/lib/conig.inc.php steht folgendes:

    /** Default Language and Timezone
    $conf['language'] = 'de';
    $conf['debug_language'] = false;
    $conf['timezone'] = 'UTC';

    Und unter /usr/local/ispconfig/server/lib/conig.inc.php steht folgendes:

    /** Default Language and Timezone
    $conf['language'] = 'de';
    $conf['debug_language'] = false;
    $conf['timezone'] = 'UTC';

    Muss hier in beiden Dateien
    $conf['timezone'] = 'CET';
    eingetragen sein?
     
  9. Till

    Till Administrator

    Trag bitte mal Europe/Berlin auch als Zeitzone in beiden ISPConfig Dateien ein.
     
  10. hanzfranz

    hanzfranz New Member

    Also so?

    $conf['timezone'] = 'Europe/Berlin';</strong>

    und nicht so?

    $conf['timezone'] = 'CET';</strong>
     
  11. hanzfranz

    hanzfranz New Member

    Sorry, copy und paste Fehler. meinte natürlich

    $conf['timezone'] = 'Europe/Berlin';
     
  12. hanzfranz

    hanzfranz New Member

    Hat geklappt.:)

    Gibt es eigentlich auch schon eine Lösung den Autoresponder Text in der Antwortmail über der dem eigentlichen Mailtext anzuzeigen? Im Moment wird immer erst die Mail zitiert und darunter erscheint der Antworttext. Gerade bei langen Mails ist das nicht gut, da man den eigentlich wichtigen Autoresponder Text erst am Ende der Mail findet.
     
  13. Till

    Till Administrator

    Verwendest Du Courier oder Dovecot?
     
  14. hanzfranz

    hanzfranz New Member

    Ich verwende Courier
     
  15. hanzfranz

    hanzfranz New Member

    Ich verwende Courier und Maildrop
     
  16. Till

    Till Administrator

    Du könntest versuchen das autoresponder.master script zu ändern auf dem neue autoresponder von courier basieren. Die Vorlage dazu findest Du in /usr/local/ispconfig/server/conf/

    Die Optionen zu mailbot stehen z.B. hier:

    Man page of MAILBOT

    Du könntest z.B. mit der Option:

    -T 'forwardatt'

    das Programm anweisen, dass die Originalnachricht angehängt wird.
     
  17. hanzfranz

    hanzfranz New Member

    Also wenn ich die autoresponder.master so ändere, arbeitet der Aotorespnder leider gar nicht mehr:

    ....
    # The following must be one contiguous line
    cc "| mailbot -t $RESPOND -d $RESPONDDB -c 'UTF-8' -T 'forwardatt' -D 1 \
    -A 'From: $RECIPIENT' -s 'Auto Response: from $RECIPIENT' \
    /usr/sbin/sendmail -t -f ''"
    ....

    Der original Eintrag sieht bei mir so aus:

    `test -f {vmail_mailbox_base}/mailfilters/$HOST/$USER/.vacation.msg && exit 1 || exit 0`
    if ($RETURNCODE==1)
    {
    {
    if (!/^List-Unsubscribe:.*/:h )
    {
    if (!/^X-Spam-Flag: YES/:h )
    {
    NOW=time
    if ({start_date} lt $NOW && {end_date} gt $NOW)
    {
    RESPOND="{vmail_mailbox_base}/mailfilters/$HOST/$USER/.vacation.msg"
    RESPONDDB="{vmail_mailbox_base}/mailfilters/$HOST/$USER/.vacation.lst"

    # The following must be one contiguous line
    cc "| mailbot -t $RESPOND -d $RESPONDDB -c 'UTF-8' -D 1 \
    -A 'From: $RECIPIENT' -s 'Auto Response: from $RECIPIENT' \
    /usr/sbin/sendmail -t -f ''"
    }
    }
    }
    }
    }
     

Diese Seite empfehlen