AWstats und Aktualisierung

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von TDS, 25. Okt. 2010.

  1. TDS

    TDS New Member

    Hallo,
    nach dem neuen Update gibt es ja AWstats. Davor hatte ich die Lösung mit dem Plugin welche man auch hier im Forum findet.
    Doch jetzt werden die Statistiken nicht richtig generiert:

    Day Number of visits Pages Hits Bandwidth
    21 Oct 2010 1 78 79 41.06 KB
    22 Oct 2010 1 78 78 34.99 KB
    23 Oct 2010 1 78 79 42.65 KB
    24 Oct 2010 1 78 78 36.25 KB


    Nur noch 1 Besucher pro Tag.

    Lasse ich cron_daily.sh manuell laufen, dann kommt so was:
    25 Oct 2010 20 2408 3127 13.23 MB

    An was kann das liegen?
     
  2. Quest

    Quest Member

    Naja, das Skript wertet ja nur für den letzten Tag die Logfiles aus und nicht alle zurückliegenden.
    Deine Ausgabe zeigt auch nicht 1 Besucher, sondern 20 Besucher für den 25.10.
    Nur wie gesagt, es werden nur die Logs für den jeweiligen Tag von der cron_daily abgearbeitet.
     
  3. TDS

    TDS New Member

    Das ist mir schon bewusst. Nur wird jeden Tag nur 1 Besucher ausgegeben obwohl nachweislich mehrere online waren. Mit der Plugin-Lösung hat es ja geklappt. Nur mit dem eingebauten AWStats-Modul der neuesten Version gibt es Probleme.
     
  4. Till

    Till Administrator

    Redest Du jetzt über ISPConfig 2 oder 3?
     
  5. TDS

    TDS New Member

    Ich rede über ISPConfig 3.0.3.
    Dort hatte ich erst von http://www.emperor-it.com/component/content/article/38-ispconfig3/56-ispconfig3-awstats.html das Plugin genutzt (<3.0.3).

    Jetzt ist ja AWStats integriert und ich habe es rausgenommen und für den Kunden AWStats anstatt Webalizer aktiviert. Jedoch ist immer nur 1 Visit verzeichnet.
    [​IMG]

    Wenn ich den daily cron separat aufrufe dann nimmt er das heutige Datum. Ich denke hier liegt das Problem. Wenn z.B. um 0.10Uhr ISPConfig die Statistiken aktualisiert, dann gibt es nur einen Visit (den durch den Cron selbst).
     
  6. Till

    Till Administrator

    Vermutlich wurde das alte plugin nicht vollständig entfernt. Denn die awstats Statistiken laufen auf allen meinen Systemen einwandfrei und komplett. Ich denke mal bei Dir läuft noch ein 2. awstats job, der die Statistiken durcheinader bringt. Sieh am besten mal alle Cronjobs durch.
     
  7. TDS

    TDS New Member

    Hmm, awstats hatte unter /etc/cron.d/ einen Job angelegt (Datum: 10/2008). Der Cron war voher nicht da. Evtl. durch ein Systemupgrade dazu gekommen. Den hab ich jetzt erstmal entfernt. Mal gucken was morgen rauskommt.
     
  8. TDS

    TDS New Member

    So, alles von awstats ist gelöscht was nicht rein gehört.
    Problem besteht jedoch weiterhin. Nur 1 Visitor. Führe ich gegen mittags manuell den Befehl aus, dann kommen zwischen 10 und 20 Visitors.

    Aus diesem Grund denke ich das der Fehler darin besteht das AWStats nicht den letzten, sondern den aktuellen Tag nimmt. Wahrscheinlich ist das durch die Logrotation eine neue access.log erstellt wurde und die alte bereits als .gz existiert. Somit wird der daily cron nur ein Visitor haben da max. der Cronjob auf der HP auf die Seite zugegriffen hat.

    //edit:
    Habe jetzt die SVN-Version installiert da dort die AWStats-Config pro Domain neu geschrieben wird falls nicht vorhanden.
    Hab eine alte mit der neuen config verglichen und dort stehen komplett andere Werte drin. Das waren die Überbleibsel von dem AWStats-Plugin.
    Mal gucken ob morgen aktualisierte Stats vorhanden sind.

    PS: Hab auch nen Bugreport zum Installer respektive zur Remote-Klasse gepostet.
     
    Zuletzt bearbeitet: 27. Okt. 2010
  9. TDS

    TDS New Member

    Die Statistiken werden nicht neu generiert :(
    Wer kann helfen bzw. seine Configs zum Vergleich posten :confused:
     

Diese Seite empfehlen