Der [Fast] Perfekte Server

#1
Leider nur Fast denn ich habe immernoch ein paar kleinigkeiten die ich selbst leider nicht fixen kann zum Perfekten Server, bzw. dinge die mir nicht gelungen sind und so hoffe ich das ich mein kleines Problemchen sammelsorium hier stück für stück erledigen kann wenn ich es Ordentlich zusammenfasse. Natürlich habe ich nach jedem Problem gegooglet und es auch schon probiert zu lösen. Der Server ist ein Debian - Squeeze Server mit Postfix, Fail2ban, Dovecot...

1. ISPConfig absichern mit einer .htaccess
Die Schritte habe ich unternommen wie hier beschrieben ISPc3 mit .htaccess sichern - Howtoforge Forum
Doch leider taucht keine .htaccess auf, auch die logs sind leer.

2. Munin Spammt mir den Access log mit Apache Mod Status voll
127.0.0.1 - - [07/Apr/2013:06:25:02 +0000] "GET /server-status?auto HTTP/1.1" 200 617 "-" "libwww-perl/5.836"
127.0.0.1 - - [07/Apr/2013:06:25:02 +0000] "GET /server-status?auto HTTP/1.1" 200 617 "-" "libwww-perl/5.836"
127.0.0.1 - - [07/Apr/2013:06:25:03 +0000] "GET /server-status?auto HTTP/1.1" 200 616 "-" "libwww-perl/5.836"
Das ist natürlich eine unschöne angelegenheit und ich würde gerne den Mod Status davon abbringen die internen Dummy verbindungen nicht zu loggen, leider funktionierte das bisher nicht für die access.log

Ich habe hierfür schon folgendes eingebaut.
SetEnvIf Remote_Addr "127\.0\.0\.1" dontlog
SetEnvIf Remote_Addr "::1" dontlog
SetEnvIf User-Agent ".*internal dummy connection.*" dontlog
CustomLog /var/log/apache2/other_vhosts_access.log vhost_combined env=!dontlog
Dieses gilt jedoch nicht für die access.log doch wenn ich dieses dort anfüge ist die configuration hinüber.:(

3. Fehlermeldung No virtual Host GELÖST
[Wed Apr 17 03:57:40 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Wed Apr 17 03:57:40 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
Dieses tritt auch nach dem neustart von Apache auf. Ich denke es handelt sich dabei um das Standard Web-Directory welches erreichbar ist über die IP Adresse. Wenn es geht würde ich gerne komplett darauf verzichten.

4. ::1 Adress not listed for localhost
Apr 17 02:05:02 z110 postfix/smtpd[6856]: warning: ::1: address not listed for hostname localhost
Dieses finde ich ziemlich oft in den logs, habe da schon versucht an Postfix zu basteln um dieses loszuwerden jedoch ohne erfolg.



Ja dieses wären zur Zeit meine Sorgen.
Ich bin dankbar für Jede Hilfe und würde natürlich Ergebnisse und Lösungen sofort hier addieren sofern ich sie finde.
 
Zuletzt bearbeitet:
#2
#3
Hallo D.Hoffmann

Danke dir für den Tipp. Das hat den Fehler wirklich behoben der Access Log sieht nun sauber aus.

Die anderen bestehen leider trotzdem auch die Tipps des anderen Threads haben bei Postfix leider das Problem nicht gelöst =(

Aber immerhin einer weniger hehe :p
 

Werbung

Top