Der perfekte Server - Debian Etch (4.0) - Seite 5 "saslauthd start" problem

#1
Der perfekte Server - Debian Etch (4.0) - Seite 5 / 250-AUTH PLAIN fehlt

Moin Moin,
Ich bin an dem Punkt "/etc/init.d/saslauthd start"
dann kommt allerdings die fehlermeldung :

/etc/default/saslauthd: line 38: -m: command not found

und ich kann mir nicht erklären warum ???
 
Zuletzt bearbeitet:
#2
habe den fehler selbst gefunden DENKE ich :
wenn ich bei dem satz die leerzeichen weg lasse geht es:
OPTIONS=”-c -m /var/spool/postfix/var/run/saslauthd -r”

aber nun folgt der nächste fehler:confused:
bei der eingabe von:
telnet localhost 25

und dann:
ehlo localhost
fehlt mir die anzeige :
250-AUTH PLAIN LOGIN

meine Anzeige sieht so aus:
Code:
ehlo localhost
250-debian-server.xxxx
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.
kann da ein Spetzi helfen?
 

Till

Administrator
#3
Du darfst die Leerzeichen bei OPTIONS=”-c -m /var/spool/postfix/var/run/saslauthd -r” nicht weglassen! Das Howto ist zu 100% korrekt und getestet, also nichts abweichend modifizieren sonst funktioniert es nicht!
 
#4
Hmm... und warum bekomme ich dann eine fehlermeldung ??? wenn ich die Leerzeichen lasse!

genauso wie an diesen Punkt:
Code:
Als nächstes dieses eingeben:
 postconf -e ’smtpd_sasl_local_domain =’
postconf -e ’smtpd_sasl_auth_enable = yes’
postconf -e ’smtpd_sasl_security_options = noanonymous’
postconf -e ‘broken_sasl_auth_clients = yes’
postconf -e ’smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination’
postconf -e ‘inet_interfaces = all’
echo ‘pwcheck_method: saslauthd’ >> /etc/postfix/sasl/smtpd.conf
echo ‘mech_list: plain login’ >> /etc/postfix/sasl/smtpd.conf
hier ging es auch nur wenn ich die Leerzeichen weggelassen habe ???
 

Till

Administrator
#5
Achte bitte auf die korrekten Anführunszeichen. Es muss heißen:

postconf -e 'smtpd_sasl_local_domain ='

und nicht:

postconf -e ’smtpd_sasl_local_domain =’
 
#6
hi,
ich habe dasselbe Problem:
ehlo localhost
250-Rosengarten
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye

kein 250 AUTH wird angezeigt.
und ich musste auch die Leerzeichen vor und nach dem = entfernen, sonst gings nicht# und ich habe die richtigen Anführungszeichen verwendet!
HILFE!
 
#7
Rosengarten:/etc/postfix/ssl# openssl rsa -in smtpd.key -out smtpd.key.unencrypted
Enter pass phrase for smtpd.key:
writing RSA key
Rosengarten:/etc/postfix/ssl# mv -f smtpd.key.unencrypted smtpd.key
Rosengarten:/etc/postfix/ssl# openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 3650
Generating a 1024 bit RSA private key
....................++++++
......................................................................++++++
writing new private key to 'cakey.pem'
Enter PEM pass phrase:
Verifying - Enter PEM pass phrase:
-----
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [AU]:GE
State or Province Name (full name) [Some-State]:xxxx
Locality Name (eg, city) []:xxxxxx
Organization Name (eg, company) [Internet Widgits Pty Ltd]:xxxx
Organizational Unit Name (eg, section) []:
Common Name (eg, YOUR name) []:xxxx
Email Address []:xxxxxx
Rosengarten:/etc/postfix/ssl# postconf -e ‘myhostname = Rosengarten’
postconf: fatal: missing '=' after attribute name: "???myhostname"
Rosengarten:/etc/postfix/ssl# postconf -e ‘myhostname=Rosengarten’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_auth_only= no’
postconf: fatal: missing '=' after attribute name: "no???"
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_auth_only=no’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtp_use_tls=yes’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_use_tls=yes’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtp_tls_note_starttls_offer=yes’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_key_file=/etc/postfix/ssl/smtpd.key’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_cert_file=/etc/postfix/ssl/smtpd.crt’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_CAfile=/etc/postfix/ssl/cacert.pem’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_loglevel=1′
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_received_header=yes’
Rosengarten:/etc/postfix/ssl# postconf -e ’smtpd_tls_session_cache_timeout=3600s’
Rosengarten:/etc/postfix/ssl# postconf -e ‘tls_random_source=dev:/dev/urandom’Rosengarten:/etc/postfix/ssl# cat /etc/postfix/main.cf
 

Till

Administrator
#8
Versuche Dich mal mit einem mail client per smtp-auth zu verbinden, wenn das nicht geht dann poste bitte dei Fehlermeldungen aus dem mail log.
 

Werbung

Top