DNS Eintrag Zonenverwaltung Records

#1
Hallo,

Zuerst einmal zu meinem System, Debian Lenny, Ispconfig 3.0.1.1.

Das System läuft und lies sich auch ohne Problme installieren, es ist ein privates Netzwerk, demzufolge auch private addressen, der Server hat die IP 192.168.178.80, der Name ist debian.home.lan.

Ich kann Ihn aber im Browser nicht mit http://debian.home.lan:8080 und auch nicht mit http://debian.home.lan ansprechen, auf meine anderen Rechenern ist der Server als zweites DNS eingetragen, hab auch mal getauscht, also erster und zweiter DNS, geht auch nicht.

Die Server IP ist in den Einstellungen von ISPconig auch korekt zugeorndnet. Unter der IP ist er ansprechbar, port 80 und 8080 auch.(also debian.home.lan ist mit der IP verknüpft)

Kunden anlegen geht auch ohne Problem, Web anlegen auch, E-Mail auch, mach ich nun für einen Kunden eine FQDN lege eine Domain an zb test.neu.lg machen einen A-Record eintrag, und weiße die IP zu, also 192.168.178.80, lässt sich alles machen, nur über FQDN ( test.neu.lg) komme ich nicht zu den Kunden Web.

ftp, ssh komm ich mit den Kunden login drann.

Ich verzweifel bald:gg wo liegt mein Fehler? wäre nett wenn mir jemand ein paar Tips gegeben würde oder mich aus meiner Denkblockade raus holen würde.

MfG zoschel
 
Zuletzt bearbeitet:

Till

Administrator
#2
Dir fehlt ganz einfach ein DNS Record für debian.home.lan. Das geht am einfachsten indem Du auf Deiner Workstation (nicht dem Server) die hosts Datei modifizierst und eine Zeile wie:

192.168.178.80 debian.home.lan

einfügst.
 
#3
Hallo Till,

danke für Deine Antwort. Ja es ginge schon mit dem editieren der hosts Datei auf den Workstation, das wäre sicherlich ein Lösung, ist aber nicht Sinn des ganzen, schließlich läuft ja ein DNS Server im Netz und dieser ist in der resolve.conf auf den Clients eingetragen, als zweiter
"nameserver 192.168.178.80".

Folgendes habe ich in ISPconfig eingestellt.
add a new zone

server debian.home.lan
client -------- hab ich frei gelassen--- "oder muss ich einen extra Client für den reinen Server angeben?"

Zone (SOA) home.lan

NS ns.debian.home.lan "oder sollte hier nur debian.home.lan rein?"

Email webmaster.home.lan

Allow zone transfers to these IPs --- leer---

Aktivate yes

Das mal zu der Zone

jetzt Records

DNS A

Hostname debian.home.lan
IP Adresse 192.168.178.80
TTL
Aktiv yes


NS

Zone home.lan
Nameserver Hostname debian,home.lan
TTL
Aktiv yes

Also sollte doch wenn mein Debian Server mit ISPconfig im Netz als DNS-Server fungieren, oder?

Zum ersten Test Kunden,

Kunde angelegt, Web angelegt

Server debian.home.lan
Kunde ralf
IP-Adresse 192.168.178.80
Domain ralf.neu.tdl
Harddisk Quota
CGI


SSI


SuEXEC


Eigene Fehlerseiten




Auto-Subdomain *.
SSL


PHP Disabled Fast-CGI CGI Mod-PHP SuPHP
Aktiv

Dann noch den den Record A Eintrag gemacht unter der Zone home.lan

Das Web wurde angelegt ftp user ssh user auch für diesen Kunden, man kommt auch per sft, ftp, ssh in diesen kundebreich.

Rein theortisch müsste ich doch jetzt auf das Kunden Web kommen mit http://ralf.neu.tdl, oder mit http://debian.home.lan auf die Serverseite des Server.
Der Apache sollte doch vhost machen wenn ich das alles so eintrage, eine ip aber verschiedene Domains.

Update.

[Tue May 19 07:59:03 2009] [warn] NameVirtualHost 192.168.178.80:80 has no VirtualHosts
[Tue May 19 07:59:03 2009] [warn] NameVirtualHost 192.168.178.80:443 has no VirtualHosts

das steht im icpc Protokoll


Ich hoffe es ist nicht zu viel Text, wenn ja sorry

Danke schon mal im voraus:) mf zoschel
 
Zuletzt bearbeitet:

Till

Administrator
#4
Du hast die Punlte am Ende der Zonendefinition vergessen, daher kann die Domain auch nicht aufgelöst werden. Benutz mal den DNS Wizard zum anlegen der Domäne, damit Du ein Beispiel für einen Korrekten Record hast.
 
#5
Dns

Hallo Till,

die Punkte am Ende der Zonen (SAO) Einträge sind vorhanden, entschuldige bitte das ich sie nicht mit gepostet habe, copy and paste hat warschscheinlich nicht richt gefunzt.

Ich würde Dir gerne ein Video zukommen lassen, ich werde es auf einen Filehoster legen, wäre sehr nett wenn Du es Dir anschauen würdest, denn ich möchte unbedingt IPSconfig demnächst produktive einsetzten, weil ich finde es ist eine gelungene Software, tolle Arbeit die Ihr da gemacht habt.

Mfg Zoschel

Update
/etc/init.d/openbsd-inetd restart

ist das einzigste was mir bei der Installation auffällt das sich dieser Dienst nicht starten lässt
 
Zuletzt bearbeitet:

Till

Administrator
#6
Ich würde Dir gerne ein Video zukommen lassen, ich werde es auf einen Filehoster legen, wäre sehr nett wenn Du es Dir anschauen würdest, denn ich möchte unbedingt IPSconfig demnächst produktive einsetzten, weil ich finde es ist eine gelungene Software, tolle Arbeit die Ihr da gemacht habt.
Sorry, aber ich mache keinen individuellen Support außerhalb des Forums kostenlos. Wenn Du kommerziellen Support möchtest, dann schau mal auf die ispconfig Website unter support da findest Du aich die Kontakt Emailadresse.

Update
/etc/init.d/openbsd-inetd restart

ist das einzigste was mir bei der Installation auffällt das sich dieser Dienst nicht starten lässt
Das ist auch richtig so, der wird in einem ispconfig setup nicht verwendet.
 
#7
Dns

Hallo Till,

Danke für deine Antwort, gut den Support werde ich dann natürlich in Anspruch nehmen, das ist kein Thema sobald der Server produktiv arbeitet.

Ich bin mir nur im moment etwas sehr Ratlos warum der DNS-Server einfach nicht auflöst, die IP stimmt zum Server, die Installation verlief von insgesamt 6 Versuchen immer ohne Fehler, Dienste laufen auch alle, Updates kann ich auch machen, Zonen (SAO) werden auch anglegt, Record einträge auch, Kunden und Webs auch, Vhost sind enabled, E-Mail Server funzt auch usw usw...., nur die Namen löst er nicht auf.
Ich werde jetzt noch mal einen Versuch machen, wenn nicht nehm ich die V2, da weiß ich das es geht. Irgendwo muss ein Fehler sein, nur wo?

MfG zoschel
 

Werbung

Top