dovecot nachträglich installiert --> problem mit filter

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von closed, 7. Okt. 2010.

  1. closed

    closed New Member

    hi @all,

    erstmal vielen dank für die geilen tutorials. die habens echt gebracht bisher.

    leider hatte ich ein problem mit dem courier und musste auf dovecot wechseln. (problem bestand beim anlegen von mailboxen, die auf der gleichen ebene, wie die inbox sein sollten). die authentifizierung mit den useraccounts funktioniert derzeit auch schon echt super. ich hab allerdings noch ein problem mit den filterregeln. diese werden in die db eingetragen, greifen aber nicht.

    hat vlt. irgendwer erfahrung damit bzw kann mir jemand seine konfigs zusenden, mit denen die filterregeln greifen? bin derzeit etwas ratlos und weiß nicht wie ich das ans laufen bekomme.

    vielen dank
     
  2. closed

    closed New Member

    nach längerem hin und her hab ichs jetzt zumindest mal geschafft, dass sieve akzeptiert wird und auch filtert.

    dabei sit mir folgendes aufgefallen:
    ispconfig erstellt den mailfilter in der datenbank. für sieve scheint der aber falsch zu sein. da stimmt die syntax einfach nicht.

    wenn ich die datei selbst erstelle und ins mail folder reinlege, dann funktionierts. die frage ist jetzt: wie macht ispconfig das normalerweise? erstellt ispconfig die .sieve dateien normalerweise selbst im mailfolder? muss ich irgendwo irgendwas an ispconfig in den config files ändern?


    danke für die hilfe
     
  3. Till

    Till Administrator

    Welche ISPConfig version nutzt Du denn? Habe sieve in ispconfig 3.0.3 getestet und die Filter siund definitiv korrekt.

    Ich hoffe Du hast Bei Deiner Umstellung auch beachtet die mailfilter sysntax von maildrop auf sieve in der server config in ISPConfig umzustellen?
     
  4. closed

    closed New Member

    ja das hatte ich alles genutzt, aber ispconfig hat das fiel ohne den "require" tag angelget. das konnte nciht funktionieren.

    Die Lösung ist jetzt folgende: Update eingespielt (das ist ja zum Glück vorgestern erschienen), alle Dienste von ISPConfig neu konfigurieren lassen und danach die Dienste wieder angepasst.

    War ein elendiger Kraftakt, aber jetzt funktioniert ISPConfig mit dovecot und sieve. Es ist wirklich klasse und ich bin total begeistert. Die Mühe hat sich total ausgezahlt

    Dank dir trotzdem Till
     

Diese Seite empfehlen