E-Mail Versand vom Root Möglich, E-Mail Empfang aber nicht!

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von toca, 17. Aug. 2008.

  1. toca

    toca New Member

    Inhalt gelöscht
     
    Zuletzt bearbeitet: 29. Nov. 2011
  2. toca

    toca New Member

    ich glaube die Nachricht um die es geht steht konkret in meiner failure notice von GMX:

    <web5_toca@maxxshare.com>:
    195.34.175.199_does_not_like_recipient./Remote_host_said:_553_sorry,_that_domain_isn't_in_my_list_of_allowed_rcpthosts_(#5.7.1)/Giving_up_on_195.34.175.199./


    daraus verstehe ich, das mein Server die GMX Server nicht als Mail Versender akzeptiert...oder? Nur wo kann ich es änderen das fremde User und den usern auf meinem Server E-Mails schicken können? Kann ja net sein das große anbieter wie gmx grundsätzlich geblockt werden
     
  3. Till

    Till Administrator

  4. toca

    toca New Member

    ja hat sie
     
  5. Till

    Till Administrator

    Und maxxshare.com ist in der datei
    /etc/postfix/local-host-names aufgelistet?
     
  6. toca

    toca New Member

    jo die Hauptdomain sowie Subdomains sind darin eingetragen
    Ich hatte auch ganz vergessen das die MX Einträge über den Server eines Kumpels laufen,
    der mir damit wohl auch etwas arbeit abnimmt. Er sagte mir er hat jetzt die MX Einträge auf meinen
    Server umgeleitet, doch wenn ich mir eine E-Mail an meinen Server schreibe kommt:

    Code:
    This is the mail system at host ks358293.kimsufi.com.
     
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
     
    For further assistance, please send mail to postmaster.
     
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
     
    The mail system
     
    <[EMAIL="web5_toca@stock.ovh.net"][COLOR=#0000ff]web5_toca@stock.ovh.net[/COLOR][/EMAIL]> (expanded from <[EMAIL="toca@maxxshare.com"][COLOR=#0000ff]toca@maxxshare.com[/COLOR][/EMAIL]>): Host or domain
    name not found. Name service error for name=stock.ovh.net type=A: Host
    found but no data record of requested type
    
     
    Zuletzt bearbeitet: 20. Aug. 2008
  7. toca

    toca New Member

    und zusätzlich habe ich jetzt nochmal genau kontrolliert..
    also in dem Web des Webspaces steht bei Domain nicht www.maxxshare.com sondern "maxxshare.com" mit hostname www und bei Weiterleitung steht ebenfalls nur "maxxshare.com", dort aber ohne hostname.

    wenn ich jetzt aber Domain auf www.maxxshare.com stelle statt nur maxxshare.com, kommt die Fehlermeldung:

    Code:
    [FONT=Helvetica, Arial][SIZE=3][COLOR=#ffffff][B]Geteilte IP-Adresse[/B][/COLOR][/SIZE][/FONT]
    
    [FONT=Helvetica, Arial][SIZE=2][COLOR=#000000]
    Diese IP-Adresse wird mehrfach genutzt. Um die gew?e Website zu erreichen, geben Sie ihre Domain anstelle der IP-Adresse in der Adresszeile des Browsers ein.[/COLOR][/SIZE][/FONT]
    [FONT=Helvetica, Arial][SIZE=2][COLOR=#000000]Bei Fragen oder Problemen wenden Sie sich bitte an den Server-Administrator.[/COLOR][/SIZE][/FONT]
    
    mein Login läuft auch über maxxshare.com, adresszeile ist:
    https://www.maxxshare.com:81
    ruft das vielleicht den IP Konflikt hervor? Weil du sagst ja das bei Domain soll die adresse mit "www" angegeben sein, und bei Co-Domain, ohne dem "www" davor. Sobald ich dies mache gibts einen IP Konflikt.
     
  8. Till

    Till Administrator

    Das ist korrekt und exakt so muss es sein. mache bitte die anderen Änderungen rückgangig, die Fehler die Du erhalten hast iegen an den Änderungen, es ist kein IP konflikt.
     
  9. toca

    toca New Member

    Ich habe die Änderungen auch gleich Rückgängig gemacht, nur stellt sich nun natürlich immernoch die Frage woran es hängen könnte das die E-Mails offenbar nicht korrekt an den Mailserver weitergeleitet werden... der Host wird laut der E-Mail Rückmeldung zwar allem Anschein nach erkannt, doch wird die E-Mail intern wohl nicht richtig weitergeleitet, oder?
     
  10. Till

    Till Administrator

    Installier bitte mal eines der Webmail Pakete auf Deinem ISPCOnfig Server und schock Dir dann selbst eine mail, um zu sehen ob sie ankommt.
     
  11. vzcrsa

    vzcrsa New Member

    guten morgen till, mit den mail habe ich das gleiche problem, schicken kann ich aber empangen nichts , folgende meldung komm zurück :

    This is the mail system at host server1.example.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <VPS14_xxx.de@server1.example.com> (expanded from <info@xxx.de>): unknown
    user: "vps14_xxx.de"
    Reporting-MTA: dns; server1.example.com
    X-Postfix-Queue-ID: 2C6B15B0A0D
    X-Postfix-Sender: rfc822; xx@xxx.de
    Arrival-Date: Wed, 27 Aug 2008 23:26:40 +0200 (CEST)

    Final-Recipient: rfc822; VPS14_xxx.de@server1.example.com
    Original-Recipient: rfc822;info@xxx.de
    Action: failed
    Status: 5.1.1
    Diagnostic-Code: X-Postfix; unknown user: "vps14_xxx.de"
     
    Zuletzt bearbeitet: 28. Aug. 2008
  12. Till

    Till Administrator

    Das Problem ist vermutlich, dass Dein User große und kleine Buchstaben enthält. Stell bitte Dein Usernamen Prefix auf Kleinbuchstaben um, lösche den User und lege dann den User neu an.
     
  13. vzcrsa

    vzcrsa New Member

    oh löschen nee dann sind die seiten der kunden weg und das kann ich nicht machen , gibt es eine andere lösung
     
  14. Till

    Till Administrator

    1) Den Prefix musst Du auf jeden Fall ändern, damit wenigstens neue User korrekt sind.

    2) Du kannst versuchen (ber erstmal nur bei einem Test-User), die Groß / Kleinschreibung von Hand zu korrigieren, und zwar in:

    /etc/passwd
    /etc/shadow
    /etc/group
    /etc/gshadow
    /etc/postfix/virtusertable

    Dann in der ISPConfig DB den Eintrag in der Tabelle isp_isp_user

    Dann versuch nochmal, eine Mail an diesen User zu schicken.
     
  15. vzcrsa

    vzcrsa New Member

    so bei denen die noch nichts drau und drin haben habe ich es jetzt gemacht und dort einen fehler erhalten :Sie haben bereits einen User mit dem Namen vps8_xxx.de angelegt.
    Es existiert bereits ein User mit dieser Emailadresse.
    Es existiert bereits ein User mit Administratorrechten in diesem Web.

    obwohl dieser gelöscht wurde und in klein neu angelegt werden soll.

    alle papierkörbe sind leer !!
     
  16. vzcrsa

    vzcrsa New Member

    das problem wurde behoben, habe den user aus der db gelöscht jetzt geht es: vps8_xxx.de wurde korekt angelegt

    danke für die schnelle hilfe
     
  17. Till

    Till Administrator

    Bitte nichts direkt in der DB löschen, Du hast jetzt vermutlich die Datenitegrität zerstört, da jetzt noch abhängige Einträge in den Tabellen isp_dep und isp_nodes existieren. Dass kann später zu problemen führen, wie z.B. dass User an falsche Webs gehängt werden oder Emailadressen in postfix auf den aflschen User umgebogen werden.
     
  18. vzcrsa

    vzcrsa New Member

    schein aber gut gegangen zu sein, zumiendest läuft alles so wie es soll :eek::cool::)

    oha doch nicht - mails können nicht empfangen werden !

    scheiss und jetzt ? möchte webspace nicht löschen müssen - emails löschen egeal aber webspace nicht
     
    Zuletzt bearbeitet: 28. Aug. 2008
  19. Till

    Till Administrator

    Exakte Fehlermeldung?

    Webspace muss auch auf keinen Fall gelöscht werden, höchstens die User. Problem ist aber, nachdem die Einträge manuell entfernt wurden, kann ISPConfig die verbliebenen "Reste" bicht mehr selber löschen. Du hast Dir nicht zufällig die doc_id nummern der gelöschten Einträge aufgeschrieben?
     
  20. vzcrsa

    vzcrsa New Member

    nein das habe ich nicht ! müste aber 1017 sein weil 1016 hat ein andere user und 1018 ist für vps8_xxx.de neu vergeben worden

    wie bekomme ich das jetzt wieder hin ist nur bei dem einem user
     
    Zuletzt bearbeitet: 28. Aug. 2008

Diese Seite empfehlen