Eigene DNS Server (Primär und Sekundär) mit ISPConfig 3 aufsetzen (Debian Squeeze)

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von mh_, 6. Feb. 2012.

  1. mh_

    mh_ New Member

    Tutorial:
    http://www.howtoforge.de/anleitung/eigene-dns-server-primar-und-sekundar-mit-ispconfig-3-aufsetzen-debian-squeeze

    Problem:
    Die Installation verlief auf 2 Servern ohne jegliche Probleme.
    Gehalten habe ich mich an jegliche Schritte, jedoch besteht ein Problem.
    Die Sache ist die, dass es eigentlich fast egal ist nach welchen Tutorial ich mich richte, da sie eigentlich alle nur Feinheiten beinhalten und die einzelnen Programme anders konfiguriert sind.
    Folgendes; richte ich auf dem Hauptserver eine Zone, Website oder sonstiges an, wird die ganze Geschichte immer auf dem zweiten Server geadded, der ja eigentlich nur rein der NS-Replikation dienen sollte. Auch habe ich schon versucht mal mehr und mal weniger Dienste auf dem zweiten Server zu installieren. Ich bekomme es einfach nicht hin ihm klar zu machen dass es auf den ersten Server gehoert. FTP-Accounts funktionien bisweilen auch gleich mal gar nicht. Egal ob ich es da bei Server 1 oder 2 versuche. Im Tutorial steht selbst dass zum Beispiel TLS laufen muesste. Tatsache ist aber, dass ich staendig gesagt bekommen dass diese Methode nicht implementiert ist.
    Also, eine ganze Reihe von Probleme die mich da beschaeftigen, hat jemand vielleicht einen Rat warum alles auf dem zweiten Server geadded wird, anstatt auf dem Ersten? (Es steht ja ausdruecklich immer der erste Server in der Auswahl - in den Hosts stehen die IPs auch nich falsch drin zu den Hostnames..)
     
  2. Till

    Till Administrator

    Das Tutorial das Du verwendet hast ist für reine DNS Server, es kann also auf den Servern keine mailkonten oder websites geben. Wenn Du doch welche anlegst, dann werden deise natürlich mit gespiegelt. Denn das was Du gemacht hast entspricht eher diesem Tutorial:

    Installing A Web, Email And MySQL Database Cluster (Mirror) On Debian 5.0 With ISPConfig 3 | HowtoForge - Linux Howtos and Tutorials

    anstatt einem ns mirror.

    Mit anderen Worten, Du hast bei Dir ein vollständiges Mirror setup gemacht und eben keinen DNS only mirror und genauso verhält sich Dein System auch. Es funktioniert also alles einwandfrei und so wie es zu erwarten ist, wenn man bei der Installation des slave auch email und Web mit konfiguriert. Wenn Du bei der Installation des slaves ausgewählt hättest dass er web und mail nicht konfigurieren soll wie im Tutorial beschrieben, dann würde auch keine Webseiten angelegt werden.

    Du kannst das ganze jetzt nachträglich dadurch beheben indem Du das web und email Modul in /usr/local/ispconfig/mods-enabled/ löschst.
     
  3. mh_

    mh_ New Member

    Danke fuer die fixe Antwort.
    Ganz so einfach ist es aber nicht. Die Konfiguration hatte ich erst die Nacht probiert, dass der Slave auch mal komplett alles mit "spiegeln" soll, sprich, alle Services mitkonfiguriert, vorher eben nicht. Jedoch spiegelt er es ja nicht wirklich, er added es in diesem Fall wirklich nur auf dem Slave, der Master hingegen ist leer. Die DNS-Eintraege, /var/www/clients etc liegen komplett nur auf dem Slave.
     
  4. Till

    Till Administrator

  5. mh_

    mh_ New Member

    Mir gehen ehrlich gesagt die Ideen aus woran es liegen koennte. Gab insgesammt mindestens 10 Installtionen in jeglichen Variationen. Bei einem Setup mit 3 Servern, wo Slave 1 und 2 auch nur fuer DNS gedacht war, lag die Konfiguration auch nur auf dem letzten Server, jedoch nicht auf dem Master und dem ersten Slave. Ganz gleich ob ich unter Tools alles hab verteilen lassen.
     
  6. Till

    Till Administrator

    Ich hab Dir den Link gepostet, wie Du es debuggen kannst. Ohne debug output kann ich auch nur meine Glaskugel raus holen ;) Da das mirror setup aber auf sehr vielen Servern einwandfrei läuft, kannst Du davon ausgehen dass es sich um ein Konfigurationsproblem Deiner Server handelt. Dass das Problem immer wieder auftritt hat wenig zu bedeuten, es besagt halt nur dass der Fehler bei allen Installationen gemacht worden ist, z.B. weil Du etwas anders interpretiert hast.
     

Diese Seite empfehlen