Eine Webseite fuer zwei Internetadressen

#5
Geteilte IP Adresse

Hallo,

danke erstmal fuer die Antworten. Ich hab das alles schon probiert.

Ich habe einen A Record auf dem DNS Server ns1.ersteadresse.com fuer www.zweiteadresse.com und zweiteadresse.com eingetragen.

In der Website ersteadresse.com haben ich zwei Subdomains ww.zweiteadresse.com und zweiteadresse.com eingetragen.

Ich komm aber immer nur auf die ispconfig site geteilte IP Adresse.



$TTL 86400
@ IN SOA ns1.ersteadresse.com. ulrich.brunhuber.com. (
2008032007 ; serial, todays date + todays serial #
28800 ; refresh, seconds
7200 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;
NS ns1.ersteadresse.ro. ; Inet Address of name server 1
NS ns3.xtremeweb.de. ; Inet Address of name server 2
;

MX 10 mail.ersteadresse.com.

green-pc.ro. A 89.121.251.4
mail A 89.121.251.4
www A 89.121.251.4
ns1 A 89.121.251.4
ns A 89.121.251.4
www.zweiteadresse.com A 89.121.251.4
zweiteadresse.com A 89.121.251.4

pop CNAME mail.ersteadresse.com.
pop3 CNAME mail.ersteadresse.com.
imap CNAME mail.ersteadresse.com.
smtp CNAME mail.ersteadresse.com.
webmail CNAME mail.ersteadresse.com.ro.

ersteadresse.com.ro. TXT "v=spf1 a ~all"

;;;; MAKE MANUAL ENTRIES BELOW THIS LINE! ;;;;


Vielleicht mach ich was falsch...

mfg

Uli
 
#6
was sagt denn die /etc/apache2/vhosts/Vhosts_ispconfig.conf an, steht da der eintrag für die zweitedomain.de (ServerAlias)in der richtigen Virtualhost-config (ServerName www.erstedomain.de) drin? wenn ja: apache neustarten, wenn nicht ... nicht gut.


markus
 
#7
Hallo,
vielen dank fuer die Tips. Das ist der Abschnitt aus der

server/etc/apache2/vhosts/Vhosts_ispconfig.conf:

#
######################################
# Vhost: www.ersteseite.com:80
######################################
#
#
<VirtualHost 89.121.251.4:80>
SuexecUserGroup web18_sergiu web18
ServerName www.ersteseite.com:80
ServerAdmin webmaster@www.ersteseite.com
DocumentRoot /srv/www/web18/web
ServerAlias green-pc.ro 89.121.251.4.zweiteseite.com
89.121.251.4.www.zweiteseite.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /srv/www/web18/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /srv/www/web18/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/srv/www/web18/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web18/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web18/user/$1/web/$3
</VirtualHost>
#
#


Hab den Server neu gestartet, aber es bleibt dabei:

[FONT=Helvetica, Arial]
Diese IP-Adresse wird mehrfach genutzt. Um die gewünschte Website zu erreichen, geben Sie ihre Domain anstelle der IP-Adresse in der Adresszeile des Browsers ein.
[/FONT]
[FONT=Helvetica, Arial]Bei Fragen oder Problemen wenden Sie sich bitte an den Server-Administrator.[/FONT]
[FONT=Verdana, Arial]powered by ISPConfig

[/FONT]
[FONT=Verdana, Arial]Vielleicht hat ja noch jemand einen Tip.[/FONT][FONT=Verdana, Arial]mfg[/FONT][FONT=Verdana, Arial]Uli[/FONT]
 
#8
Geht auch nicht....

Hallo,
vielen dank fuer die Tips. Das ist der Abschnitt aus der

server/etc/apache2/vhosts/Vhosts_ispconfig.conf:

#
######################################
# Vhost: www.ersteseite.com:80
######################################
#
#
<VirtualHost 89.121.251.4:80>
SuexecUserGroup web18_sergiu web18
ServerName www.ersteseite.com:80
ServerAdmin webmaster@www.ersteseite.com
DocumentRoot /srv/www/web18/web
ServerAlias green-pc.ro 89.121.251.4.zweiteseite.com
89.121.251.4.www.zweiteseite.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /srv/www/web18/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /srv/www/web18/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/srv/www/web18/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /srv/www/web18/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /srv/www/web18/user/$1/web/$3
</VirtualHost>
#
#


Hab den Server neu gestartet, aber es bleibt dabei:

[FONT=Helvetica, Arial]
Diese IP-Adresse wird mehrfach genutzt. Um die gewünschte Website zu erreichen, geben Sie ihre Domain anstelle der IP-Adresse in der Adresszeile des Browsers ein.
[/FONT]
[FONT=Helvetica, Arial]Bei Fragen oder Problemen wenden Sie sich bitte an den Server-Administrator.[/FONT]
[FONT=Verdana, Arial]powered by ISPConfig

[/FONT][FONT=Verdana, Arial]Vielleicht hat ja noch jemand einen Tip.[/FONT][FONT=Verdana, Arial]mfg[/FONT][FONT=Verdana, Arial]Uli[/FONT]
 
#9
Zitat von uli27;2515 ###################################### # Vhost: [URL="http://www.ersteseite.com:80":
www.ersteseite.com:80[/url]
######################################
#
#
<VirtualHost 89.121.251.4:80>
SuexecUserGroup web18_sergiu web18
ServerName www.ersteseite.com:80
ServerAdmin webmaster@www.ersteseite.com
DocumentRoot /srv/www/web18/web
ServerAlias green-pc.ro 89.121.251.4.zweiteseite.com
89.121.251.4.www.zweiteseite.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3

... snip ...

</VirtualHost>
#
#
ok, und die domain zweiteseite.com wird auch auf die richtige ip aufgelöst, wenn du nen ping auf zweiteseite.com machst?

zu deiner config: bei ServerAlias sieht das bei mir so aus:

ServerAlias green-pc.ro 89.121.251.4.zweiteseite.com
89.121.251.4.www.zweiteseite.com

da müsste zwischen der ip und zweiteseite.com ein
leerzeichen sein, ausserdem müssen alle aliase
in einer zeile stehen (ich hoffe mal, das liegt am copy&paste)

schau mal nach, ob da ein leerezichen steht, wenn nicht hast du bei
der konfiguration was versemmelt.

zum angucken der livelogs: tail -f /var/log/apache2/access_log
und tail -f /var/log/apache2/error_log

markus
 
#10
Geht auch nicht....

Hallo Markus,

ich hab die Zeile

ServerAlias green-pc.ro 89.121.251.4.zweiteseite.com
89.121.251.4.www.zweiteseite.com

geaendert

ServerAlias ersteseite.com 89.121.251.4. zweiteseite.com
89.121.251.4. www.zweiteseite.com

der Zeilenumbruch ist wegen der Seitenbreite..

funktioniert nicht

Hier das gewuenschte:

iemens:~ # tail -f /var/log/apache2/access_log
127.0.0.1 - - [19/Mar/2008:18:07:58 +0200] "GET /phpMyAdmin/themes/original/img/b_edit.png HTTP/1.1" 200 451 "http://localhost/phpMyAdmin/db_operations.php?db=hcp&token=15924fb07863b43eb291b83923c2b9ca&goto=db_operations.php" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:02 +0200] "GET /phpMyAdmin/main.php?token=15924fb07863b43eb291b83923c2b9ca HTTP/1.1" 200 53135 "http://localhost/phpMyAdmin/db_operations.php?db=hcp&token=15924fb07863b43eb291b83923c2b9ca&goto=db_operations.php" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:02 +0200] "GET /phpMyAdmin/print.css HTTP/1.1" 404 1394 "http://localhost/phpMyAdmin/main.php?token=15924fb07863b43eb291b83923c2b9ca" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:02 +0200] "GET /phpMyAdmin/navigation.php?server=1&db=&table=&lang=de-utf-8&collation_connection=utf8_unicode_ci HTTP/1.1" 200 3197 "http://localhost/phpMyAdmin/index.php?db=hcp&token=15924fb07863b43eb291b83923c2b9ca" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:05 +0200] "GET /phpMyAdmin/server_privileges.php?token=15924fb07863b43eb291b83923c2b9ca HTTP/1.1" 200 13556 "http://localhost/phpMyAdmin/main.php?token=15924fb07863b43eb291b83923c2b9ca" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:05 +0200] "GET /phpMyAdmin/print.css HTTP/1.1" 404 1420 "http://localhost/phpMyAdmin/server_privileges.php?token=15924fb07863b43eb291b83923c2b9ca" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:05 +0200] "GET /phpMyAdmin/themes/original/img/b_usrlist.png HTTP/1.1" 200 401 "http://localhost/phpMyAdmin/server_privileges.php?token=15924fb07863b43eb291b83923c2b9ca" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:05 +0200] "GET /phpMyAdmin/themes/original/img/b_usrdrop.png HTTP/1.1" 200 438 "http://localhost/phpMyAdmin/server_privileges.php?token=15924fb07863b43eb291b83923c2b9ca" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:05 +0200] "GET /phpMyAdmin/themes/original/img/s_warn.png HTTP/1.1" 200 261 "http://localhost/phpMyAdmin/phpmyadmin.css.php?token=15924fb07863b43eb291b83923c2b9ca&js_frame=right&nocache=1205942150" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
127.0.0.1 - - [19/Mar/2008:18:08:05 +0200] "GET /phpMyAdmin/themes/original/img/b_usradd.png HTTP/1.1" 200 523 "http://localhost/phpMyAdmin/server_privileges.php?token=15924fb07863b43eb291b83923c2b9ca" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"

Vielleicht kannst du mir noch einen Tip geben.

mfg

Uli
 
#11
Hallo Markus,

ich hab die Zeile

ServerAlias green-pc.ro 89.121.251.4.zweiteseite.com
89.121.251.4.www.zweiteseite.com

geaendert

ServerAlias ersteseite.com 89.121.251.4. zweiteseite.com
89.121.251.4. www.zweiteseite.com

der Zeilenumbruch ist wegen der Seitenbreite..


Uli
apacheneustart ;-))

grundsätzlich sollte er dann zweiteseite.com auf die gleichen verzeichnisse wie ersteseite.com leiten.

die logs sagen garnix, ausser, das du mit phpmyadmin unterwegs bist; du musst gucken was passiert, wenn du auf zweiteseite.com zugreifen willst. du kannst dann in den logs live sehen was passiert

wie viele IPs hat der server?

und was passiert, wenn du nen ping auf zweiteseite.com absetzt, wird dort die ip angezeigt, die der domain zugewiesen ist?

ein tip:
http://www.amazon.de/Apache-Das-umf...=sr_1_2?ie=UTF8&s=books&qid=1206107464&sr=8-2



markus
 
#12
Hallo Markus,
schoenen Dan fuer die Hilfe.

Neustart hab ich gemacht ueber ISPCONFIG.

Das ist das richtige Log, gestern war ich auf dem Laptop und nicht im Server.:p

server1:~ # tail -f /var/log/apache2/access_log
66.249.73.88 - - [21/Mar/2008:21:06:41 +0200] "GET /index.php?page=shop.product_
details&flypage=shop.flypage&product_id=249&category_id=39&manufacturer_id=0&opt
ion=com_virtuemart&Itemid=3&vmcchk=1&Itemid=3&lang=ro HTTP/1.1" 200 28222 "-" "M
ozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
66.249.73.88 - - [21/Mar/2008:21:06:47 +0200] "GET /index.php?page=shop.product_
details&flypage=shop.flypage&product_id=138&category_id=22&manufacturer_id=0&opt
ion=com_virtuemart&Itemid=37&vmcchk=1&Itemid=37&lang=en HTTP/1.1" 200 27251 "-"
"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
66.249.73.88 - - [21/Mar/2008:21:09:22 +0200] "GET /index.php?page=shop.product_
details&flypage=shop.flypage&product_id=271&category_id=40&manufacturer_id=0&opt
ion=com_virtuemart&Itemid=23&vmcchk=1&Itemid=23&lang=en HTTP/1.1" 200 26896 "-"
"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
66.249.73.88 - - [21/Mar/2008:21:12:13 +0200] "GET /index.php?page=shop.product_
details&flypage=shop.flypage&product_id=276&category_id=40&manufacturer_id=0&opt
ion=com_virtuemart&Itemid=2&vmcchk=1&Itemid=2&lang=ge HTTP/1.1" 200 26989 "-" "M
ozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
86.121.254.69 - - [21/Mar/2008:21:44:57 +0200] "GET / HTTP/1.0" 200 1229 "-" "-"
66.249.73.88 - - [21/Mar/2008:21:52:49 +0200] "GET /index.php?page=shop.product_
details&flypage=shop.flypage&product_id=252&category_id=39&manufacturer_id=0&opt
ion=com_virtuemart&Itemid=26&vmcchk=1&Itemid=26&lang=ro HTTP/1.1" 200 28322 "-"
"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
86.121.254.69 - - [21/Mar/2008:22:12:45 +0200] "GET / HTTP/1.0" 200 1229 "-" "-"
92.80.73.76 - - [21/Mar/2008:22:53:51 +0200] "GET / HTTP/1.1" 200 1229 "-" "Mozi
lla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 F irefox/2.0.0.12"
92.80.73.76 - - [21/Mar/2008:22:53:51 +0200] "GET /favicon.ico HTTP/1.1" 404 114 5 "-" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0 .0.12-0.1 Firefox/2.0.0.12"
92.80.73.76 - - [21/Mar/2008:22:54:17 +0200] "GET /favicon.ico HTTP/1.1" 404 114 5 "-" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0 .0.12-0.1 Firefox/2.0.0.12"
92.80.73.76 - - [21/Mar/2008:22:56:24 +0200] "GET /favicon.ico HTTP/1.1" 404 114 5 "-" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0 .0.12-0.1 Firefox/2.0.0.12"
92.80.73.76 - - [21/Mar/2008:22:56:26 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla /5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Fire fox/2.0.0.12"


92.80.73.76 - - [21/Mar/2008:22:56:35 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla /5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Fire fox/2.0.0.12"

92.80.73.76 - - [21/Mar/2008:22:57:00 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla /5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Fire fox/2.0.0.12"
92.80.73.76 - - [21/Mar/2008:23:00:41 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.12) Gecko/20080203 SUSE/2.0.0.12-0.1 Firefox/2.0.0.12"
92.80.73.76 - - [21/Mar/2008:23:00:42 +0200] "GET / HTTP/1.1" 304 - "-" "Mozilla/5.0 (X11; U; Linux i686; de;

Der Server hat zwei IPs, eine 192.168.0.xxx und 89.121.251.4....

Wenn ich einen ping auf zweiteseit.com sende, findet er die IP des Severs. Ich habe ja im DNS Server (ns1.ersteseite.com) ueber IPCONFIG zwei A Records angelegt:


A Record IP-Adresse Host 89.121.251.4 mail 89.121.251.4 www 89.121.251.4 ns1 89.121.251.4 ns 89.121.251.4 www.zweiteseite.com
89.121.251.4 www.zweiteseite.com
Der Tip mit dem Buch ist gut. Danke. Ich wohne aber in Rumaenien, mal schaun ob die dahin liefern. Ich denke schon.

mfg

Uli
 
Zuletzt bearbeitet:
#13
Hallo Markus,

Der Server hat zwei IPs, eine 192.168.0.xxx und 89.121.251.4....

Wenn ich einen ping auf zweiteseit.com sende, findet er die IP des Severs.
Uli

Hallo Ulli,

welche IP? die erste Frage ist, ob zweiteseite.com auch auf die richtige IP aufgelöst wird und die zweite farge ist, ob apache dann die virtuelle domain richtig zuordnet .

so aus der ferne sind auszüge aus dem logfile irgendwie ... sinnlos ;_)) du musst dir das angucken, wenn du auf zweiteseite.com sper browser zugreifen willst um zu erkennen, was der apache da überhaupt machen will.

ich vermute mal entweder falsches dns oder falsche vhost.conf, irgendwo dort muss das problem liegen.

lösch am besten di co-location nochmal raus, dann relaod von apache (kannst du das auf der console? die fehlerausgaben sind meist gold wert, zb wenn der apache aufgrund von fehlkonfiguration garnicht neustartet sondern einfach weiterläuft)

fang am besten nochmal in ruhe von vorne an, welche IP auf welche domain, zeigt die domain auf die richtige ip, wenn ja, in ispconfig server-alias/co-location anlegen,


markus
 
#14
Danke Markus, jetzt gehts.

Hallo Markus,

vielen Dank fuer deine Tips. Ich habe alle DNS Eintraege geloescht, die Websites geloescht. In der Mysql Datenbank blieben eintraege erhalten, nachdem ich die Subdomains geloescht habe. Ich hab die nach langem ueberlegen mit auch geloescht. Dann habe ich alles nochmal eingegeben. Jetzt gehts.

Mit freundlichen Gruessen

U. Brunhuber
;)
 

Till

Administrator
#15
Du Darfst nie etwas in der MySQL DB direkt löschen, wenn Du es doch machst, ist danach die DB inkonsistent was später zu Fehlern führen kann.

Stattdessen hättest Du einfach den Papierkorb leeren müssen.
 
#16
Und jetzt? Alles neu installieren?

Hallo Till,

danke fuer den Hinweis. Was kann ich jetzt machen? Alles neu instalieren?
Bei mir geht z. B. Webalizer nicht mehr. Es hierte einfach mit einem bestimmten Datum auf zu Arbeiten.

mfg

Uli
 
Zuletzt bearbeitet:

Werbung