Fehler bei Installation "connect to server at 'ispconfig.local' failed"

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Karl, 15. Aug. 2008.

  1. Karl

    Karl New Member

    Hallo,

    ich habe Version 3.0.0.5 beta installiert auf Debian 4.0 (V-Server) und bekomme folgende Fehlermeldungen:

    Ich bin strikt nach der Anleitung INSTALL_DEBIAN.txt vorgegangen. Ziemlich am Anfang gibt es den Befehl "mysqladmin -h ispconfig.local -u root password yourrootsqlpassword" (mit richtigem Passwort eingefügt). Als Ergebnis erhalte ich diese Fehlermeldung:

    "mysqladmin: connect to server at 'ispconfig.local' failed
    error: 'Unknown MySQL server host 'ispconfig.local' (1)'
    Check that mysqld is running on ispconfig.local and that the port is 3306.
    You can check this by doing 'telnet ispconfig.local 3306
    "

    Später im Laufe der weiteren Installation erhalte ich dann:

    "Configure DNS Server (y,n) [y]:

    Configuring MyDNS
    mydns[26587]: Error connecting to MySQL server at localhost: Access denied for user 'ispconfig'@'localhost' (using password: YES) (errno=0)
    "

    Hat jemand eine Idee?

    Gruß
    Karl
     
  2. Karl

    Karl New Member

    Im englischen Forum habe ich diesen Hinweis von till gefunden:

    Offensichtlich ist die Angabe "ispconfig.local" in der Installationsanweisung ein Tippfehler und sollte entweder "ispconfig.localhost" oder nur "localhost" heißen...
    Ich habe nun beide Varianten ausprobiert – leider immer mit derselben Fehlermeldung: "mysqladmin: connect to server at 'ispconfig.localhost' failed... usw.".

    Vielleicht hat Till ja eine Idee, wo evtl. noch ein Tippfehler steckt – oder ich mache etwas Grundsätzliches falsch.

    Gruß
    Karl
     
  3. Till

    Till Administrator

    ispconfig.local ist ein Platzhalter, sowas wie Max Mustermann. Du musst es durch den Hostnamen Deines Servers ersetzen und dieser Hostname muss auch wirklich erreichbar sein.

    Beim MySQL Hostnamen solltest Du localhost nehmen.
     
  4. Karl

    Karl New Member

    Till, danke für die schnelle Antwort.

    Das hatte ich schon gemacht. Es handelt sich um einen V-Server von Strato (V-PowerServer A). Der Hostname ist vorgegeben: "h141xxxx.stratoserver.net". Habe deshalb schon mal den Befehl "mysqladmin -h ispconfig.local -u root password yourrootsqlpassword" abgewandelt in "mysqladmin -h h141xxxx.stratoserver.net -u root password meinrootpasswort". Als Ergebnis erhalte ich diese Fehlermeldung:

    "mysqladmin: connect to server at 'h141xxxx.stratoserver.net' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
    "

    Da hakt es bei mir wieder. Wie passt das zum obigen Thema? Wo muss ich "localhost" nehmen bei diesem Befehl: "mysqladmin -h ispconfig.local -u root password yourrootsqlpassword"?

    Gruß
    Karl
     
    Zuletzt bearbeitet: 15. Aug. 2008
  5. Till

    Till Administrator

    mysqladmin -h localhost -u root password yourrootsqlpassword

    Vermutlich ist aber einfach Deine MySQL datenbank nicht richtig installiert bzw. Du hast schon ein Passwort für den root User vergeben.
     
  6. Karl

    Karl New Member

    Ich gestehe, ich stehe auf dem Schlauch. Ich bin strikt nach der Installationsanleitung vorgegangen. Dort steht Folgendes:

    ..................................................................................
    Set the mysql database password:

    mysqladmin -u root password yourrootsqlpassword
    mysqladmin -h ispconfig.local -u root password yourrootsqlpassword

    ..................................................................................

    Habe also zuerst "mysqladmin -u root password yourrootsqlpassword" gemacht --> ohne Probleme.

    Dann als nächstes "mysqladmin -h h141xxxx.stratoserver.net -u root password yourrootsqlpassword" --> Fehlermeldung.

    Was du jetzt schreibst: "mysqladmin -h localhost -u root password yourrootsqlpassword" kommt in der Installationsanleitung garnicht vor. An welcher Stelle sollte das gemacht werden?
     
  7. Till

    Till Administrator

    Die Installationsanleitung ist korrekt, sie geht aber von einem "normalen" Debian aus und nicht von einer Strato VSErver Installation, bei der Strato scheinbar einige Voreinstellungen geändert hat.

    Das hat mit der Installationsanleitung nichts zu tun, Du hast es hier im Thread nachgefragt.

    Also, lass einfach den zweiten Befehl "mysqladmin -h ispconfig.local -u root password yourrootsqlpassword" aus und mach mit den nächsten Schritten weiter, Du kannst das Passwort für den Hostnamen Deines Servers auch später mit phpmyadmin korrigieren, da es nicht für die ISPConfig installation wichtig ist. Es ist nur eine Sicherheitsmaßnahme, dass Dir nachher niemand Deine Datenbank hackt.
     
  8. Karl

    Karl New Member

    Vielen Dank für die Hilfe. Die Installation lief jetzt bis zum Ende durch.
     
  9. Karl

    Karl New Member

    Server läuft nicht

    Hallo Till,

    leider hat die Installation doch nicht so reibungslos geklappt wie es ausgesehen hat. Es gab zwar dank deiner Hilfe keine Fehlermeldungen mehr bei der Installation. Nach Installationsende war ISPConfig auch erreichbar und ich konnte einen Client und eine Domain anlegen.

    Aber nach einem Reboot des Servers läuft ISPConfig nicht mehr. Die Admin-Site ist nicht mehr erreichbar.

    Hast du noch einen Tipp für mich?
     
  10. Till

    Till Administrator

    Vermutlich ist der apache Webserver nicht gestartet.
     
  11. Karl

    Karl New Member

    Apache nicht gestartet

    Danke, das war der richtige Tipp.

    "invoke-rc.d apache2 start
    Starting web server (apache2)...Syntax error on line 25 of /etc/apache2/sites-enabled/xxxxxxxx.de.vhost:
    Invalid command 'suPHP_Engine', perhaps misspelled or defined by a module not included in the server configuration
    failed!
    "

    Bei der Domain-Einrichtung hatte ich "suPHP" gewählt.

    Ist natürlich überraschend, dass dann Apache und ISPConfig garnicht mehr laufen.

    Das einzige Problem scheint jetzt noch, dass der [FONT=Verdana, Arial, Helvetica, sans-serif]FTP-Server nicht läuft (offline).
    [/FONT]
     
  12. Till

    Till Administrator

    Du solltest schone eine der PHP Versionen wählen, die Du auch auf Deinem Server installiert hast. Das ist standardmäßig mod_php.

    Poste mal die Ausgabe von:

    netstat -tap | grep ftp
     
  13. Karl

    Karl New Member

    Keine Ausgabe (nichts).
     
  14. Till

    Till Administrator

    Ok, dann hast Du pureftpd entweder nicht installiert oder nicht gestartet. Starte pureftpd bitte mal mit dem Start Script in /etc/init.d
     
  15. Karl

    Karl New Member

    "# /etc/init.d/pure-ftpd-mysql start
    Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -O clf:/var/log/pure-ftpd/transfer.log -B
    "

    netstat aber immer noch ohne Ausgabe.
     
  16. Till

    Till Administrator

    Kannst Du Dich denn per FTP Client verbinden?
     
  17. Karl

    Karl New Member

    Nein, leider nicht.

    Ich kann zwar problemlos einen FTP-User anlegen aber unter "Monitor" erscheint "FTP-Server: Offline".

    Ich habe jetzt nochmal ISPConfig V. 3.0.0.6 völlig neu installiert -- diesmal ohne Fehlermeldungen. Aber an dem FTP-Problem hat sich überhaupt nichts geändert.


    PS: Ich mache mal einen neuen Thread auf deswegen.
     

Diese Seite empfehlen