Fehler beim Installieren von Pagespeed für nginx

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Snatch, 10. Mai 2015.

  1. Snatch

    Snatch New Member

    Hallo zusammen,

    ich bin nach diesem Tut vorgegangen:
    https://www.howtoforge.com/tutorial/nginx-with-ngx_pagespeed-on-debian-8-jessie/

    Nginx war bei mir bereits installiert und lief soweit. Nun erhalte ich aber bei der Intallation folgenden Fehler:
    root@server1:/usr/src/nginx-pagespeed# dpkg --install nginx-common_1.6.2-5_all.deb nginx_1.6.2-5_all.deb nginx-full_1.6.2-5_amd64.deb
    (Lese Datenbank ... 55669 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von nginx-common_1.6.2-5_all.deb ...
    Entpacken von nginx-common (1.6.2-5) über (1.6.2-5) ...
    Vorbereitung zum Entpacken von nginx_1.6.2-5_all.deb ...
    Entpacken von nginx (1.6.2-5) über (1.6.2-5) ...
    Vorbereitung zum Entpacken von nginx-full_1.6.2-5_amd64.deb ...
    Entpacken von nginx-full (1.6.2-5) über (1.6.2-5) ...
    nginx-common (1.6.2-5) wird eingerichtet ...
    nginx-full (1.6.2-5) wird eingerichtet ...
    Job for nginx.service failed. See 'systemctl status nginx.service' and 'journalctl -xn' for details.
    invoke-rc.d: initscript nginx, action "start" failed.
    dpkg: Fehler beim Bearbeiten des Paketes nginx-full (--install):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von nginx:
    nginx hängt ab von nginx-full (>= 1.6.2-5) | nginx-light (>= 1.6.2-5) | nginx-extras (>= 1.6.2-5); aber:
    Paket nginx-full ist noch nicht konfiguriert.
    Paket nginx-light ist nicht installiert.
    Paket nginx-extras ist nicht installiert.
    nginx hängt ab von nginx-full (<< 1.6.2-5.1~) | nginx-light (<< 1.6.2-5.1~) | nginx-extras (<< 1.6.2-5.1~); aber:
    Paket nginx-full ist noch nicht konfiguriert.
    Paket nginx-light ist nicht installiert.
    Paket nginx-extras ist nicht installiert.

    dpkg: Fehler beim Bearbeiten des Paketes nginx (--install):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    Trigger für man-db (2.7.0.2-5) werden verarbeitet ...
    Trigger für systemd (215-17) werden verarbeitet ...
    Fehler traten auf beim Bearbeiten von:
    nginx-full
    nginx
    Sie haben neue Post in /var/mail/root.
    root@server1:/usr/src/nginx-pagespeed#


    Kann mir dabei jemand helfen?

    Grüße und Danke
     
  2. Snatch

    Snatch New Member

    So, das Problem ist gelöst. Habe alles gelöscht und nochmal neu begonnen ohne den nginx davor per apt zu installieren, dann ging es.
    Nginx rennt auch wieder. Allerdings habe ich nun ein weiteres Problem.

    Ich habe diese beiden Zeilen in die nginx.conf eingefügt, so wie es im Tut beschrieben ist:
    pagespeed on;
    pagespeed FileCachePath /var/ngx_pagespeed_cache;

    Ein Reload bringt mir aber diesen Fehler:
    root@server1:/usr/src/nginx-pagespeed# service nginx reload
    Job for nginx.service failed. See 'systemctl status nginx.service' and 'journalctl -xn' for details.
    root@server1:/usr/src/nginx-pagespeed# systemctl status nginx.service
    ● nginx.service - A high performance web server and a reverse proxy server
    Loaded: loaded (/lib/systemd/system/nginx.service; enabled)
    Active: active (running) (Result: exit-code) since So 2015-05-10 16:53:36 CEST; 5min ago
    Process: 2819 ExecReload=/usr/sbin/nginx -g daemon on; master_process on; -s reload (code=exited, status=1/FAILURE)
    Main PID: 24540 (nginx)
    CGroup: /system.slice/nginx.service
    ├─24540 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
    ├─26950 nginx: worker process
    ├─26951 nginx: worker process
    ├─26952 nginx: worker process
    └─26953 nginx: worker process

    Mai 10 16:54:59 server1.dampfer-server.eu nginx[26922]: nginx: [warn] duplicate MIME type "text/html" in /etc/nginx/nginx.conf:66
    Mai 10 16:57:34 server1.dampfer-server.eu nginx[654]: nginx: [emerg] unknown directive "pagespeed" in /etc/nginx/nginx.conf:16
    Mai 10 16:57:34 server1.dampfer-server.eu systemd[1]: nginx.service: control process exited, code=exited status=1
    Mai 10 16:57:34 server1.dampfer-server.eu systemd[1]: Reload failed for A high performance web server and a reverse proxy server.
    Mai 10 16:57:48 server1.dampfer-server.eu nginx[675]: nginx: [emerg] unknown directive "pagespeed" in /etc/nginx/nginx.conf:16
    Mai 10 16:57:48 server1.dampfer-server.eu systemd[1]: nginx.service: control process exited, code=exited status=1
    Mai 10 16:57:48 server1.dampfer-server.eu systemd[1]: Reload failed for A high performance web server and a reverse proxy server.
    Mai 10 16:58:42 server1.dampfer-server.eu nginx[2819]: nginx: [emerg] unknown directive "pagespeed" in /etc/nginx/nginx.conf:16
    Mai 10 16:58:42 server1.dampfer-server.eu systemd[1]: nginx.service: control process exited, code=exited status=1
    Mai 10 16:58:42 server1.dampfer-server.eu systemd[1]: Reload failed for A high performance web server and a reverse proxy server.


    Wiso finde er pagespeed nicht. Installiert ist es:
    root@server1:/# nginx -v
    nginx version: nginx/1.6.2
    root@server1:/# nginx -V
    nginx version: nginx/1.6.2
    TLS SNI support enabled
    configure arguments: --with-cc-opt='-g -O2 -fstack-protector-strong -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2' --with-ld-opt=-Wl,-z,relro --prefix=/usr/share/nginx --conf-path=/etc/nginx/nginx.conf --http-log-path=/var/log/nginx/access.log --error-log-path=/var/log/nginx/error.log --lock-path=/var/lock/nginx.lock --pid-path=/run/nginx.pid --http-client-body-temp-path=/var/lib/nginx/body --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --http-proxy-temp-path=/var/lib/nginx/proxy --http-scgi-temp-path=/var/lib/nginx/scgi --http-uwsgi-temp-path=/var/lib/nginx/uwsgi --with-debug --with-pcre-jit --with-ipv6 --with-http_ssl_module --with-http_stub_status_module --with-http_realip_module --with-http_auth_request_module --with-http_addition_module --with-http_dav_module --with-http_geoip_module --with-http_gzip_static_module --with-http_image_filter_module --with-http_spdy_module --with-http_sub_module --with-http_xslt_module --with-mail --with-mail_ssl_module --add-module=/usr/src/nginx-pagespeed/nginx-1.6.2/debian/modules/nginx-auth-pam --add-module=/usr/src/nginx-pagespeed/nginx-1.6.2/debian/modules/nginx-dav-ext-module --add-module=/usr/src/nginx-pagespeed/nginx-1.6.2/debian/modules/nginx-echo --add-module=/usr/src/nginx-pagespeed/nginx-1.6.2/debian/modules/nginx-upstream-fair --add-module=/usr/src/nginx-pagespeed/nginx-1.6.2/debian/modules/ngx_http_substitutions_filter_module
     
  3. F4RR3LL

    F4RR3LL Member

    Servus Snatch,
    Pagespeed ist bei Dir nicht installiert.
    Sonst würde diese Passage noch auftauchen bei nginx -V:
    Code:
    –add-module=/usr/src/nginx-pagespeed/nginx-1.6.2/debian/modules/ngx_pagespeed
    
    Hast du beim Make kein Gemecker erhalten?
    Wenn man beim Editieren der Debianrules Leerzeichen falsch erstellt oder verbastelt passiert das ganz schnell,
    dass die –add-module=$(MODULESDIR)/ngx_pagespeed \ nicht funktioniert.
    Ebenso muss die add-module Zeile an der richtigen Stelle stehen, sonst klappts auch nicht.

    Gruß Sven

    //Edit: Wenn Du es ganz einfach haben willst-> hier sind die fertigen Pakete für Debian 8, per wget ziehen und mit dpkg installieren https://download.nixhelp.de/ISPconfig-amd64/Debian-8/Nginx-1.6.2-incl-pagespeed/ ;)
     
    Till gefällt das.
  4. nowayback

    nowayback Well-Known Member

    warum nicht dotdeb? da ist es auch fertig drin in nginx-extras
     
  5. F4RR3LL

    F4RR3LL Member

    Is wohl Geschmackssache :) Aber gut für den Threadersteller, noch mehr Alternativen.

    Gruß Sven
     

Diese Seite empfehlen