Fehler in Zonendatei bei CNAME Eintrag in DNS

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von isp_geek, 16. Mai 2014.

  1. isp_geek

    isp_geek Member

    Hallo Leute, hallo Till,

    irgendwie streikt mein DNS bei CNAME. Ich hatte mir eine Vorlage in v304x eingerichtet und diese funktionierte super .. jetzt mit v3054p1 verweigert das Bind oder das Ispconfig die Arbeit mit dem CNAME Eintrag.

    Also, sobald ich einen CNAME Eintrag mache ist die Zone weg mir Error .err markiert. Hab jetzt etliche Verianten probiert ... und nix geht ... wenn ich den CNAME Eintrag wegnehme ist alles wieder da!?

    Im Log hab ich nur "... zone mydomain.de/IN: (master) removed" sonst keine Info weiter.

    Hat jmd ne Idee was da los ist .. ähm ich hab nicht den Punkt am Ende vergessen ..

    Achso die Mails noch
     
    Zuletzt bearbeitet: 16. Mai 2014
  2. SAVERSERVER

    SAVERSERVER Member

    ich hatte auch in der 3.0.5.4p1 Probleme mit DNS (aber bezüglich der rDNS, Adressfeldlänge für IPv6)
    Das Problem ist mittlerweile behoben und kommt in der 3.0.5.4p2

    Daher bin ich wieder zurück zu 3.0.5.4b1, da kann ich auch bestätigen dass die CNAME funktionieren. Nimm doch mal dein Backup und mach einen Upgrade auf 3.0.5.4b1.
     
  3. isp_geek

    isp_geek Member

    ooooooh man! Hab den Fehler gefunden ..

    Es ist nicht das CNAME, es war der MX Record darunter der keinen Namen hatte. Hab die Einstellung vom Provider übernommen und da waren keine Namen dirn - ein * hat auch keine Abhilfe geschaffen.

    Erst als ich die MX Records ans Ende der Zonendatei geschrieben habe ging es .. mir echt unerklärlich .. ich werde diesem Phänomen stäter auf den Grund gehen ...

    Im Übrigen ging die Bsp Zonendatei von Hetzner mit dem @ und IN so auch nicht ..

    Wer das sonst noch interssiert hier ein schnelles Workaround:

    In ISPconfig alle Daten eintragen und dann nix mehr in der Zone ändern, dann
    die /etc/bind/pri.yourdom.com.err zu /etc/bnd/pri.yourdom.com umbenennen, dann
    in /etc/bind/named.conf.local den Zoneneintrag zu yourdom.com wiederherstellen
    /etc/bind/pri.yourdom.com ändern indem Ihr alle Zeilen mit MX ans Ende der Datei verschiebt.
    Bind neu starten usw logs checken ...

    oder ganz einfach den Namen nicht leer lassen sondern dafür youdom.com. eintragen, damit wäre das Workaround überflüssig .. man lernt nie aus ..hehe

    Viel Erfolg .. ich hoffe im nächsten Update ist das Geschichte.

    lg.ks
     
    Zuletzt bearbeitet: 16. Mai 2014

Diese Seite empfehlen