Fehlermeldung Awstats

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von nikobell, 20. Feb. 2012.

  1. nikobell

    nikobell New Member

    Hallo,

    ich suche nach einer Lösung folgende Fehlermeldung von awstats zu bereinigen.


    Create/Update database for config "/etc/awstats/awstats.xxxxxxx.de.conf" by AWStats version 6.95 (build 1.943) From data in log file "/var/log/ispconfig/httpd/xxxxxxx.de/yesterday-access.log"...
    Error: Couldn't open server log file "/var/log/ispconfig/httpd/xxxxxxx.de/yesterday-access.log" : No such file or directory Setup ('/etc/awstats/awstats.xxxxxxx.de.conf' file, web server or permissions) may be wrong.
    Check config file, permissions and AWStats documentation (in 'docs' directory).

    Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.
    Setup ('/etc/awstats/awstats.conf' file, web server or permissions) may be wrong.


    Wie kann ich diesen Fehler beseitigen. Vielen Dank für eine Antwort.
     
  2. Till

    Till Administrator

    Schau mal in die Datei /usr/local/ispconfig/server/lib/config.inc.php und stell sicher dass dort die richtige Zeitzone eingestellt ist, also die Zeitzone die auf dem Server verwendet wird. Für Deutschland ist dies normalerweise "Europe/Berlin", vorausgesetzt dass Du auf dem Server auch die lokale Deutsche zeit und nicht UTC verwendest.
     
  3. nikobell

    nikobell New Member

    Danke Till für die schnelle Antwort.

    Habe die Zeitzone umgestellt.

    $conf['timezone'] = 'Europe/Berlin';

    Leider kommt die Fehlermeldung alle 10 Minuten immer wieder per mail.

    Gibt es vielleicht noch eine andere Lösung. Dieser Fehler betrifft auch nicht alle Domains. nur die letzten beiden.
     
  4. Till

    Till Administrator

    Der Cronjob von ISPConfig läuft aber nur einmal pro Nacht. Vermutlich hast Du bei Dir noch irgendeeinen anderen awstats cronjob am laufen, den solltest Du löschen.
     
  5. nikobell

    nikobell New Member

    Hallo,

    ich habe nur einen Cronjob bezüglich awstats laufen.

    der befindet sich unter /etc/con.d/awstats

    mit folgendem Inhalt


    */10 * * * * www-data [ -x /usr/share/awstats/tools/update.sh ] && /usr/share/awstats/tools/update.sh

    # Generate static reports:
    # 10 03 * * * www-data [ -x /usr/share/awstats/tools/buildstatic.sh ] && /usr/share/awstats/tools/buildstatic.sh


    sonst habe ich keinen laufen. Mittlerweile habe ich in der Domainverwaltung von ispconfig 3.40.3 auf Webalizer umgestellt. Nach wie vor kommen diese Fehlermeldungen.
     
  6. Till

    Till Administrator

    Der Cronjob ist nicht von ISPConfig und muss deaktiviert werden.
     
  7. nikobell

    nikobell New Member

    Danke Till für die Hilfe.

    Ich erhalte jetzt keine Fehlermeldungen mehr. Es scheint, dass das Problem jetzt gelöst ist.

    Danke nochmal.
     

Diese Seite empfehlen