Foswiki auf ispconfig3, perl probleme

Dieses Thema im Forum "Allgemein" wurde erstellt von Rupertt, 7. Jan. 2011.

  1. Rupertt

    Rupertt New Member

    Hallo,

    ich versuche das Foswiki auf meiner ipsconfig3 maschine zum laufen zu bringen.
    Foswiki basiert komplett auf Perl, und nutzt perl files ohne endung .pl.

    Ich habe das Problem das diese nicht interpretiert werden.

    Wie kann ich ispconfig/perl so konfigurieren das dies funktioniert?


    Dies sind die Einträge die ich im ispconfig gemacht habe:

    Code:
    BrowserMatchNoCase ^$ blockAccess
    BrowserMatch "^gsa-crawler" NO_FOSWIKI_SESSION
    
    
    ScriptAlias /foswiki/bin "/srv/www/clients/client5/web68/web/bin"
     AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
    Alias /foswiki/pub "/srv/www/clients/client5/web68/web/pub"
    
    <Directory "/srv/www/clients/client5/web68/web/">
        Order Allow,Deny
        Allow from all
        Deny from env=blockAccess
    </Directory>
    
    Alias /foswiki "/srv/www/clients/client5/web68/web"
    
    BrowserMatchNoCase ^$ blockAccess
    
    BrowserMatch "^gsa-crawler" NO_FOSWIKI_SESSION
    
    <Directory "/srv/www/clients/client5/web68/web/bin">
        AllowOverride None
        Order Allow,Deny
        Allow from all
        Deny from env=blockAccess
    
        Options ExecCGI FollowSymLinks
        SetHandler cgi-script
    
        # Password file for Foswiki users
        AuthUserFile /srv/www/clients/client5/web68/web/data/.htpasswd
        AuthName 'blackbit'
        AuthType Basic
        
    
    <FilesMatch "^configure.*">
        SetHandler cgi-script
        Order Deny,Allow
        Deny from all
        Allow from 127.0.0.1 192.168.1 192.168.112
        Require user JohnDoe
        Satisfy Any
    </FilesMatch>
    
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/pub">
        #if you are using an svn checkout an pseudo-install.pl, you will need to enable symlinks
        #Options FollowSymLinks
        Options None
        AllowOverride None
        Order Allow,Deny
        Allow from all
        Deny from env=blockAccess
        
    
        php_admin_flag engine off
        
    
        AddType text/plain .shtml .php .php3 .phtml .phtm .pl .py .cgi
        
        ErrorDocument 404 /srv/www/clients/client5/web68/web/bin/viewfile
    
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/pub/Trash">
    	deny from all
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/data">
        deny from all
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/templates">
        deny from all
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/lib">
        deny from all
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/locale">
        deny from all
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/tools">
        deny from all
    </Directory>
    
    <Directory "/srv/www/clients/client5/web68/web/working">
        deny from all
    </Directory>
    
    <IfModule mod_perl.c>
    <Files ~ (\.pl$)>
                    SetHandler perl-script
                    PerlHandler ModPerl::Registry
                    Options ExecCGI  
                    allow from all   
                    PerlSendHeader On
    </Files>   
    </IfModule>
    
    PerlResponseHandler ModPerl::Registry
    PerlOptions +ParseHeaders
    
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule !^.+\..+$ - [H=perl-script]
    
    
     
  2. jietoh

    jietoh New Member

Diese Seite empfehlen