Frage zu: VBoxHeadless – Virtuelle Maschinen mit VirtualBox 3.1.x auf einem Debian...

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von M. Zink, 9. Nov. 2010.

  1. M. Zink

    M. Zink New Member

    Zu folgendem HowTo hab ich zwei Fragen
    http://www.howtoforge.de/blogroll/v...rtualbox-3-1-x-auf-einem-debian-lenny-server/
    Und zwar wird erst die Source hinzu gefügt und dann der Public Key. Wenn ich nun mit aptitude update (oder auch apt-get update) eine Aktualisierung ausführe bekomme ich immer folgende Meldung.
    Und außerdem bei der Installation von Vbox kommt noch ein Hinweis irgendwas wegen unsicherer Software oder sowas. Hingegen die Frage nach der Benutzergruppe laut Tutorial kommt bei mir nicht.

    Ich hab das Tutorial durchgearbeitet bei einem frisch installierten Testsystem auch nach dem HowTo für den perfekten Server für Debian Lenny mit ISPC3.
     
  2. M. Zink

    M. Zink New Member

    Ich muss hier noch mal Nachfassen. So wie es aussieht funktioniert VBox trotz der kleineren Probleme. Mir ist aufgefallen das ich vielleicht die neueste VBox Version installieren sollte aber das teste ich heute Mittag noch mal.

    Wichtiger ist wie ich überhaupt die 64 Bit Variante von Windows SBS installieren kann. Ich hab die original Lizenz und den Installationsdatenträger in 64 Bit und beim ersten Start meldet er schon das ein 64 Bit Prozessor verlangt wird aber nur ein 32 Bit vorhanden ist. Ich hab aber mit 100% Sicherheit einen 64 Bit Prozessor verbaut.

    Langsam hab ich den Eindruck das VBox doch nicht wirklich das richtige ist für mein Vorhaben. Vielleicht teste ich auch mal OpenVZ oder so falls sich hier niemand meldet und weiß was ich falsch mache :)
     
  3. Laubie

    Laubie Member

    moin,
    ich hab mal versucht nen 64bit windows auf eine VBox zu installieren.
    Jedoch lief VBox auch auf einem 64bit Windows.

    Problem war, dass mein Prozessor nicht genau die Virtualisierungtechnik unterstützte, die VBox haben muss, um 64bit zu virtualisieren.

    K.A. ob das mit deiner Hardware klappt. Auf jeden Fall musste man noch mindestens 3 Häkchen in der GUI anklicken, damit er es überhaupt versuchte.
    Eines davon war bei mir ausgegraut...

    Naja, vielleicht hilft dir das ein bisschen ;)
    Laubie
     
  4. M. Zink

    M. Zink New Member

    Ich glaube bei VBox muss das kein wirklich zertifizierter Prozessor sein. Er muss nur gewisse Anforderungen erfüllen. Getestet hab ich das auf einem Core i7, einem Xeon und einem E6600 was alles 64 Bit Prozessoren sind. Daran kanns eigentlich nicht liegen zumal der Xeon sogar Hyper V zertifiziert ist.

    Mit OpenVZ scheint es auch nicht zu klappen. Wobei ich bei meinem Test ganz massive Probleme hatte nachdem ich den OpenVZ Kernel installiert hab. Danach soll man das System ja starten und muss noch ein paar Dinge in der Sysconf anpassen. Das System wollte allerdings nach der Installation vom Kernel erst mal nicht mehr starten. Und mit 64 Bit Windows läuft OpenVZ soweit ich das lesen konnte auch nicht. Von daher bringt mir das ja unterm Strich nichts.

    Wieso gibts bei VBox überhaupt die Einstellung für Windows 2008 wenn es damit nicht läuft? Ich versuch jetzt mal noch den normalen Windows Server 2008 und nicht SBS mal sehen ob der zu installieren geht.

    Aber mir scheint mein Vorhaben auf dem Webserver nen Exchange Server zu installieren ist zum Scheitern verurteilt.
     
  5. F4RR3LL

    F4RR3LL Member

    Ähm OpenVZ ist nur zur Virtualisierung von Linux. Win und BSD lassen sich damit nicht virtualisieren.

    Anbei ist auf deinem Host ein 64 oder 32 Bit Linux Debian installiert?

    Gruß Sven
     
  6. M. Zink

    M. Zink New Member

    Ich hab das 64 Bit Debian Lenny nach dem Howto für den perfekten Server hier von Howto Forge installiert.

    Ich hab es inzwischen aber geschafft einen Window Server 2008 Standard 32 Bit zu installieren in Virtual Box und ich muss sagen das ist absolut bemerkenswert wie gut das ganze läuft. Jetzt muss ich natürlich mal schauen was so alles nötig ist um den Exchange zu betreiben und vor allem wie ich das ganze auch so einrichte das der Server hinter dem Schutz des Linux Servers sitzt aber ich bin schon mal zufrieden das es überhaupt geht.

    Wär sogar zu überlegen ob ich nachher nicht einfach die Maschine die ich hier lokal jetzt am Laufen hab auf den Webserver schiede und da gar nicht erst neu installiere sondern einfach bloß importiere. Wozu doppelt arbeit machen. Das Hochladen wird eh das größte Problem bei nem 1000er Upload kann das schon mal ne ganze Zeit dauern.
     
  7. M. Zink

    M. Zink New Member

    Noch mal zurück zu dem Howto um das es ja letztenendes eigentlich hier im Thema geht.

    Ich hatte ja wie zu Anfang geschrieben Probleme mit der Installation von VBox und habe auch ein paar Fehler erhalten. Das Problem konnte ich jetzt lösen und das sollte denke ich im Howto angepasst werden.

    1. Der Public Key war früher von Sun und ist jetzt von Oracle. Die Zeile im HowTo muss wie folgt aussehen.
    2. Aktuell ist nicht mehr Version 3.1 sondern 3.2. Titel im Howto sowie die Zeile für die Installation sollte angepasst werden.

    Ob ggf. noch mehr angepasst werden sollte / muss kann ich nicht sagen. Ich hab jetzt auf einem frisch installierten Debian Lenny einfach nur mittels apt-get install virtualbox-3.2 die Installation laufen lassen und merke bis jetzt keine Probleme. DKMS soll ja für die Kernelmodule sein das kann denke ich nicht schaden (oder ist vielleicht sogar nötig?) und was linux-headers-$(uname -r) build-essential ist weiß ich nicht. Vielleicht kann mir das aber wer erklären. Danke :)
     

Diese Seite empfehlen