Fresh-Install von ISPC 3.0.4.3 auf OpenSuse 12.1 nach PerfectSetup mit Apache2.

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von neurex, 19. Feb. 2012.

  1. neurex

    neurex Member

    Also bei mir lief es nicht so gut...
    Fresh-Install von ISPC 3.0.4.3 auf OpenSuse 12.1 nach PerfectSetup mit Apache2.

    Wenn ich Apache2 jetzt starte erhalte ich folgendes:

    in der error_log steht dazu folgendes:

    Die Daten (User und Passwort) in der vlogger-dbi.conf stimmen mit denen der config.inc.php von ISPConfig überein...

    Woran kann das noch liegen?
     
  2. Till

    Till Administrator

    Kannst Du Dich mit den Zugangsdaten in /etc/vlogger-dbi.conf in mysql einloggen? Wenn ja, dann fehlt möglicherweise ein perl Modul wie das perl library für mysql.
     
  3. neurex

    neurex Member

    Ja, ich kann mich mit den Zugangsdaten wunderbar von der CLI aus einloggen. Hab das Problem aber gerade selber gefunden...

    vlogger war gar nicht installiert. Da das nicht im PS-Tutorial erwähnt wurde ging ich davon aus das vlogger nun bestandteil eines anderen Paketes wurde und hab mich darum gar nicht weiter gekümmert. Nachdem ich es gerade installiert habe kommt zumindest kein MySQL connection problem mehr, den Rest muss ich noch testen...

    Oder sollte der doch schon in einem anderen Paket mit drin sein?
     
  4. Till

    Till Administrator

    vlogger liegt ISPConfig bei, muss also nicht extra installiert werden. Es wird also wie ich vermutet hatte ein Perl Paket gefehlt haben, das jetz bei der vlogger Installation als Abhängigkeit mitinstalliert wurde so dass der ISPConfig beiliegende vlogger jetzt geht.

    Welche Abhängigkeiten hat er denn bei der Installation von vlogger angezeigt, die jetzt mitinstalliert wurden?
     
  5. neurex

    neurex Member

    Okay, dann kann ich ja vlogger als rpm wieder deinstallieren.

    In diesem Fall hat das Paket perl-DBD-mysql gefehlt (und auch perl-DBI aber das ist eine Abhängigkeit des ersten weshalb es mitinstalliert wird).

    Trotzdem vielen Dank für deine schnelle Hilfe Till :)
     
  6. sandy65

    sandy65 New Member

    Hallo,

    ich habe ein ähnliches problem mit der installation und dem vlogger. hab versucht vlogger nochmals zu installieren, aber mit yast2 -i vlogger gehts nicht.
    anbei die apache log datei vielleicht habt ihr eine idee?

    vielen dank :)

    [Fri Feb 24 16:50:01 2012] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/ piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly [Fri Feb 24 16:55:01 2012] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/ piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly [Fri Feb 24 17:00:01 2012] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/ piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
     
  7. neurex

    neurex Member

    Probier mal folgendes:

    yast2 -i perl-DBD-mysql perl-DBI

    und starte dann den Apache2 neu.
     
  8. sandy65

    sandy65 New Member

    ... danke für dein feedback, hat leider nichts geholfen. immer noch die selben fehlermeldungen in der apache logdatei :(

    was könnte ich noch versuchen?
     
  9. neurex

    neurex Member

    Existiert eine /etc/vlogger-dbi.conf Datei und stimmt deren Inhalt (insbesondere Passwort und User) mit dem aus der config.inc.php von ISPConfig (müsste unter /usr/local/ispconfig irgendwo zu finden sein) überein?
     
  10. sandy65

    sandy65 New Member

    ja, es existiert die vlogger-dbi.conf und der enthaltene user ist mit dem selben passwort in der /usr/local/ispconfig/server/lib/config.inc.php

    ich kann mich mit dem user aus der vlogger-dbi.conf auch an phpmyadmin anmelden
     
  11. neurex

    neurex Member

    Okay jetzt wird es langsam schwer. Entweder es fehlen immernoch Abhängigkeiten oder es ist etwas komplett anderes...

    Um den ersten Fall ausschließen zu können führe mal ein:

    rpm -ivh http://ftp5.gwdg.de/pub/opensuse/re...enSUSE_12.1/noarch/vlogger-1.3-6.1.noarch.rpm

    vlogger wird zwar schon mitgeliefert bei ISPConfig aber vielleicht löst das noch ein paar Abhängigkeiten auf. Deinstalliere es dann aber wieder und schau ob die vlogger-dbi.conf auch noch sei heißt.
     
  12. sandy65

    sandy65 New Member

    :( .. hab das rpm packet installiert und wieder deinstalliert, sowie die vlogger-dbi.conf nach der deinstallation wieder unbenannt. leider immer noch das selbe.

    könnte es sein, dass das mit dem zugriffsfehler auf /srv/www/htdocs zu tun hat?

    [Sat Feb 25 16:10:02 2012] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/

    piped log program ' /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd' failed unexpectedly
     
  13. neurex

    neurex Member

    Nein eigentlich nicht vlogger müsste trotzdem arbeiten...

    Ich hatte haargenau die selbe Fehlermeldung aber bei mir haben eben die oben genannten Pakete gefehlt. Du hast den Server aber nach dem PerfectSetup für openSUSE 12.1 aufgesetzt, oder?
     
  14. sandy65

    sandy65 New Member

    ja, 1:1. -- na, schöne sch***

    hab schon überlegt das ganze nochmals zu probieren. ich starte vorübergehend den server um mitternacht neu, ansonsten "stirbt" das ding täglich seinen langsamen tod
     
  15. gguem

    gguem New Member

    genau das selbe problem hier ...

    hab schon versucht, alle perl-date perl-time module zu installieren. leider kein erfolg.
     
  16. Till

    Till Administrator

    Nein.

    Ruf den Befehl mal manuell auf um zu sehen was für eine Fehlermeldung er bringt:

    Code:
    /usr/local/ispconfig/server/scripts/vlogger -s access.log -t "%Y%m%d-access.log" -d "/etc/vlogger-dbi.conf" /var/log/ispconfig/httpd
     
  17. gguem

    gguem New Member

    Hallo. Tut sich nichts. Die selbige Fehlermeldung kommt immer noch alle paar Minuten im error.log. Einzig eine Überprüfung der Logfiles in /var/log/ispconfig/httpd ergibt, dass 3 von 6 access.log alle 3 - 5 Minuten aktualisiert werden.

    Besitzen alle die selben Rechte.
     
  18. sandy65

    sandy65 New Member

    Hallo Till,

    Befehl eingeben -> tut sich nicht, nochmals "enter" kommt folgendes:

    Use of uninitialized value $vhost in lc at /usr/local/ispconfig/server/scripts/vlogger line 385, <STDIN> line 1.
    Use of uninitialized value $reqsize in pattern match (m//) at /usr/local/ispconfig/server/scripts/vlogger line 463, <STDIN> line 1.
    Use of uninitialized value $reqsize in numeric gt (>) at /usr/local/ispconfig/server/scripts/vlogger line 463, <STDIN> line 1.
     
  19. Till

    Till Administrator

    Das ist ok, da der Befehl ja auf eine Logzeile wartet. Dann weiß ich auch nicht arum es auf der SuSE Version nicht läuft.
     
  20. sandy65

    sandy65 New Member

    ... so, der nächste supergau. nachdem zufällig im ispconfig heute um 15:00 gesehen habe das ein ein apache update durchgeführt wurde kommt nun

    DBI connect('database=dbispconfig;host=localhost:3306','ispconfig',...) failed: Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2) at /usr/local/ispconfig/server/scripts/vlogger line 257

    sowie

    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.
    Warning: SuexecUserGroup directive requires SUEXEC wrapper.

    der zugriff apache <-> mysql funktioniert nicht mehr (webshop)

    und ich bin mit meinem latein am ende.
    weiß hier bitte jemand rat? ich bin echt schon am verzweifeln!!! [​IMG]
     

Diese Seite empfehlen