FTP - irgendwie will es nicht

Dieses Thema im Forum "Server Administration" wurde erstellt von MaKraKa, 23. Nov. 2007.

  1. MaKraKa

    MaKraKa New Member

    Hallo Zusammen

    habe mir gestern ISConfig unter debian auf meinen Root gespielt. Läuft auch soweit alles. Nun habe ich alles angelegt, jedoch blicke ich nicht, wo ich ftp anlegen kann und wie ich dann darauf zugreife.
    Bin sicher nicht dumm und hab bissl Ahnung, aber hab alles versucht und nix gefunden.
    Habe 4 IPS. Die erste habe ich der beim rootserver anhängenden IP gegeben. Die anderen 3 habe ich bei INWX und schon auf die neuen IPS eingestellt.

    Wer kann mir da mit dem FTP weiterhelfen?

    Gruß
    MaKraKa
     
  2. Till

    Till Administrator

    Ganz einbfach:

    1) Webseite anlegen.
    2) Benutzer auf der Reiterkarte email & User anelegen. Soll der User Zugriff auf das Hauptverzeichnis des Webs haben, nicht vergessen, die "Administrator" Checkbox zu aktivieren.
    3) Mit diesen Benutzerdaten die Du dort angelegt hast per FTP einloggen.

    Das steht übrigens auch alles im Handbuch ;)
     
  3. MaKraKa

    MaKraKa New Member

    Hallo Till,

    danke für deine Hilfe. Hat auch soweit jetzt geklappt. Nur leider habe ich das Problem, dass er mir bei der Hauptdomain keinen ftp login zulässt. Erhalte da die Meldung das nur "530 this Server is anonymus only". Wenn ich das mache, also dann ohne Daten, komem ich zwar auf den Server (was sicher nicht so sein soll), aber kann nix uppen.
    Auch über den Web-Ftp komme ich nicht dran. Erhalte immer die Meldung, dass Login falsch ist.

    Wenn ich von den weiteren externen urls, die auf eine der 4 ips gehen, auf nen anderen UserFTP zugreifen will, erhalte ich auch keine Verbindung. Kommt irgendwann was wegen Zeitlimit

    Gruß
    MaKraKa
     
  4. Till

    Till Administrator

    FTP ist nicht abhängig von der Domain sondern vom Benutzernamen. Sie bitte nach, ob der Benutzer in der datei /etc/passwd steht.
     
  5. MaKraKa

    MaKraKa New Member

    Ja, stehen drin. Hab da aber auch ne Zeile dabei

    web4_anonftp:x:12004:12004::/var/www/web4/ftp:/bin/false


    Habs jetzt auch mit den anderen Daten auf der Hauptdomain versucht, aber auch wieder die Meldung wegen anonymus ftp...
     
    Zuletzt bearbeitet: 26. Nov. 2007
  6. Till

    Till Administrator

    Dann poste mal den Inhalt der proftpd.conf Datei.
     
  7. MaKraKa

    MaKraKa New Member

    ###################################
    #
    # ISPConfig proftpd Configuration File
    # Version 1.0
    #
    ###################################
    DefaultAddress 127.0.0.1
    <VirtualHost 217.xx.xx.xx4>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </VirtualHost>
    <VirtualHost 217.xx.xx.xx5>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </VirtualHost>
    <VirtualHost 217.xx.xx.xx6>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    </VirtualHost>
    <VirtualHost 217.xx.xx.xx7>
    DefaultRoot ~
    AllowOverwrite on
    Umask 002
    <Anonymous /var/www/web4/ftp>
    User web4_anonftp
    Group web4_anonftp
    UserAlias anonymous web4_anonftp
    UserAlias guest web4_anonftp
    MaxClients 10
    <Directory *>
    <Limit WRITE>
    DenyAll
    </Limit>
    </Directory>
    <Directory /var/www/web4/ftp/incoming>
    Umask 002
    <Limit STOR>
    AllowAll
    </Limit>
    <Limit READ>
    DenyAll
    </Limit>
    </Directory>
    </Anonymous>
    </VirtualHost>
     
  8. MaKraKa

    MaKraKa New Member

    auf der xx7 sollte normal auch eine domain laufen. user hab ich angelegt etc. also auch wie oben beschrieben
     
  9. Till

    Till Administrator

    Poste bitte die proftpd.conf Datei, nicht die proftpd_ispconfig.conf Datei.
     
  10. MaKraKa

    MaKraKa New Member

    öhm, die gibt es nicht

    hab nur
    proftpd_ispconfig.conf
    und
    proftpd_ispconfig.conf~

    :(


    das hätte ich noch
    vsftpd.conf
     
  11. Till

    Till Administrator

    Wirf bitte mal einen Blick in das perfect setup tutorial für Deoine Linuxdistribution und installiere proftpd wie es dort beschrieben ist.
     
  12. MaKraKa

    MaKraKa New Member

    Hab ich versucht, aber erhalte dann:

    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    debian64:~# apt-get install proftpd ucf
    Reading package lists... Done
    Building dependency tree... Done
    ucf is already the newest version.
    Suggested packages:
    proftpd-doc
    The following packages will be REMOVED:
    vsftpd
    The following NEW packages will be installed:
    proftpd
    0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
    Need to get 0B/847kB of archives.
    After unpacking 2286kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Preconfiguring packages ...
    (Reading database ... 38429 files and directories currently installed.)
    Removing vsftpd ...
    Stopping FTP server: vsftpd.
    Selecting previously deselected package proftpd.
    (Reading database ... 38385 files and directories currently installed.)
    Unpacking proftpd (from .../proftpd_1.3.0-19_amd64.deb) ...
    Setting up proftpd (1.3.0-19) ...
    Starting ftp server: proftpd - IPv4 getaddrinfo 'debian64' error: Name or servic e not known
    - warning: unable to determine IP address of 'debian64'
    - error: no valid servers configured
    - Fatal: error processing configuration file '/etc/proftpd/proftpd.conf'
    failed!
    invoke-rc.d: initscript proftpd, action "start" failed.
    dpkg: error processing proftpd (--configure):
    subprocess post-installation script returned error exit status 1
    Errors were encountered while processing:
    proftpd
    E: Sub-process /usr/bin/dpkg returned an error code (1)
     
  13. MaKraKa

    MaKraKa New Member

    ok, hab mal geschaut. proftp verzeichnis war da und das file dann auch. hab auch die ipv6 geändert, wie da in der anleitung steht.
     
  14. MaKraKa

    MaKraKa New Member

    #
    # /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
    # To really apply changes reload proftpd after modifications.
    #

    # Includes DSO modules
    Include /etc/proftpd/modules.conf

    # Set off to disable IPv6 support which is annoying on IPv4 only boxes.
    UseIPv6 off

    ServerName "Debian"
    ServerType standalone
    DeferWelcome off

    MultilineRFC2228 on
    DefaultServer on
    ShowSymlinks on

    TimeoutNoTransfer 600
    TimeoutStalled 600
    TimeoutIdle 1200

    DisplayLogin welcome.msg
    DisplayFirstChdir .message
    ListOptions "-l"

    DenyFilter \*.*/

    DefaultRoot ~
    IdentLookups off
    ServerIdent on "FTP Server ready."

    # Port 21 is the standard FTP port.
    Port 21

    # In some cases you have to specify passive ports range to by-pass
    # firewall limitations. Ephemeral ports can be used for that, but
    # feel free to use a more narrow range.
    # PassivePorts 49152 65534

    # To prevent DoS attacks, set the maximum number of child processes
    # to 30. If you need to allow more than 30 concurrent connections
    # at once, simply increase this value. Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances 30

    # Set the user and group that the server normally runs at.
    User proftpd
    Group nogroup

    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask 022 022
    # Normally, we want files to be overwriteable.
    AllowOverwrite on

    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    # PersistentPasswd off

    # Be warned: use of this directive impacts CPU average load!
    #
    # Uncomment this if you like to see progress and transfer rate with ftpwho
    # in downloads. That is not needed for uploads rates.
    # UseSendFile off

    TransferLog /var/log/proftpd/xferlog
    SystemLog /var/log/proftpd/proftpd.log

    <IfModule mod_tls.c>
    TLSEngine off
    </IfModule>

    <IfModule mod_quota.c>
    QuotaEngine on
    </IfModule>

    <IfModule mod_ratio.c>
    Ratios on
    </IfModule>


    # Delay engine reduces impact of the so-called Timing Attack described in
    # http://security.lss.hr/index.php?page=details&ID=LSS-2004-10-02
    # It is on by default.
    <IfModule mod_delay.c>
    DelayEngine on
    </IfModule>

    <IfModule mod_ctrls.c>
    ControlsEngine on
    ControlsMaxClients 2
    ControlsLog /var/log/proftpd/controls.log
    ControlsInterval 5
    ControlsSocket /var/run/proftpd/proftpd.sock
    </IfModule>

    <IfModule mod_ctrls_admin.c>
    AdminControlsEngine on
    </IfModule>

    # A basic anonymous configuration, no upload directories.

    # <Anonymous ~ftp>
    # User ftp
    # Group nogroup
    # # We want clients to be able to login with "anonymous" as well as "ftp"
    # UserAlias anonymous ftp
    # # Cosmetic changes, all files belongs to ftp user
    # DirFakeUser on ftp
    # DirFakeGroup on ftp
    #
    # RequireValidShell off
    #
    # # Limit the maximum number of anonymous logins
    # MaxClients 10
    #
    # # We want 'welcome.msg' displayed at login, and '.message' displayed
    # # in each newly chdired directory.
    # DisplayLogin welcome.msg
    # DisplayFirstChdir .message
    #
    # # Limit WRITE everywhere in the anonymous chroot
    # <Directory *>
    # <Limit WRITE>
    # DenyAll
    # </Limit>
    # </Directory>
    #
    # # Uncomment this if you're brave.
    # # <Directory incoming>
    # # # Umask 022 is a good standard umask to prevent new files and dirs
    # # # (second parm) from being group and world writable.
    # # Umask 022 022
    # # <Limit READ WRITE>
    # # DenyAll
    # # </Limit>
    # # <Limit STOR>
    # # AllowAll
    # # </Limit>
    # # </Directory>
    #
    # </Anonymous>



    ------------------------

    wenn ich den restart wie in anleitung mache, kommt:

    debian64:~# /etc/init.d/proftpd restart
    Stopping ftp server: proftpd.
    Starting ftp server: proftpd - IPv4 getaddrinfo 'debian64' error: Name or service not known
    - warning: unable to determine IP address of 'debian64'
    - error: no valid servers configured
    - Fatal: error processing configuration file '/etc/proftpd/proftpd.conf'
    failed!
    debian64:~#
     
  15. Till

    Till Administrator

    Du musst mal den Hostnamen Deines Servers richtig setzen, damit proftpd überhaupt startet.

    1) den vollen Hostnamen, z.B. server1.domain.tld in die Datei /etc/hostname eintragen.
    2) aufrufen:

    hostname -F /etc/hostname

    3) Sicherstellen dass für den Hostnamen eine Zeile in /etc/hosts drin steht, die auf die IP Adresse Deines Servers verweist.
     
  16. MaKraKa

    MaKraKa New Member

    So, hab eben geschaut

    Da steht keine Zeile drinne mit der IP :(
     
  17. Till

    Till Administrator

    Dann füg doch eine ein. Faormat:

    IPAdresse HostnameDesServers
     
  18. MaKraKa

    MaKraKa New Member

    So, ok is drinne. Hab das gleich für alle 4 ips gemacht

    Mal zwischen drin "Danke für deine Geduld, die du hast"
     
  19. MaKraKa

    MaKraKa New Member

    Mhh, übers webftp komme ich nun mit den Daten rein, aber ned über ftp ^^
     
  20. Till

    Till Administrator

    Poste bitte mal die Ausgabe von:

    netstat -tap | grep ftp

    und

    iptables -L
     

Diese Seite empfehlen