FTP über TLS hängt bei Login

Dieses Thema im Forum "Allgemein" wurde erstellt von fireman, 25. Aug. 2013.

  1. fireman

    fireman New Member

    Hallo Zusammen

    ich haber nach dieser Anleitung meinen Server installiert: The Perfect Server - Debian Wheezy (Apache2, BIND, Dovecot, ISPConfig 3) | HowtoForge - Linux Howtos and Tutorials

    Alles läuft auch ohne Probleme, nur wenn ich mich über FTP/TLS verbinden möchte, hängt Filezilla mit folgender Meldung:

    Code:
    Status:    Verbindung hergestellt, warte auf Willkommensnachricht...
    Antwort:    220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Antwort:    220-You are user number 2 of 50 allowed.
    Antwort:    220-Local time is now 22:51. Server port: 21.
    Antwort:    220-This is a private system - No anonymous login
    Antwort:    220-IPv6 connections are also welcome on this server.
    Antwort:    220 You will be disconnected after 15 minutes of inactivity.
    Befehl:    AUTH TLS
    Antwort:    234 AUTH TLS OK.
    Status:    Initialisiere TLS...
    
    Also muss es ja irgendwie am Zertifikat (welches ich schonmal neu erstellt habe) bzw. an SSL liegen.

    Im pure-ftpd log taucht nichts auf. Ohne SSL geht der Login ohne Probleme.

    OS: Debian 7.1

    Ich hab den Server auf ispconfig 3.0.5.3 geupdated.

    Danke!

    Gruß
    fireman
     
    Zuletzt bearbeitet: 25. Aug. 2013
  2. magenbrot

    magenbrot Member

    probier mal dich im "passive mode" zu verbinden. oder deaktiviere testweise vorhandene Firewalls (zuerst die auf deinem Server).
     
  3. fireman

    fireman New Member

    Hallo

    leider hat das nichts gebracht. Ich habe jetzt aber folgende Zeile im Log gefunden:

    Code:
     [WARNING] Sorry, cleartext sessions are not accepted on this server.#012Please reconnect using SSL/TLS security mechanisms.
    
    Ich verbinde mich mittels filezilla über explizites TLS. Daran kann es also nicht liegen.

    Ich hab nach der Fehlermeldung gegoogeld, aber die Treffer haben mich leider nicht weitergebracht.

    Weiß sonst noch jemand rat?

    Vielen Dank!
     
  4. Till

    Till Administrator

    Hast du eine firewall oder einen router mit firewall vor dem server? Der häufigste fehler ist die firewall bei ftp wie magenbrot bereits geschrieben hat und bei firewall problemen steht auch nichts im log. Ansonsten kannst du mal versuchen das ssl cert des ftp servers neu zu erstellen, möglicherweise ist es defekt.
     
  5. fireman

    fireman New Member

    Hallo Till,

    vielen Dank für deine Antwort. Ja, ich habe die normale ispconfig firewall laufen. Daher dachte ich das es von dem her keine Probleme geben sollte. Allerdings ist es ein vServer (strato). Und ich erinnere mich dunkel, dass man bei vServern die ispconfig firewall deaktivieren sollte ...

    Kann das sein?
    Aber eigentlich hätte es doch dann über die Angabe von PassivePorts in der pure-ftpd config und der Freischaltung dieser an der Firewall funktionieren müssen?

    Das Zertifikat hab ich übrigens schonmal neu erstellt, das hat nichts geädert.

    Gruß
    fireman
     
  6. Till

    Till Administrator

    Deaktivier die Firwall bitte mal in ispconfig oder stoppe die bastille firewall auf der Shell, dann warte min. 1 Minute und versuch es nochmal.
     
  7. fireman

    fireman New Member

    Hallo Till

    bin endlich dazugekommen weiterzumachen. Habe die Firewall deaktiviert, jetzt hänge ich bei der Meldung

    Code:
    Befehl:    AUTH TLS
    Antwort:   234 AUTH TLS OK.
    Status:    Initialisiere TLS...
    Fehler:    Herstellen der Verbindung zum Server fehlgeschlagen
    Im syslog steht folgendes:

    Code:
     17 20:03:10 hostname pure-ftpd: (?@xxx.xxx.xxx.xxx) [WARNING] Sorry, cleartext sessions are not accepted on this server.#012Please reconnect using SSL/TLS security mechanisms.
    Sep 17 20:03:15 hostname pure-ftpd: (?@xxx.xxx.xxx.xxx) [INFO] New connection from xxx.xxx.xxx.xxx
    
    Das kann aber fast nicht sein, da ich in Filezila bei Verschlüsselung folgendes gewählt habe:
    Code:
    Explizites FTP über TLS erfordern
    Liegt es am Ende doch am Client? Wäre das erste mal das ich mit Filezilla Probleme habe, deswegen habe ich das bis jetzt kategorisch ausgeschlossen.

    Danke & Gruß


    /edit
    Habe jetzt testweise mal FlashFXP ausprobiert, hier auch kein Erfolg.
    Bekomme hier folgende Meldung.

    Code:
    [R] AUTH SSL
    [R] 500 This security scheme is not implemented
    [R] AUTH TLS
    [R] 234 AUTH TLS OK.
    [R] Connected. Negotiating SSL/TLS session
    [R] Failed TLSv1.2 negotiation, disconnected
    [R] Failed SSL/TLS negotiation, disconnected
    [R] Connection failed (Connection closed by server)
    Wähle ich direkt TLS aus, kommen die ersten 2 Zeilen natürlich nicht. Im syslog habe ich dieselbe Fehlermeldung. Jetzt kann es natürlich noch an meinem Heimnetzwerk-Setup liegen ... (2 Router, da einer Zwangzugewiesen vom Provider, mit dem kann ich aber leider nichts anfangen. Mein Router ist allerdings nicht in der DMZ vom Zwangsrouter sondern die Beiden routen nur via IP (also per DHCP), vermute hier könnte das Problem liegen). Werde es morgen aus der Arbeit nochmal probieren mit jetzigem Server-Setup.



    /edit #2

    Habe es jetzt nochmal probiert. Firewall ist immer noch deaktiviert. Es funktioniert einwandfrei. Scheint tatsächlich an den zwei hintereinander geschalteten Routern zu liegen. Werde die Firewall aktivieren und das Ganze nochmal testen.
    Sorry for all the trouble ;-) aber nochmals danke für Deine Hilfe Till!
     
    Zuletzt bearbeitet: 18. Sep. 2013

Diese Seite empfehlen