FTPS funktioniert nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von redi78, 4. Juni 2012.

  1. redi78

    redi78 Member

    Hallo Leute,

    ich erhalte mit Filezilla bei "Explizites FTP über TLS" folgende Fehlermeldung:
    Code:
    [SIZE=1][COLOR=#008000][SIZE=1][COLOR=#008000]
    500 This security scheme is not implemented
    [/COLOR][/SIZE][/COLOR][/SIZE]
    Sollte FTPS nicht von Haus aus funktionieren?

    lg redi78
     
  2. Till

    Till Administrator

    Versuch mal bitte folgendes:

    1) SSL Zert erstellen:

    mkdir -p /etc/ssl/private/
    openssl req -x509 -nodes -newkey rsa:1024 -keyout \
    /etc/ssl/private/pure-ftpd.pem \
    -out /etc/ssl/private/pure-ftpd.pem
    chmod 600 /etc/ssl/private/*.pem

    2) TLS aktivieren:

    cd /etc/pure-ftpd/conf
    echo 1 > TLS

    3) pure-ftpd neu starten.
     
  3. redi78

    redi78 Member

    mhh... klappt nicht

    Code:
     
    [EMAIL="root@rdssrv1:/"]root@rdssrv1:/[/EMAIL]# sudo /etc/init.d/pure-ftpd restart
    sudo: /etc/init.d/pure-ftpd: command not found
    [EMAIL="root@rdssrv1:/"]root@rdssrv1:/[/EMAIL]#
    
     
  4. redi78

    redi78 Member

    ups... das hier ist ja der richtige Befehl:

    Code:
    /etc/init.d/pure-ftpd-mysql [B][COLOR=#ff0000]restart[/COLOR][/B]
    

    Leider erhalte ich jetzt folgende Fehlermeldung vom Filezilla zurück:

    Code:
    [SIZE=1][COLOR=#ff0000][SIZE=1][COLOR=#ff0000]
    GnuTLS error -53: Error in the push function.
    [/COLOR][/SIZE][/COLOR][/SIZE]
    Was nun?
     
  5. Till

    Till Administrator

    pure-ftpd ist der name des Programms, das heißt nicht dass das start script auch so heißt. Schau mal in /etc/init.d/ nach wie das start script heißt, ich denke es heißt pure-ftpd-mysql
     
  6. Till

    Till Administrator

    Siehe FAQ:

    How to enable verbose logging in pure-ftpd on Debian Linux « FAQforge
     

Diese Seite empfehlen