geteilte IP obwohl alles richtig ist

Dieses Thema im Forum "Allgemein" wurde erstellt von AndréS, 23. Okt. 2007.

  1. AndréS

    AndréS New Member

    Hallo Leute, Hallo Till,

    also ich habe da nun ein kleines Problem. Warum auch immer. Es lief alles super, habe auch nichts gemacht, außer ebenhalt regelmäßig den Server geupdated. Nun, wenn ich jetzt eine Domain anlege. Kommt immer geteilte IP. Obwohl sie gar nicht geteilt sein kann. Ist nur einmal alles vorhanden und scheint auch alles toll zu laufen. Wie gesagt, scheint.

    Habe für einen Kunden die Domain www.pflegehamburg.de übernommen, und ich bekomme nur geteilte IP. Auch bei einer alten Domain, die schon sehr lange übertragen ist heute aber erst eingerichtet worden istbekomme ich die Meldung.
    www.propbuilder.de

    woran kann das liegen? Ich hatte gerade vor ein paar Tagen ein größeres Update des Servers, auch der Dienste per apt-get update und apt-get upgrade gemacht. Liegt es daran?
    Welche Logs braucht ihr, dann hole ich die schnell.

    Vielen Dank euch allen


    André
     
  2. Till

    Till Administrator

    Überprüf bitte mal, ob die IP-Adresse von:

    ping www.pflegehamburg.de

    mit der IP-Adresse übereinstimmt, mit der IP des Vhosts in der Datei /etc/apache2/vhosts/Vhost_ispconfig.conf

    Unwahrscheinlich. Ich habe meine Server auch unter Debian und hatte nie ein Problem mit dem Systemupdate.
     
  3. AndréS

    AndréS New Member

    Hi,

    also in der Datei ist die Domain NICHT vorhanden. Also beide.
    Ich glaube mal du meintest Vhosts_ispconfig.conf
    da habe ich auch die Daten drinne gefunden, aber die anderen, die nue angelegeten Domains nicht.

    was muss ich denn nun machen, damit es wieder funktioniert???


    Vielen lieben Dank


    André
     
  4. Till

    Till Administrator

    Dann liegt vermutlich eine Fehlkonfiguration im Apache vor. Sind in dem Verzeichnis Kopien der Datei Vhosts_ispconfig.conf mit einem Datum angehängt? Dann benenn die Datei Vhosts_ispconfig.conf in Vhosts_ispconfig.conf.bak um, als nächstes nimmst Du die neueste Kopie der Datei Vhosts_ispconfig.conf mit angehängtem datum und benennst sie in Vhosts_ispconfig.conf um.

    Dann ruf den Befehl:

    httpd -t

    auf, und poste die Fehlermeldung.
     
  5. AndréS

    AndréS New Member

    Debian-40-etch-32-minimal:/etc/apache2/vhosts# httpd -t
    Syntax error on line 622 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    SSLCertificateKeyFile: file '/var/www/web26/ssl/www.shop-schwarzes-gesoxx.de.key' does not exist or is empty
     
  6. AndréS

    AndréS New Member

    Upa, zu schnell enter gedrückt :) Okay, dass ist die Fehlermeldung. Scheint als wenn das mit dem SSL-Zertifikat nicht geklappt hat.
    Was mache ich denn da nun?
     
  7. Till

    Till Administrator

    Ist das ein signiertes SSL Zertifikat, das schon funktioniert hat? Oder ist das "nur" ein Self signed Zertifikat?
     
  8. AndréS

    AndréS New Member

    na ja, eigentlicht sollte es ein signiertes sein, jedoch hatte ich immer Probleme beim erstellen des Zertifikates. Jedesmal wenn ich die Daten eingegeben habe, folgten Fehler in der Form, dass es als ein selbstsigniertes Zertifikat sei.

    André
     
  9. Till

    Till Administrator

    Um den Fehler zu beheben, musst Du die Felder für das SSL-Zertifikat ausfüllen und dann auf Zertifikat erzeugen gehen, damit ein neuer SSL-Key erstellt wird.

    Das ist kein Fehler, das ist normal bis Du dein Zertifikat "beglaubigt" hast. Du musst erst ein selbst signiertes Zertifikat erstellan, dann den CSR bei thawte, verisign, instantssl oder bei einer anderen Authority zertifizieren lassen. Von denen bekommst Du ein Zertifikat zurück, dessen Inhalt Du in das Feld "Zertifikat" der Webseite einfügst und dann als Aktion speichern auswählen.
     
  10. AndréS

    AndréS New Member

    Danke, nachdem ich das Zertifikat gelöscht habe, funktioniert alles. Gut, ich werde das nochmal ausprobieren mit dem Zertifikat.

    Vielen vielen vielen Dank


    André
     

Diese Seite empfehlen