GitLab Mailversand SMTP

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Benedict, 16. Feb. 2014.

  1. Benedict

    Benedict Member

    Ich habe GitLab installiert (Wheezy, nginx). Um einen externen Mailserver für den Versand zu verwenden habe ich folgende Einstellungen vorgenommen:

    1) In config/environments/production.rb
    ...

    config.action_mailer.delivery_method = :smtp
    ...

    2) In config/initializers/smtp_settings.rb
    ...
    port: 587,
    ...
    authentication: plain,
    enable_starttls-auto: true

    Nach dem Anlegen eines neuen Benutzers in GitLab steht in der Mail-Log insbesondere
    "lost connection after STARTTLS from" und es handelt sich dabei um den "Gitlab-Server". Der angelegte Benutzer soll also benachrichtigt werden, was aber am SMTP scheitert. Postfix habe ich bei der Installation von GitLab ausgelassen. Der in der smtp_settings.rb benannte Mailserver ist Teil eines Multiserver-Setups (openvz) nach den entsprechenden ISPConfig 3 Tutorials - und der geht!

    Was kann man da tun?
    Danke!
     
    Zuletzt bearbeitet: 16. Feb. 2014
  2. Till

    Till Administrator

    versuch es doch mal ohne authentifizierung. wenn der gitlab server eine feste IP hat und es dein server ist, dann kannst Du sie ja zu mynetworks auf dem mailserver hinzufügen in der main.cf
     
  3. Benedict

    Benedict Member

    Hi und danke für de Antwort.

    Die Mailzustellung klappt ja, wenn man halt postfix nach Anleitung mit installiert. Und solange es nur um der Versand geht?! Vielmehr nervt dann das Thema https in Bezug auf GitLab. Die Howto's und Tutorial geben da nicht viel her, finde ich. Rewrites "im" nginx führen dann zu Problemen beim clone/push usw. Auf jeden Fall schau ich mir postifx und die restrictions genau(er) an :) und teste dies separat. Steht sowieso an...

    Gruß
     

Diese Seite empfehlen