Globale Subdomains?

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von max06, 27. Jan. 2009.

  1. max06

    max06 New Member

    'N Abend,

    ich hätt da gleich noch ne Frage :D

    Ich habe mich unter anderem für das Horde-Framework, sowie für die aktuellste phpmyadmin-Version von der offiziellen Website entschieden.

    Horde habe ich noch nicht getestet, aber pma lies sich ohne Probleme in ein beliebiges Verzeichnis installieren.

    Gibt es eine Möglichkeit, eine globale Subdomain einzurichten?
    Ich habe viele Domaintransfers vor mir, und ich will den Inhabern einen umkomplizierten Zugang zu den Tools über http://phpmyadmin.*/ und http://webmail.*/ zur Verfügung stellen.

    Ist dies möglich, und falls ja: wie wird das umgesetzt?

    Grüße,
    max06
     
  2. Till

    Till Administrator

    Du könntest mal versuchen einen vhost in der apache2.conf datei manuell anzulegen, bei dem der servername sowas wie phpmyadmin.* ist
     
  3. max06

    max06 New Member

    die apache2.conf wird nicht überschrieben?

    EDIT: Ich habs fast geschafft... durch einen weiteren Eintrag in der /etc/apache2/sites-enables/000-default.conf (der hoffentlich nicht überschrieben wird!), werden nun alle Aufrufe auf phpmyadmin.* mittels mod_proxy nach http://domain.de:81/phpmyadmin/ weitergeleitet. Sollte zumindest. Alle Aufrufe durch die Proxy enden mit einem 403, Access denied. Rufe ich die Zielurl direkt auf, funktioniert alles.

    Mein Verdacht liegt bei einem störenden Deny from all oder ähnlichem... eventuell irgendwelche Tipps parat?

    Grüße,
    max06
     
    Zuletzt bearbeitet: 28. Jan. 2009
  4. Till

    Till Administrator

    nein. ISPConfig überschreibt nur die Vhosts_ispconfig.conf
     
  5. max06

    max06 New Member

    Das is schonma sehr gut...

    Verbietet die httpd-Konfiguration vom ispconfig-server irgendwie den Zugriff von außerhalb? Momentan enden alle Aufrufe in einem 403...
     
  6. max06

    max06 New Member

    Das Problem wäre gelöst...

    Der Fehler lag in der /etc/apache2/mods-enabled/proxy.conf - ein Order Deny, Allow...
     
  7. MasterTH

    MasterTH New Member

    könntest du deine Config-Datei bitte mal posten, damit andere Leute wissen wie es gemacht werden muss?


    Lösungen die hier gefunden werden sollten der breiten Allgemeinheit zur Verfügung gestellt werden.



    Ich gebs ja zu ich machs auch aus meinem Interesse ;)


    EDIT:
    Hier die configuration die man so abändern kann wie man das braucht.
    Code:
    <VirtualHost SERVER-IP:80>
        DocumentRoot /usr/share/webmail/
        ServerName webmail
        ServerAlias webmail.*
    </VirtualHost>
    
     
    Zuletzt bearbeitet: 2. Feb. 2009
  8. max06

    max06 New Member

    Meine Config sieht da noch nen bissl anders aus :D

    Code:
    <VirtualHost SERVER-IP:80>
            ServerName phpmyadmin.max06.de
            ServerAlias phpmyadmin.*
    
            ProxyPass / http://l101.max06.de:81/phpmyadmin/
    </VirtualHost>
    Statt dem DocumentRoot kann man auch mit besagter Proxy-Pass-Zeile arbeiten. Allerdings ist dann neben einem
    Code:
    $ a2enmod proxy
    auch eine Änderung in der /etc/apache2/mods-enabled/proxy.conf nötig.
    Code:
            <Proxy *>
                    AddDefaultCharset off
                    Order deny,allow                 
                    Allow from all              ##Das hier muss umgedreht werden... Aus Deny → Allow                      
                    #Allow from .example.com
            </Proxy>
    
    Damit funktionierts bei mir einwandfrei...

    Grüße,
    max06
     

Diese Seite empfehlen