htaccess

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von Le-Seaw, 23. Juni 2010.

  1. Le-Seaw

    Le-Seaw Member

    Hallo,

    ich habe die vermutung das mein htaccess nicht geht.
    kennt jemand einen sicheren weg um das zu testen?

    danke euch :)
     
  2. Burge

    Burge Member

    verweigere doch mal in der htaccess den ordner dann merkst du es
     
  3. Le-Seaw

    Le-Seaw Member

    also htaccess und htpassw gehen.
    auch wenn 500 Fehler kommt.

    Woran das nun liegt ist die nächste Frage, und habe noch immer das Problem das ich htaccess und htpassw nicht sehe :(
     
  4. Till

    Till Administrator

    Schau ins errpr.log der webseite, da sollte der Grund für den 500er Fehler drin stehen.
     
  5. Le-Seaw

    Le-Seaw Member

    er findet die htpassw nicht :(
    htaccess:

    AuthType Basic
    AuthName "My Protected Area"
    AuthUserFile /web/test
    Require valid-user

    .htpassw

    axel:$apr1$AmIzD...$oAaa1QOMaOL6H6Xy5yYEW0

    ist nur test, kein richtiges passwort für irgendwas, als Info.
    Und die Dateien liegen beide in /web/test drin aber er findet sie nicht :(
     
  6. Till

    Till Administrator

    Du musst ja auch den Pfad inkl. dateiname angeben. Der Pfad ist auch definitiv nicht /web/test, da sich / hier auf / des Servers und nicht das webroot bezieht.
     
  7. Le-Seaw

    Le-Seaw Member

    also müsste es dann beginnen mit
    /var/www/.....

    oder stehe ich auf dem Schlauch?
     
  8. Till

    Till Administrator

    entweder das, oder Du lässt einfach den / am Anfang weg und nimmst einen relativen Pfad.
     

Diese Seite empfehlen