Installation und Benutzung von OpenVZ auf Debian Lenny (AMD64)

Dieses Thema im Forum "Fragen zu Howtos" wurde erstellt von Falcon37, 14. März 2010.

  1. Falcon37

    Falcon37 New Member

    Hi. Habe einige Probleme beim Tutorial.

    Wenn ich das System jetzt updaten will (apt-get update/upgrade) bekomme ich folgende Fehlermeldung:

    Code:
    Hole:2 [URL="http://download.openvz.org/"]http://download.openvz.org[/URL] lenny Release [8739B]
    Ign [URL="http://download.openvz.org/"]http://download.openvz.org[/URL] lenny Release
    Ign [URL="http://download.openvz.org/"]http://download.openvz.org[/URL] lenny/openvz Packages/DiffIndex
    OK   [URL="http://download.openvz.org/"]http://download.openvz.org[/URL] lenny/openvz Packages
    Es wurden 8936B in 1s geholt (5585B/s)
    Paketlisten werden gelesen... Fertig
    W: GPG error: [URL="http://download.openvz.org/"]http://download.openvz.org[/URL] lenny Release: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY B015D879C64120F1
    W: Probieren Sie »apt-get update«, um diese Probleme zu korrigieren.
    
    Und bei der Eingabe von:
    Code:
    wget -q http://download.openvz.org/debian-systs/dso_archiv_signing_key.asc -O- | apt-key add . && apt-get update
    Folgenden Fehler:

    Code:
    gpg: .: read error: Ist ein Verzeichnis
    gpg: Keine gültigen OpenPGP-Daten gefunden.
    Bei den folgenden Sachen auch...

    Code:
    testsys:~# vzctl create 101 .ostemplate debian-5.0-amd64-minimal .config vps.basic
    non-option ARGV-elements: .ostemplate debian-5.0-amd64-minimal .config vps.basic
    testsys:~# vzctl set 101 .onboot yes .save
    non-option ARGV-elements: .onboot yes .save
    testsys:~# vzctl set 101 .hostname test.example.com .save
    non-option ARGV-elements: .hostname test.example.com .save
    testsys:~# vzctl set 101 .ipadd 192.168.0.101 .save
    non-option ARGV-elements: .ipadd 192.168.0.101 .save
    testsys:~# vzctl set 101 .numothersock 120 .save
    non-option ARGV-elements: .numothersock 120 .save
    testsys:~# vzctl set 101 .nameserver 145.253.2.75 .nameserver 213.191.92.86 .save
    non-option ARGV-elements: .nameserver 145.253.2.75 .nameserver 213.191.92.86 .save
    testsys:~# vzctl start 101
    VE config file does not exist
    /etc/apt/preferences gibt’s bei mir übrigens nicht, Datei nicht gefunden.

    Wollte das Setup auf einem neu installierten AMD64 System ausführen.
    Kann wer helfen? System: Debian Lenny 64 Bit . Die Sprache des Systems ist deutsch deswegen sehen die Umlaute so komisch aus.

    Danke

    Sorry fürn Doppelpost, aber kann mein Kommentar nicht ändern oder löschen... Hätte es eigentlich ins Kommentar geschrieben aber WordPress meint "Hmmm, your comment seems a bit spammy. We're not real big on spam around here.".
     
  2. Till

    Till Administrator

  3. Falcon37

    Falcon37 New Member

    Ach so ok danke. Warum eigentlich WordPress, vB4 hat ein CMS dabei, was auch ganz gut sein soll wie ich gehört habe.

    Bei dem englischen Tutorial habe ich aber auch das Problem das keiner der Einträge in /etc/sysctl.conf existiert hat, habe also alle einfach reinkopiert. Beim ausführen von:

    Code:
    wget  [URL]http://www.proxmox.com/cms_proxmox/cms/upload/vzdump/vzdump_1.1-1_all.deb[/URL]
    dpkg -i vzdump_1.1-1_all.deb
    (ich habe die neue Version genommen, also das eingetippt):

    Code:
    wget  [URL]http://www.proxmox.com/cms_proxmox/cms/upload/vzdump/vzdump_1.2-5_all.deb[/URL]
     dpkg -i vzdump_1.2-5_all.deb
    bekomme ich diese Fehlermeldung:

    Code:
    testsys:/# wget  http://www.proxmox.com/cms_proxmox/cms/upload/vzdump/vzdump_1.2-5_all.deb
    --2010-03-18 17:34:36--  http://www.proxmox.com/cms_proxmox/cms/upload/vzdump/vzdump_1.2-5_all.deb
    Auflösen des Hostnamen »www.proxmox.com«.... 87.230.14.152
    Verbindungsaufbau zu www.proxmox.com|87.230.14.152|:80... verbunden.
    HTTP Anforderung gesendet, warte auf Antwort... 200 OK
    Länge: 26796 (26K) [application/x-debian-package]
    In »vzdump_1.2-5_all.deb.1« speichern.
    
    100%[==============================================================================================================================>] 26.796      --.-K/s   in 0,06s
    
    2010-03-18 17:34:36 (422 KB/s) - »vzdump_1.2-5_all.deb.1« gespeichert [26796/26796]
    
    testsys:/# dpkg -i vzdump_1.2-5_all.deb
    (Lese Datenbank ... 26099 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereiten zum Ersetzen von vzdump 1.2-5 (durch vzdump_1.2-5_all.deb) ...
    Entpacke Ersatz für vzdump ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von vzdump:
     vzdump hängt ab von liblockfile-simple-perl; aber:
      Paket liblockfile-simple-perl ist nicht installiert.
    dpkg: Fehler beim Bearbeiten von vzdump (--install):
     Abhängigkeitsprobleme - lasse es unkonfiguriert
    Verarbeite Trigger für man-db ...
    Fehler traten auf beim Bearbeiten von:
     vzdump
    testsys:/#
    Da aber vzdump jetzt anscheinend in der Repositorie vorhanden ist, habe ich das einfach über apt-get installiert:

    apt-get install vzdump liblockfile-simple-perl liblog-agent-perl

    Dann startet das System, wie es scheint sauber, neu. Die Datei /etc/apt/preferences gibt's allerdings jetzt auch nicht, also lege ich diese an. Das installieren eines amd64 templates lief ohne Probleme ab. Der Test vServer läuft (wenn auch ohne SSH, liegt denke ich mal an der IP die ich vergeben habe) *freu* :)

    Frage mich nun aber ob die Fehler bei der Installation unter Umständen das System in irgendeiner weise beeinträchtigen könnten (nicht dass auf einmal der vServer nicht mehr startet oder sowas in der Art) ? Wie sieht es mit der Wartung aus, läuft das jetzt dauerhaft so gut oder muss jeden Tag OpenVZ geupdatet werden ? Kenne mich in diesem Thema leider überhaupt nicht aus ...:( Kann man das so im produktiven Einsatz laufen lassen? Wie sicher ist so ein vServer wenn er mal gehackt wird - ist das host System geschützt?

    Danke für dieses Tutorial, echt super das es läuft.
     
  4. Till

    Till Administrator

    VB4 gibt es erst seit ein paar Monaten, howtoforge.de seit 2007 :)

    Zu Deinem Problem mit vzdump, soweit ich weiß gibt es vzdump inzwischen in den repos, versuch doch mal ein:

    apt-cache search vzdump
     
  5. Falcon37

    Falcon37 New Member

    Es scheint so das seit ein paar Tagen alles läuft :)
    Die Frage ob ich das so im produktiven Einsatz laufen lassen, konnte ich mir aber noch nicht beantworten, mal kuken.

    Ich meinte warum WordPress generell überhaupt verwendet wird. Gibts howtoforge.com auch erst seit '07 ?
     
  6. Till

    Till Administrator

    Nein. Howtoforge.com gibt es schon deutlich länger. Nur Howtoforge.de gibt es seit 2007.

    Howtoforge.com verwendet ein stark angepasstes Drupal system, das hat aber so seine eigenen Probleme von daher ist wordpress schon eine Verbesserung. Wenn da eben nicht das Umwandlungsproblem mit Sonderzeichen wäre, das muss ich nach jedem Wordpress update wieder rauspatchen.

    Mal sehen wie vbulletin4 so in der Praxis ist, wenn es gut funktioniert stellen wir vielleicht mal darauf um. Ein Nachteil von vbulletin ist für mich immer, dass sie alle Templates in der DB haben und man sie nur über den eingebauten Editor ändern kann, somit ist sowas wie SVN und Patchen nicht möglich.
     
  7. chasing

    chasing New Member

    Hallo,

    ich hab ebenfalls dieses Tutorial benutzt habe aber ein anderes Problem.
    Der VE läuf und Ping auf andere Rechner im LAN funktionieren jedoch kann der VE scheinbar keine Namen auflösen, auf dem realem Server läuft alles.

    Das Netzwerk sieht wie folgt aus:

    Debian VE101 IP 192.168.0.101

    Debian real IP 192.168.0.2

    davor sitze ein Netgear Router der als DHCP-Server dient mit der IP 192.168.0.1, dieser routet alle PC´s im LAN ins WAN über die Kabel-Deutschland Server

    Wo liegt denn mein Denkfehler, hab ich etwas vergessen?
    Wo kann ich nachschauen, was muß ich verändern?

    LG Peter
     
    Zuletzt bearbeitet: 7. Apr. 2010
  8. Burge

    Burge Member

    trag mal der ve auch ein nameserver ein dann sollte es klappen.
     
  9. chasing

    chasing New Member

    THX, nun gehts, mußte erstmal suchen wo ich die KD-Nameserver IP´s finde, normal brauch ich die ja nicht *ggg*
    Gibts denn eine Möglichkeit die Nameserver auch per DHCP vom Router zu übernehmen?
     

Diese Seite empfehlen