[IPConfig 3]pure-ftpd startet nicht

#1
Hallo.
Habe soeben meinen Server neu aufgesetzt. Und zwar nach dem bei
der Installation beiligenden Debian 4.0 HowTo.
Das hat auch alles reibunslos geklappt.
Lediglich der FTP-Server will nicht starten.

Die Logfiles geben nichts aussergewöhnliches her. Nach einem Aufruf von

/etc/init.d/pure-ftpd-mysql start

Bekomme ich als Ausgabe:

Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -B

Die Ausgabe von netstat -tap
lässt aber keinen FTP-Dämon erkennen.

Auch die Server-Statusübersicht in ISPConfig 3 sagt, das der FTP-Server nicht gestartet ist.

Kann mir da jemand auf die Sprünge helfen?
 

Till

Administrator
#4
Wenn pureftpd nicht startet und es sich um einen vserver mit openvz oder virtuozzo handelt dann sind die capabilities im vserver setup falsch eingestellt. Das muss auf dem host server geändert werden. Ob aber Stato das macht weiß ich nicht. Die Befehle dazu sind:

Code:
VPSID=101
for CAP in CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE
do
  vzctl set $VPSID --capability ${CAP}:on --save
done
Alternativ kannst Du höchtens versuchen Dir selbst pureftpd zu kompilieren und dabei die capability Funktionen zu deaktivieren.
 
#7
@Till.
Danke, habe dort mal gelesen. Habe auch einen Trace erstellen können.
Allerdings erkenne ich da jetzt nicht, woran es hapern könnte.
Kennst Du dich damit aus, und könntest mir einen Tip geben?

Code:
execve("/usr/bin/touch", ["touch", "/tmp/file"], [/* 18 vars */]) = 0
uname({sys="Linux", node="h1234567.serverkompetenz.net", ...}) = 0
brk(0)                                  = 0x87ec000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap2(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7f4c000
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=16683, ...}) = 0
mmap2(NULL, 16683, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7f47000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/tls/librt.so.1", O_RDONLY)   = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0`\35\0\000"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0644, st_size=26516, ...}) = 0
mmap2(NULL, 29264, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb7f3f000
mmap2(0xb7f45000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x5) = 0xb7f45000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/tls/libc.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\240O\1"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0644, st_size=1245488, ...}) = 0
mmap2(NULL, 1251484, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb7e0d000
mmap2(0xb7f35000, 28672, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x128) = 0xb7f35000
mmap2(0xb7f3c000, 10396, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb7f3c000
close(3)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/tls/libpthread.so.0", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\360G\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=85010, ...}) = 0
mmap2(NULL, 70104, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0xb7dfb000
mmap2(0xb7e09000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0xd) = 0xb7e09000
mmap2(0xb7e0b000, 4568, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb7e0b000
close(3)                                = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7dfa000
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7df9000
mprotect(0xb7f35000, 20480, PROT_READ)  = 0
set_thread_area({entry_number:-1 -> 6, base_addr:0xb7df96c0, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
munmap(0xb7f47000, 16683)               = 0
set_tid_address(0xb7df9708)             = 17435
rt_sigaction(SIGRTMIN, {0xb7dff450, [], SA_RESTORER|SA_SIGINFO, 0xb7e06660}, NULL, 8) = 0
rt_sigaction(SIGRT_1, {0xb7dff3c0, [], SA_RESTORER|SA_RESTART|SA_SIGINFO, 0xb7e06660}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [RTMIN RT_1], NULL, 8) = 0
getrlimit(RLIMIT_STACK, {rlim_cur=8192*1024, rlim_max=RLIM_INFINITY}) = 0
uname({sys="Linux", node="h1234567.serverkompetenz.net", ...}) = 0
brk(0)                                  = 0x87ec000
brk(0x880d000)                          = 0x880d000
open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=1209216, ...}) = 0
mmap2(NULL, 1209216, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7cd1000
close(3)                                = 0
close(0)                                = 0
open("/tmp/file", O_WRONLY|O_NONBLOCK|O_CREAT|O_NOCTTY|O_LARGEFILE, 0666) = 0
utimes("/proc/self/fd/0", NULL)         = 0
close(0)                                = 0
close(1)                                = 0
exit_group(0)                           = ?
 

Till

Administrator
#8
Damit kenne ich mich auch nicht aus. Ich würde an Deiner stelle einfach pureftpd neu kompilieren mit der option --without-capabilities
 
#11
Hi, ja das der nicht gestartet ist war klar :D.

Nur wie muss ich jetzt vorgehen. Habe das system mehrfahr aufgesetzt und durchprobiert, lief alles ohne Probleme. Nun habe ich es auf einen VPS bei Hosteurope aufgesetzt. Lief genauso alles ohne Probleme. Nur leider lässt sich der FTP nicht starten. Es ist ein Lenny mit Aktuellsten updates und frisch aufgesetzt.

Vielen dank schonma.

MFG

gansa
 
#14
Wenn pureftpd nicht startet und es sich um einen vserver mit openvz oder virtuozzo handelt dann sind die capabilities im vserver setup falsch eingestellt. Das muss auf dem host server geändert werden. Ob aber Stato das macht weiß ich nicht. Die Befehle dazu sind:

Code:
VPSID=101
for CAP in CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE
do
  vzctl set $VPSID --capability ${CAP}:on --save
done
Alternativ kannst Du höchtens versuchen Dir selbst pureftpd zu kompilieren und dabei die capability Funktionen zu deaktivieren.

Hab's versucht kam diese Meldung:

Code:
XX-XX-XXX-XX:~# /etc/init.d/pure-ftpd-mysql restart
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -A -b -O clf:/var/log/pure-ftpd/transfer.log -H -B
XX-XX-XXX-XX:~# VPSID=101
XX-XX-XXX-XX:~# for CAP in CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE
> do
>   vzctl set $VPSID --capability ${CAP}:on --save
> done
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
-bash: vzctl: command not found
XX-XX-XXX-XX:~#
Bin aufm vServer von STRATO mit ISPConfig 3 debian lenny installiert nach diesem Howto.
 
#15
Hallo,

Das kann soweit ich das verstanden habe allerhöchstens (!) der Serververwalter tun, also derjenige mit Zugriff auf die physische Maschine und das Confixx o.ä. das darauf läuft und die virtuellen Server verwaltet und eben auch beschränkt.

Versuche mal meine debs von oben zu installieren falls du unter Debian Etch bist.

forgist
 
#16
Hallo,

Das kann soweit ich das verstanden habe allerhöchstens (!) der Serververwalter tun, also derjenige mit Zugriff auf die physische Maschine und das Confixx o.ä. das darauf läuft und die virtuellen Server verwaltet und eben auch beschränkt.

Versuche mal meine debs von oben zu installieren falls du unter Debian Etch bist.

forgist
ach so danke dir hab den thread etwas schnell durchgelesen.
bin leider unter lenny dafür ist keine lösung bekannt oder?
oder kann ich nicht einfach einen anderen ftp dämon in ispconfig 3 einbinden? pure ftp ist sowieso nicht mein ding, mir ist alles außer das recht.
 

Werbung

Top