isp schreibt conf nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von ts-onlyfree, 21. Nov. 2008.

  1. ts-onlyfree

    ts-onlyfree New Member

    moinmoin

    seit dem update auf 2.2.27 gab es permission-errors nach änderungen im webIF. gerade ist uns folgendes problem aufgefallen, hab dann isp nochmal drüber installiert, die errors sind nun weg aber :

    isp will die conf nicht mehr komplett schreiben. ich habe 4 anbieter angelegt, beim 3 funktionieren einiges webs nicht mehr, sind aber optisch sichtbar und die files sind auch noch da, aber in der apache-conf fehlen genau diese. die anderen haben wir bisher nicht getestet, weil ich die conf nicht weiter unnötig verdrehen will --.--

    hab eben testweise mal ein altes web gelöscht, das wurde auch aus der conf geworfen aber die fehlenden kamen nicht rein. auch änderungen in den webs bringen nix, sie tauchen einfach nicht in der Vhosts_ispconfig.conf auf.

    bin verzweifelt und weiß keinen rat. die writeconf.php hab ich mir eben mal angeschaut, aber kp was da falsch laufen könnte :rolleyes:

    vielleicht hat ja jemand eine idee? ich weiß gerade nicht weiter :(

    thx & cya
    ts-onlyfree
     
  2. Till

    Till Administrator

  3. ts-onlyfree

    ts-onlyfree New Member

    yeah!! damit der thread seinen sinn behält hier meine lösung :

    navigiere nach /etc/apache2/vhosts und benenne die funktionierende .conf um
    Code:
    cd /etc/apache2/vhosts
    mv Vhosts_ispconfig.conf Vhosts_ispconfig.conf.wrk
    
    verzeichnis auflisten und das letzte .conf mit zeitstempel umbennen in Vhosts_ispconfig.conf
    Code:
    ls -lh
    mv Vhosts_ispconfig.conf_21-11-08_20-56-34 Vhosts_ispconfig.conf
    
    dann
    Code:
    httpd -t
    
    und er gab mir folgenden fehler

    Code:
    root@ts-onlyfree:/etc/apache2/vhosts# httpd -t
    Syntax error on line 1239 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    Invalid command 'Option', perhaps misspelled or defined by a module not included in the server configuration
    
    der fehler ist selbst verschuldet... da stand "option +Indexes" ... sollte heißen "options +Indexes"

    THX Till!! =) manchmal sieht man den wald vor lauter bäumen nicht :D
     

Diese Seite empfehlen