ISP3 update fehlerhaft

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von bezier, 25. März 2009.

  1. bezier

    bezier New Member

    hallo,
    ich habe versucht von 3.0.0.9 RC2 auf die finale 3.0.1 upzudaten. dies schlug leider fehl!

    habs mit dem manuellen update versucht. nach der ersten eingabe von "php -q update.php" kam die aufforderung zur eingabe des mysql passwortes und danach die frage nach einem weiteren passwort (ich denke hier war wohl auch das mysql passwort gemeint). danach kam folgende meldung:
    Code:
    ERROR: Unable to drop MySQL database: dbispconfig.
    habs dann nochmal versucht und nun kommt immer folgende meldung:

    Code:
    Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 146
    
    rufe ich nun ispconfig übers web auf kommt folgendes:

    Code:
    [B]Warning[/B]:  Invalid argument supplied for foreach() in [B]/usr/local/ispconfig/interface/web/monitor/lib/module.conf.php[/B] on line [B]38[/B]
    
    und
    Code:
    Table 'dbispconfig.server' doesn't exist
    was kann ich nun tun?

    achja, mein system ist debian lenny.
     
    Zuletzt bearbeitet: 25. März 2009
  2. Till

    Till Administrator

    Wie es aussieht hast Du scheinbar nicht den mysql root User verwendet als Du ISPConfig ursprünglich installiert hast, daher hatte es dann keine ausreichenden Berechtigungen für das Update. Er fragt auch nur einmal nach dem root Passwort außer Du hast ein falsches eingegeben, dann fragt er so lange bis es stimmt.

    Hast Du ein Backup der MySQL Datenbank?

    Poste mal die Zeile 146 der Datei
    /tmp/ispconfig3_install/install/update.php

    der Version die Du bei dir zum Update verwendest.
     
  3. bezier

    bezier New Member

    ich hab den server komplett nach der anleitung auf howtoforge installiert (The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3]).

    und eben auch das entsprechende root mysql passwort eingegeben - nur eben 2x. mit einem anderen passwort hätte doch auch nicht die datenbank gelöschen werden können, oder?

    ein backup hab ich leider nicht.

    hier noch der code aus zeile 146:
    Code:
    $conf['postfix']['vmail_mailbox_base'] = $ini_array['mail']['homedir_path'];
    ist die aktuelle version von heute abend. per wget gezogen.
     
  4. bezier

    bezier New Member

    sehe gerade ich hab noch ein backup der datenbank vom 17.03.

    soll ich das erstmal wieder einspielen?

    mein mysql-root-passwort ist mit sonderzeichen...liegts evtl. daran?
     
    Zuletzt bearbeitet: 25. März 2009
  5. Till

    Till Administrator

    ja, dass kann gut sein. Das mysql passwort darf auf keinen fall irgendwelche Stuerzeichen enthalten, die von der Shell interpretiert werden.

    Du kannst auch nochmal in /root/ nachsehen, ob dort noch ein Backup liegt das der Updater gemacht hat. Ansonsten müsstest Du Dein backup vom 17. einspielen.
     
  6. bezier

    bezier New Member

    hab das backup eingespielt und nochmal versucht. leider der gleiche fehler:

    Code:
    server1:/tmp/ispconfig3_install/install# php -q update.php
    
    
    --------------------------------------------------------------------------------
     _____ ___________   _____              __ _
    |_   _/  ___| ___ \ /  __ \            / _(_)
      | | \ `--.| |_/ / | /  \/ ___  _ __ | |_ _  __ _
      | |  `--. \  __/  | |    / _ \| '_ \|  _| |/ _` |
     _| |_/\__/ / |     | \__/\ (_) | | | | | | | (_| |
     \___/\____/\_|      \____/\___/|_| |_|_| |_|\__, |
                                                  __/ |
                                                 |___/
    --------------------------------------------------------------------------------
    
    
    >> Update
    
    Operating System: Debian Lenny/Sid or compatible
    
    This application will update ISPConfig 3 on your server.
    MySQL root password []: !!$!!meinpasswort12345
    
    Enter password:
    ERROR: Unable to drop MySQL database: dbispconfig.
    
    und die datenbank ist wieder weg...

    hab mich auch noch mal mit phpmyadmin als root und eben dem passwort erfolgreich eingeloggt, also wird das passwort schon stimmen.
     
  7. Till

    Till Administrator

    Siehe meine Post oben:

    Das mysql passwort darf auf keinen fall irgendwelche Stuerzeichen enthalten, die von der Shell interpretiert werden.

    Das $ ist ein Steuerzeichen. Ändere das mysql root Passwort dass es nur aus Zahlen, Buschtaben in klein und Großschreibung sowie dem Unterstrich besteht.
     
  8. bezier

    bezier New Member

    ich hab nach dem 17.03. nur eine website neu erstellt und die ist auch noch ohne inhalt.

    was muss ich löschen damit es keine probleme beim neuen anlegen gibt?
    ich denke mal im /etc/apache2 den eintrag in sites-available und sites-enabled, den web-ordner im entsprechenden clienten.

    der dns-eintrag ist wo? in der datenbank? wenn ja, dann wäre der ja schon weg wegen dem alten backup.

    noch was vergessen?

    wo speichert isp3 das root-mysql-passwort? will das hinterher gerne wieder mit meinen sonderzeichen haben. (hab das mal irgendwo hier gelesen, aber finde es gerade nicht.)
     
  9. Till

    Till Administrator

    Du sollst nichts löschen und ISPConfig speichert das root passwort nicht, sonst würde es ja beim Update nicht danach fragen. Also ändere bitte das root Passwort mit phpmyadmin, spiel die DB zurück und start das Update.
     
  10. bezier

    bezier New Member

    nichts löschen? aber mein backup der datenbank ist vom 17.03. und danach habe ich noch eine website angelegt welche ja nun im apache, mydns und auch im ordner des clients als web20 angelegt wurde.

    wenn ich die website nun wieder anlegen wurde kann es doch zu problemen kommen, alleine ja schon weil er dann wieder ein web20 anlegen will welches ja schon existiert, oder irre ich mich total?

    das passwort wird übrigens gespeichert. zumindest hab ich gerade die datei /usr/local/ispcomfig/server/lib/mysql_clientdb.conf mit dem pw entdeckt.
     
  11. bezier

    bezier New Member

    oje, hab das pw mit phpmyadmin geändert (also nur "abcdefghij12345" ohne sonderzeichen) und hab wieder den selben fehler!
     
  12. Till

    Till Administrator

    Nicht löschen.

    Stimmt, die spielt aber beim update keine Rolle.
     
  13. bezier

    bezier New Member

    sorry, aber es geht nicht. hab gerade wie nachfolgend das passwort neu gesetzt.

    Code:
    /etc/init.d/mysql stop 
    
    /usr/bin/mysqld_safe --skip-grant-tables &
    
    mysql -u root mysql 
    
    UPDATE user SET Password=PASSWORD('testpw_12345_') WHERE User='root';
    
    FLUSH PRIVILEGES;
    
    exit
    
    /etc/init.d/mysql stop 
    
    /etc/init.d/mysql start 
    und es geht nicht - gleicher fehler. er löscht immer die ispconfig datenbank und bricht ab.
     
  14. Till

    Till Administrator

    Keine Ahnung, bei mir haben die updates einwandfrei funktioniert. Es muss daher irgen was spezifisches an Deinem system sein.

    Dann bleibt Dir wirklich nur eine komplette Neuinstallation von ISPConfig. Zur Deinstallation rufts Du einfach das uninstall script auf, welches sich im gleichen verzeichnis wie das Update script befindet und danach dann das Install Script.
     
  15. bezier

    bezier New Member

    oje... ich geh mal davon aus das dann alle einstellungen von ispconfig futsch sind, oder? sind nämlich nicht gerade wenig... :(
     
  16. planet_fox

    planet_fox Super-Moderator

    Welche Einstellungen denn genau meinst du ?
     
  17. Till

    Till Administrator

    ja, die sind bei einer neuinstallation natürlich weg.

    Du kannst es ja nochmal mit dem Update versuchen, das Problem liegt bei deinem mysql root user. das Update schlägt fehl weil ISPConfig mit den daten die Du angibst sowie mit der Konfiguration Deines root users nicht die Datenbank mit den mysql tools "mysqldump" und "mysql" dumpen kann und danach die neue DB einlesen.
     
  18. bezier

    bezier New Member

    also nachdem ich mit phpmyadmin keine datenbank anlegen konnte hab ich mir doch mal echt gedanken um mein system gemacht und siehe da....

    "kleine" sache grosse auswirkung...ein chown -R mysql:mysql ./mysql/ wirkt schonmal wunder...

    warum mein mysql ordner eigentümer und gruppe root hatte weiß der henker...also ich wars nicht, oder?! :eek:

    naja, zumindest lief das update nun durch!

    vielen dank für die unterstützung!!!
     
  19. bezier

    bezier New Member

    nach dem update kommen keine emails mehr an und auch der ftp zugriff funktioniert nicht mehr.

    ich habe ja das mysql root passwort geändert (jetzt ohne sonderzeichen) und ich vermute das häng damit zusammen.

    irgendwo steht wahrscheinlich noch das alte, oder?
     
  20. Till

    Till Administrator

    schau mal in die logfiles und poste die exakten fehlermeldungen.
     

Diese Seite empfehlen