ISPC Roundcube Plugin zickt nach Jessie upgrade

#1
Moin,
nach einem Upgrade von Debian Wheezy auf Jessie läuft alles außer Roundcube, das ich als ISPConfig-Addon installiert habe.
Zuerst gab es Probleme mit dem Apachen, dem die "Order" und "Allow" Direktiven nicht mehr passten; diese habe ich durch die entsprechenden "Require"-Direktiven ersetzt.
Danach heißt es beim Client "404 Not found" und auf dem Server gibt es keinerlei Einträge im Apache Errorlog.

Code:
# RoundCube alias and redirect functions
Alias /webmail /var/www/apps/roundcube
<Directory /var/www/apps/roundcube>
  Options +FollowSymLinks
  DirectoryIndex index.php

  <IfModule mod_php5.c>
    AddType application/x-httpd-php .php

    php_flag magic_quotes_gpc Off
    php_flag track_vars On
    php_flag register_globals Off
    php_value include_path .
  </IfModule>

  AllowOverride All
  Require all granted
</Directory>

# Protecting basic directories:
<Directory /var/www/apps/roundcube/temp>
  Options -FollowSymLinks
  AllowOverride None
  Require all denied
</Directory>
<Directory /var/www/apps/roundcube/logs>
  Options -FollowSymLinks
  AllowOverride None
  Require all denied
</Directory>
<DirectoryMatch \.svn>
  Require all denied
</DirectoryMatch>
Jemand eine Idee?
 

Till

Administrator
#2
Verschiebe die roundcube config Datei mal ins conf-available Verzeichnis vom apache, stell sicher dass sie auf .conf endet und dann aktiviere sie mit dem a2enconf Befehl.
 
#3
Danke dir, Till. Das hat geholfen. Zwar eine Menge Deprecated und andere Warnings, aber zumindest läuft es jetzt.
Wird das conf.d Verzeichnis nicht mehr eingelesen?
[edit]Eigene Antwort: Offensichtlich nicht. Also alles, was noch in conf.d steht, ebenso behandeln.
 
Zuletzt bearbeitet:

Werbung