ISPConfig 2.2.36 released

Dieses Thema im Forum "Allgemein" wurde erstellt von Till, 28. Mai 2010.

  1. Till

    Till Administrator

    ISPConfig 2.2.36 is available for download.

    This ISPConfig release adds support for new Linux versions, updates PHP, ClamaV, Spamassassin and OpenSSL and fixes several bugs.

    Detailed Changelog
    ------------------


    - New: Added support for Fedora 13
    - New: Added support for OpenSuSE 12.0
    - New: Added an option to config.inc.php to NOT have the stats belong to the web concerned, but to root
    - New: Added global stats user to awstats statistics
    - New: Added option in config.inc.php to make log directories belong to root instead of the web owner (more fair concerning quota usage)
    - New: Added random password for admin on installation
    - Updated PHP to 5.2.13
    - Updated Spamassassin to 3.3.1
    - Updated ClamAV to 0.96.1
    - Updated OpenSSl to 0.9.8m
    - Changed: Encryption of SSL keys is now 2048 Bits
    - Changed: Disable webalizer debug setting, can be enabled while actually debugging
    - Changed: Cleanup of the installer and interface code.
    - Changed: Removed duplicate database indexes.
    - Bugfix: FS#509 - anonymous ftp should not list incoming directory
    - Bugfix: correctly purge ALL old access logs from system log directory (useful if cron job might have failed to run one day)
    - Bugfix: The *automatic* whitelist is not a score that can be adjusted
    - Bugfix: FS#887 - Remove hardcoded server_url to allow proxying ISPConfig site
    - Bugfix: Added a patch that fixed a compile problem in ClamAV on Fedora Linux 11 and below.

    Changed system requirements
    -----------------------------

    This release requires that you have these two new Perl modules installed on your system: NetAddr::IP and Archive::Tar

    Installation instructions for the new Perl modules:

    Debian/Ubuntu:

    apt-get install libnetaddr-ip-perl libarchive-tar-perl

    Fedora:

    yum install perl-NetAddr-IP perl-Archive-Tar

    OpenSUSE:

    yast -i perl-NetAddr-IP perl-Archive-Tar

    Mandriva:

    urpmi perl-NetAddr-IP perl-Archive-Tar

    CentOS 5.x (x86_64):

    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el5/en/x86_64/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el5.rf.x86_64.rpm

    CentOS 5.x (i386):

    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el5/en/i386/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el5.rf.i386.rpm

    CentOS 4.x (x86_64):

    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el4/en/x86_64/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el4.rf.x86_64.rpm

    CentOS 4.x (i386):

    yum install perl-Archive-Tar
    rpm -ivh http://apt.sw.be/redhat/el4/en/i386/rpmforge/RPMS/perl-NetAddr-IP-4.027-1.el4.rf.i386.rpm


    Download
    --------

    http://www.ispconfig.org/ispconfig-2/download/

    Forums
    ------

    http://www.howtoforge.com/forums


    Installation Instructions
    -------------------------

    Download the ISPConfig-2.2.36.tar.gz from ispconfig.org:

    http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.36.tar.gz?download


    Installation on the shell as root user:

    tar xvfz ISPConfig-2.2.36.tar.gz
    cd install_ispconfig
    ./setup

    The installer automatically detects the installed ISPConfig version and
    performs an update.
     
  2. hahni

    hahni Active Member

    Diese Fehlermeldungen erhalte ich:

    --
    chmod: cannot access `./install.php': No such file or directory

    ./setup2: line 1090: mysql_config: No such file or directory
    ./setup2: line 1091: httpd: No such file or directory
    ./setup2: line 1092: httpd2: No such file or directory
    ./setup2: line 1093: httpd2: No such file or directory
    ./setup2: line 1103: ip_addresses: No such file or directory
    ./setup2: line 1105: /root/ispconfig/php/php: No such file or directory
    ./setup2: line 1106: /root/ispconfig/dist.info: No such file or directory
    Neustart einiger Dienste...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    httpd not running, trying to start
    ./setup2: line 1143: [: ==: unary operator expected
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ISPConfig system...
    /etc/init.d/ispconfig_server: line 66: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    ISPConfig system stopped!
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ISPConfig system...
    /etc/init.d/ispconfig_server: line 45: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    /etc/init.d/ispconfig_server: line 48: /root/ispconfig/php/php: No such file or directory
    ISPConfig system is now up and running!
    Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzbereit.

    ./setup2: line 1189: cd: /tmp/install_ispconfig/compile_aps/../..: No such file or directory
    --
     
  3. Till

    Till Administrator

    Das sieht so aus als ob Du nicht mit cd ins Install Verzeichnis gewechselt bist, bevor Du das setup gestartet hast oder es wurde sudo benutzt.
     
  4. hahni

    hahni Active Member

    Nein, das war auch die Meldung von 2.2.35!

    Bei 2.2.36 erscheint folgendes:

    --
    make[2]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src'
    make[1]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    make[1]: Entering directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    ===> src/support
    make[2]: Entering directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    gcc -c -I../os/unix -I../include -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I../lib/expat-lite `../apaci` htpasswd.c
    htpasswd.c:101: error: conflicting types for 'getline'
    /usr/include/stdio.h:651: note: previous declaration of 'getline' was here
    make[2]: *** [htpasswd.o] Error 1
    make[2]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    make[1]: *** [build-support] Error 1
    make[1]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    make: *** [build] Error 2
    ERROR: Could not make Apache
    --
     
  5. Till

    Till Administrator

  6. hahni

    hahni Active Member

    Das hatte ich schon beim Update auf 2.2.35 geändert. Wieso war das jetzt wieder überschrieben?
     
  7. Till

    Till Administrator

    Vermutlich irgend ein Debian Update.
     
  8. hahni

    hahni Active Member

    Im Übrigen lag es daran! Vielen Dank, Till!
     
  9. fuxifux

    fuxifux Member

    Ich hab das Update gerade erfolgreich durchgeführt.

    Seither fällt mir auf, dass ich keine als SPAM markierten Mails mehr bekomme,
    dafür kommen SPAMs als normale Mails durch..

    Kann ich irgendwie testen, ob Spamassassin funktioniert, oder hab ich etwas übersehn?

    fuxifux
     
  10. Till

    Till Administrator

    Ruf mal auf:

    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint
     
  11. fuxifux

    fuxifux Member

    Der von Dir vorgeschlagene Befehl brachte:
    Code:
    config: no rules were found!  Do you need to run 'sa-update'?
    Nach einem Aufruf von:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update

    Bleibt dann der Aufruf von:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint

    ohne Rückmeldung, was vermutlich ein gutes Zeichen ist.

    Danke für den Tip!

    EDIT: jetzt hab ich auch entdeckt, dass mein nach dem Y2010-Bug installierter Cron-Aufruf von sa-update auf meinem neuen Server nicht funktioniert hat.
     
    Zuletzt bearbeitet: 28. Mai 2010
  12. baerndorfer

    baerndorfer Member

    Update auf 2.2.36 fehlgeschlagen..

    Servus Forum,

    ich habe soeben versucht von 2.2.35 auf 2.2.36 upzudaten - leider ohne Erfolg.

    Code:
    checking module dependencies and their versions...
    
    ***************************************************************************
    ERROR: the required NetAddr::IP module is installed (3.14),
    but is below the minimum required version 4.000,
    some functionality will not be available.
    
      Used in determining which DNS tests are to be done for each of
      the header's received fields, and used by AWL plugin for extracting network
      address from an IPv6 addresses (and from IPv4 address on nondefault mask).
    
    
    ***************************************************************************
    NOTE: the optional Digest::SHA module is not installed.
    
      The Digest::SHA module is required by the DKIM plugin.
    
    
    ***************************************************************************
    NOTE: the optional Mail::SPF module is not installed.
    
      Used to check DNS Sender Policy Framework (SPF) records to fight email
      address forgery and make it easier to identify spams.
    
    
    ***************************************************************************
    NOTE: the optional IP::Country module is not installed.
    
      Used by the RelayCountry plugin (not enabled by default) to determine
      the domain country codes of each relay in the path of an email.
    
    
    ***************************************************************************
    NOTE: the optional Razor2 module is not installed,
    minimum required version is 2.61.
    
      Used to check message signatures against Vipul's Razor collaborative
      filtering network. Razor has a large number of dependencies on CPAN
      modules. Feel free to skip installing it, if this makes you nervous;
      SpamAssassin will still work well without it.
    
      More info on installing and using Razor can be found
      at http://wiki.apache.org/spamassassin/InstallingRazor .
    
    
    ***************************************************************************
    NOTE: the optional Net::Ident module is not installed.
    
      If you plan to use the --auth-ident option to spamd, you will need
      to install this module.
    
    
    ***************************************************************************
    NOTE: the optional IO::Socket::INET6 module is not installed.
    
      This is required if the first nameserver listed in your IP
      configuration or /etc/resolv.conf file is available only via an
      IPv6 address. Also used by a DCC plugin to access dccifd over network.
    
    
    ***************************************************************************
    NOTE: the optional IO::Socket::SSL module is not installed.
    
      If you wish to use SSL encryption to communicate between spamc and
      spamd (the --ssl option to spamd), you need to install this
      module. (You will need the OpenSSL libraries and use the
      ENABLE_SSL="yes" argument to Makefile.PL to build and run an SSL
      compatibile spamc.)
    
    
    ***************************************************************************
    NOTE: the optional Mail::DKIM module is not installed,
    minimum required version is 0.31, recommended version is 0.37 or higher.
    
      If this module is installed and the DKIM plugin is enabled,
      SpamAssassin will perform DKIM signature verification when DKIM-Signature
      header fields are present in the message headers, and check ADSP rules
      (e.g. anti-phishing) when a mail message does not contain a valid author
      domain signature. Version 0.37 or later is needed to fully support ADSP.
    
    
    ***************************************************************************
    NOTE: the optional LWP::UserAgent module is not installed.
    
      The "sa-update" program requires this module to make HTTP requests.
    
    
    ***************************************************************************
    NOTE: the optional HTTP::Date module is not installed.
    
      The "sa-update" program requires this module to make HTTP
      If-Modified-Since GET requests.
    
    
    ***************************************************************************
    NOTE: the optional Encode::Detect module is not installed.
    
      If you plan to use the normalize_charset config setting to detect
      charsets and convert them into Unicode, you will need to install
      this module.
    
    REQUIRED module out of date: NetAddr::IP
    optional module missing: Digest::SHA
    optional module missing: Mail::SPF
    optional module missing: IP::Country
    optional module missing: Razor2
    optional module missing: Net::Ident
    optional module missing: IO::Socket::INET6
    optional module missing: IO::Socket::SSL
    optional module missing: Mail::DKIM
    optional module missing: LWP::UserAgent
    optional module missing: HTTP::Date
    optional module missing: Encode::Detect
    
    warning: some functionality may not be available,
    please read the above report before continuing!
    
    make: *** No targets specified and no makefile found.  Stop.
    ERROR: Could not make SpamAssassin
    
    
    
    Natürlich bin ich jetzt Ratlos!
    Bis dato haben die Updates immer hervorragend und ohne Probleme geklappt.

    Was muss ich nun machen um meiner Kiste wieder Leben einzuhauchen?
    lg
    baerndorfer
     
  13. Laubie

    Laubie Member

  14. baerndorfer

    baerndorfer Member

    Aha..

    Danke!!

    Werd das mal checken..
    lg
     
  15. baerndorfer

    baerndorfer Member

    Kann ich denn wieder auf 2.2.35 zurück updaten/downgraden wenn das Update auf 2.2.36 schief gelaufen ist?

    Muss ich vorher etwas löschen?
     
  16. Till

    Till Administrator

    Ist nicht nötig, aktualisiere einfach das Perl Modul, wie ich es beschrieben habe. Und bevor Du das ispconfig Update nochmal ausführst, immer:

    mkdir /root/ispconfig

    ausführen.
     
  17. Falloutboy6

    Falloutboy6 Member

    Seit dem ich die neue IspConfig Version installiert habe wird mein AwStats nicht mehr aktualisiert. Im Cron steht alles noch drin aber eine Aktualisierung findet nicht statt. Ist da was dazu bekannt?

    Danke
     
  18. hahni

    hahni Active Member

    Normal ist das jedenfalls nicht. Bei mir treten solche Probleme nämlich nicht auf. Welche Distribution setzt du ein?
     
  19. Falloutboy6

    Falloutboy6 Member

    Debian Lenny

    Davor ging alles wunderbar. Erst seit dem Update habe ich das Problem.
     
  20. Till

    Till Administrator

    Und welche ISPConfig Version hattest Du vorher installiert?
     

Diese Seite empfehlen