ISPConfig 2: Spam-Filter arbeitet nicht

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hahni, 2. Sep. 2011.

  1. hahni

    hahni Active Member

    Hallo zusammen,

    ich habe letzte Woche auf die Version 2.2.40 aktualisiert. Seitdem (auch wenn das Zufall sein kann) arbeitet mein Spam-Filter nicht mehr.

    Alle Mails - auch die augenscheinlich früher als Spam deklariert wurden - werden nicht mehr markiert.

    Woran könnte dies liegen und wie kann ich das beseitigen?

    Viele Grüße

    Hahni
     
  2. hahni

    hahni Active Member

    Ich habe es mittlerweile hinbekommen mit:
    Code:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update --no-gpg
    Merkwürdigerweise ist das Problem nur auf einem Server mit ISPConfig 2 (nach dem Update) aufgetreten.

    Wie auch immer: es funktioniert wieder :)
     
  3. fuxifux

    fuxifux Member

    Ich führe täglich folgendes Skript aus:

    Code:
    #!/bin/sh
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/home/admispconfig/ispconfig/tools/spamassassin/usr/bin
    
    #########################################################################################################################
    #Written by Jason Shewchuk                                                                                              #
    #E-Mail: jason <> shewchuk.ca                                                                                           #
    #Version: 0                                                                                                             #
    #Date Created: Sept. 20, 2006                                                                                           #
    #Date Modified: Sept. 20, 2006                                                                                          #
    #Feel free to use and modify this script.  Let me know of changes you have made so I can learn and improve this script  #
    #########################################################################################################################
    
    #Today's date
    today=$(date +%Y_%m_%d)
    
    #Run sa-update
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
    
    exitcode=$?     #Exit code from sa-update
    
    #Find version of sa-update
    version=$(/home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update -V | grep "sa-update")
    
    if [ $exitcode = 0 ]; then
            echo "An update was available, and was downloaded and installed successfully.  You are now running $version."  | formail -c -I"Subject: sa-update Updated for $today - Updated" -I"From: sa-update@localhost" -I"To: admin@host.com" -I"Received: from Server" | sendmail admin@host.com
    
    elif [ $exitcode = 1 ]; then
            echo "No update was available.  You are still running $version."
    
    else
            echo "An error occured while attempting to download and extract updates.  You are still running $version." | formail -c -I"Subject: sa-update Update Status for $today - Error" -I"From: sa-updater@localhost" -I"To: admin@host.com" -I"Received: from Server" | sendmail admin@host.com
    fi
    
    exit 0
    Das ist ratsam, erledigt Probleme von selbst und meldet sich, wenn spamassasin aktualisiert wird oder das update nicht funktioniert.
     

Diese Seite empfehlen