ISPConfig 3.0.1.4 hostname

Dieses Thema im Forum "Allgemein" wurde erstellt von deadmann85, 21. Sep. 2009.

  1. deadmann85

    deadmann85 New Member

    Hallo,

    ich habe einen Server nach diesem Howto eingerichtet

    Der Perfekte Server - Debian Lenny (Debian 5.0) [ISPConfig 3]

    und anschließend ispCONFIG genau nach Anleitung installiert.

    Unter der IP-Adresse ist der Server erreichbar, unter dem Domainnamen aber nicht.

    Der Server hängt hinter einem Router was muss ich ändern :confused::confused:

    Danke schon mal im Voraus.

    Grus Marcel
     
    Zuletzt bearbeitet: 21. Sep. 2009
  2. Till

    Till Administrator

    Das hat vermutlich nichts mit Deinem Sefver zu tun:

    1) Der domianname muss exsitieren und mit einem DNS A-Record auf die externe IP Deines routers verweisen.
    2) In Deinem router musst Du alle ports, die Du vaon außen erreichen möchtest, auf die interne IP Deines Servers weiterleiten.
     
  3. deadmann85

    deadmann85 New Member

    Und wie kann ich das ändern ich habe schon gegoogelt und habe mir auch andere beiträge angeschut zb irgend wie hat jeder probleme damit ich bin echt ratlos.

    Die sache mit den ports ich habe alle ports für mein server frei gegeben zb. http port 80 zum server ip 192.168.178.22 ist das so richtig?? Ich benutze eine fritz.box als router.:confused:

    Und ne DNS Zone habe ich eingerichtet:confused::confused:

    Muss ich meine resolv.conf datei ändern weil da steht bei mir

    domain fritz.box
    search fritz.box
    nameserver 192.168.178.1

    Und was ist mit bind9 muss ich das auch Installieren oder habe ich das schon mit Installiert???

    Danke im Vorraus

    Grus Marcel
     
    Zuletzt bearbeitet: 22. Sep. 2009
  4. Quest

    Quest Member

    Nochmal langsam und zum Mitschreiben:
    Du hast einen ISP3 Server in deinem lokalen Netzwerk hinter dem Router laufen.
    Du hast alle benötigten Ports im Router an den Server weitergeleitet.
    Du möchtest jetzt, dass dein Server aus den Weiten des Internets erreichbar ist.
    Soweit richtig?

    Dann kommen wir jetzt zum Problem:
    Du berwendest die Domain fritz.box.
    Diese Adresse mag zwar in deinem lokalen Netz bekannt sein, aber das wars dann auch schon.
    Um über eine Domain von Außen erreichbar zu sein musst du dir eine Domain registrieren. Für .de Domains gehst du zu Denic, für .com, .net, .org, ... gehst du zu Internic. Um eine Domain zu registrieren musst du auch noch 2 Nameserver angeben die diese Domain und die Zone dazu verwalten und auf die IP deines Routers verweisen.
    Wenn du keine "echte" Domain brauchst oder mit dem Problem einer dynamischen IP-Adresse zu kämpfen hast würde ich dir den Dienst dyndns.org empfehlen. Da kannst du dir eine Subdomain registrieren die dann immer auf deinen Router zeigt. Moderne Router bieten Funktionen um nach einer neuen Einwahl die Daten bei dyndns automatisch zu aktualisieren.
    Diese Domain kannst du dann mit ISP verwenden und bist aus den Weiten des Netzes erreichbar.
     
  5. deadmann85

    deadmann85 New Member

    Also mein problem ist ich habe eine domain bei dyndns marcelswebserver.ath.cx und sie ist auch erreichbar von zuhause aus oder auch von weiten web der welt und ich kann mich auch unter dieser domain bei ispconfig einloggen das ist alles kein problem.

    Mein Problem ist wenn ich den server installiere dann gebe ich ihn ja ein name und mein server heist server.marcelswebserver.ath.cx der hostname. Und bei der Installation wird beschrieben das ich mich unter den hostname anmelden kann das heist für mich server.marcelswebserver.ath.cx:8080 und das geht nicht. Und leider habe ich damit auch kein zugriff auf meine datenbank weil wenn ich mir eine erstelle und ich will rauf dann öffnet er mir follgende seite server.marcelswebserver.ath.cx/phpmyadmin und das gleiche gilt auch für webmail ich komme einfach nicht rauf er kann die seite nicht finden was soll ich machen Hilfe Hilfe

    Danke im Vorraus

    Grus Marcel
     
  6. deadmann85

    deadmann85 New Member

    Okay das Problem habe ich gelösst ich habe ein fehler bei der installation gemacht aber ein problem gibt es noch ich komme auf phpmyadmin nicht rauf an was liegt das


    Grus marcel
     
  7. deadmann85

    deadmann85 New Member

    Gut das Problem habe ich auch gelöst einfach den ordner phpmyadmin in das verzeichnis var/www kopiern


    grus marcel
     
  8. miglosch

    miglosch New Member

    Auch wenn es vielleicht nicht wirklich etwas bringt, aber ich halte es für keine gute Ideee, den phpmyadmin-Ordner nach /var/www/ zu kopieren. Besser wäre es wahrscheinlich einen symlink anzulegen
     
  9. Quest

    Quest Member

    Bin ich ganz deiner Meinung.
     
  10. deadmann85

    deadmann85 New Member

    Joa ich weiß habe ich auch schon gemacht trotz dem danke für den tipp

    Grus MArcel
     

Diese Seite empfehlen