ISPConfig 3.0.4.1 released

Till

Administrator
#1
ISPConfig 3.0.4.1 is available for download. This release is a bugfix release for ISPConfig 3.0.4.

For a detailed list of changes, please see the changelog section below.

=====================================================
*** New! The ISPConfig 3 manual is now available! ***

Version 1.3 for ISPConfig >= 3.0.4 (Date: 10/25/2011)
Author: Falko Timme <ft@falkotimme.com>

333 pages

The manual can be downloaded from these two links:

ISPConfig 3 Manual « ISPConfig – Hosting Control Panel
Version 1.3 Of The ISPConfig 3 Manual (Date: 10/25/2011) Available | HowtoForge - Linux Howtos and Tutorials
=====================================================

-----------------------------------------------------
- Download
-----------------------------------------------------

The software can be downloaded here:

Download ISPConfig Hosting Control Panel from SourceForge.net

------------------------------------
- Changelog
------------------------------------

=]ISPConfig::ISPConfig 3: Tasklist

--------------------------------------
- Known Issues:
--------------------------------------

Please take a look at the bugtracker:

ISPConfig::All Projects: Tasklist

--------------------------------------
- BUG Reporting
--------------------------------------

Please report bugs to the ISPConfig bugtracking system:

ISPConfig::All Projects: Tasklist

----------------------------------------
- Supported Linux Distributions
----------------------------------------

- Debian Etch (4.0) - Squeeze (6.0)
- Ubuntu 7.10 - 11.10
- OpenSuSE 11 - 12.1
- CentOS 5.2 - 6.0
- Fedora 9 - 15

-----------------------------------------
- Installation
-----------------------------------------

The installation instructions for ISPConfig can be found here:

Documentation « ISPConfig – Hosting Control Panel

or in the text files (named INSTALL_*.txt) which are inside the docs folder of the .tar.gz file.

------------------------------------------
- Update
------------------------------------------

To update existing ISPConfig 3 installations, run this command on the shell:

ispconfig_update.sh

Select "stable" as the update resource. The script will check if an updated version of ISPConfig 3 is available and then download the tar.gz and start the setup script.

Detailed instructions for making a backup before you update can be found here:

How to Update ISPConfig 3 « FAQforge

If the ISPConfig version on your server does not have this script yet, follow the manual update instructions below.

-------------------------------------------
- Manual update instructions
-------------------------------------------

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php
 

nowayback

Well-Known Member
#2
Moinsen,

Sys: Debian 6 stable
Update von 3.0.4 auf 3.0.4.1
Update durchgeführt über ISPConfig -> System -> Do ISPConfig-Update

Keine Probleme während des Updatevorgangs.

Leider wurde der FTP Server danach wieder gestartet, obwohl ich den nur installiert habe aber nicht verwende (ist auch im ISP Config entsprechend eingestellt). Gehe mal davon aus, dass es an dem Updatescript liegt, das einfach alle Dienste neu startet die es verwalten kann ;)

Ein weiteres Problem ist, wie befürchtet, immernoch FS#1801 : german specialchars making trouble in logs

Ich hab aber keine Lust mehr das nochmal aufzumachen. Im Monitor unter ISP Cron habe ich daher halt wieder keine Daten. Beim Updatestatus funktioniert es jedoch auch wenn da ein "?" angezeigt wird anstelle des "ä". Evtl. muss ich mal schauen ob das an mir liegt denn in der DB steht ein "&auml;" drin, so wie es sein sollte.

Vielen Dank für deine Arbeit,

Grüße
nwb
 

Till

Administrator
#3
Leider wurde der FTP Server danach wieder gestartet, obwohl ich den nur installiert habe aber nicht verwende (ist auch im ISP Config entsprechend eingestellt). Gehe mal davon aus, dass es an dem Updatescript liegt, das einfach alle Dienste neu startet die es verwalten kann
Das ist richtig. Du solltest also ftp mal deinstallieren, wenn Du es nicht verwendest.

Ein weiteres Problem ist, wie befürchtet, immernoch FS#1801 : german specialchars making trouble in logs

Ich hab aber keine Lust mehr das nochmal aufzumachen. Im Monitor unter ISP Cron habe ich daher halt wieder keine Daten. Beim Updatestatus funktioniert es jedoch auch wenn da ein "?" angezeigt wird anstelle des "ä". Evtl. muss ich mal schauen ob das an mir liegt denn in der DB steht ein "&auml;" drin, so wie es sein sollte.
Ich kann Dir dazu nur sagen dass es bei mir und den anderen Entwicklern jetzt geht. Du hast sicherlich auch daran gedacht, dass einige Informationen wie Updates nur alle paar Stunden überprüft werden und somit erst nach einer gewissen Zeit andere Daten in die DB geschrieben werden?
 

nowayback

Well-Known Member
#4
Moinsen,

Ich kann Dir dazu nur sagen dass es bei mir und den anderen Entwicklern jetzt geht. Du hast sicherlich auch daran gedacht, dass einige Informationen wie Updates nur alle paar Stunden überprüft werden und somit erst nach einer gewissen Zeit andere Daten in die DB geschrieben werden?
jo daran habe ich gedacht... Ich kann nur soviel sagen: Bei mir gehts nicht :)

Und zwar sieht es folgendermaßen im Moment aus:
In der Datei /var/log/ispconfig/cron.log

Zum 1.: hängt es an
2011-11-24 15:29:02 (10,8 MB/s) - »ISPConfig-3.0.4.1.tar.gz« gespeichert [2687573/2687573]
Da mag dein ISPConfig diese Doppelpfeile nicht.

Zum 2.: hängt es an
W: Fehlschlag beim Holen von http://mirror.hetzner.de/debian/packages/dists/squeeze/Release.gpg Verbindung mit mirror.hetzner.de:80 nicht möglich (213.133.99.97). - connect (110: Die Wartezeit für die Verbindung ist abgelaufen)
Ich hab die Dinge, an denen sich das Script aufhängt mal "fett" markiert.

*** Edit: Hab mal meine locales neu gesetzt, mal sehen ob das Besserung bringt. Wenn nicht wüsste ich nicht, wo ich bei mir noch suchen sollte.... Habe jetzt Standartmäßig de_utf-8 systemweit aktiviert und die alte cron.log gesichert, sowie ne neue leere erstellt. ***


*** Edit2: So sieht der Quelltext aus beim Update Status Monitor:
<div class="systemmonitor-content icons32 ico-ok">Paketlisten werden gelesen...<br>
Abh�ngigkeitsbaum wird aufgebaut...<br>
Statusinformationen werden eingelesen...<br>
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.<br>
</div>
***
Grüße
nwb
 
Zuletzt bearbeitet:

Till

Administrator
#5
Wird bei mir alles korrekt angezeigt untder Debian 6. Siehe angehängten Screenshot mit Pfeilen und DE Umlauten.

Locale:


# locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
 

Anhänge

#7
Moin!
Besten Dank!
Habs zuerst auf dem Testserver aufgespielt, ohne Probleme.
Danach auf dem Produktivsystem - ebenfalls problemfrei.

Bei mir erscheint auch der Status des Servers jetzt wieder fehlerfrei.

Lediglich das Raid-Problem (Keine Anzeige und Fehlermeldung im ISP-Log) bleibt. Aber das stört nicht weiter.

Grüße
Laubie
 

nowayback

Well-Known Member
#11
Moinsen,

ich seh schon, der Fehler liegt irgendwo bei mir aktuell... Ich melde mich wieder wenn ich ihn gefunden hab.

Grüße
nwb
Problem behoben, de Locales wurden zwar übernommen, waren aber aus irgendeinem Grund fehlerhaft, und zwar alle de. Musste se komplett rausschmeißen und solange andere verwenden, danach dann wieder draufpacken.

Vielen Dank für die Mühe.

Grüße
nwb
 
#12
Update durchgelaufen, aber seitdem wird die Jobwarteschlange nicht mehr ausgefuehrt.
Ich habe noch 8 Items in der Liste.
/usr/local/ispconfig/server/server.sh
und
/usr/local/ispconfig/server/cron_daily.sh

laufen ohne Bemaengelung durch. Log ist schon auf Debug gestzt. Aber bisher keinerlei Aenderungen.

Ich geh mal auf die Suche, was da schief laeuft.

EDIT:
im sys_datalog sind die Eintraege alle als status=OK markiert, trotzdem werden sie im BE noch angezeigt.


EDIT & Loesung :
der server.php Prozess war wohl mal aktiv, und hat die ispconfig_lock im System gelassen. Somit wurde die server.php erst gar nicht ausgefuehrt....
 
Zuletzt bearbeitet:
#14
@Till
Problem gefunden. Die ispconfig_lock war im temp vorhanden. Somit wurde garnichts ausgefuehrt.
Warum da eine Leiche von gestern noch dabei war, kann ich nicht sagen...
 
#15
Folgende Fehlermeldung erhalte ich beim hinzufügen eines weiteren Servers vom Installer:

WARNING: Unable to set rights of user in master database: dbispconfig
Query: GRANT SELECT, INSERT, UPDATE ON dbispconfig.`web_traffic` TO 'ispcsrv2'@'XYZ'
Error: String 'XYZ' is too long for host name (should be no longer than 60)
Der Hostname ist tatsächlich mehr als 60-Zeichen lang wurde nur durch XYZ ersetzt. Hat weitreichende folgen nehme ich an oder ist dies wirklich nur ne Warnung?

Dann noch folgendes: Server 1 soll für alles da sein außer Mail, dafür soll Server 2 da sein.
Dann müsste doch bei Server 2 in ISPConfig3>System alles auf Null stehen außer Mail, oder? Und Server zwei müsste bei allem eins stehen haben außer bei Mail. Aber Server 1 benötigt trotzdem Postfix falls Mails per z.B. Kontaktformular versendet werden sollen, richtig?
 
Zuletzt bearbeitet:

Till

Administrator
#16
Der Hostname ist tatsächlich mehr als 60-Zeichen lang wurde nur durch XYZ ersetzt. Hat weitreichende folgen nehme ich an oder ist dies wirklich nur ne Warnung?
das ist ja ein mysql Fehler, also keiner von ISPConfig. MySQL konte den User der für die Replikation zwischen den Servern nicht anlegen, da Dein Hostname zu lan ist. Das Ergebnis wird also sein dass die Beiden Server nicht verbunden sind und somit keine Änderungen vom Slave übernommen werden. Du solltest den Hostnamen kürzen und dann ISPConfig auf dem slave neu installieren.

Dann müsste doch bei Server 2 in ISPConfig3>System alles auf Null stehen außer Mail, oder? Und Server zwei müsste bei allem eins stehen haben außer bei Mail. Aber Server 1 benötigt trotzdem Postfix falls Mails per z.B. Kontaktformular versendet werden sollen, richtig?
Ja.
 

Werbung