ISPConfig 3.0.5.3 FTP-Account Konfiguration defekt

Dieses Thema im Forum "Allgemein" wurde erstellt von yato, 13. Aug. 2013.

  1. yato

    yato New Member

    Hallo,
    seit dem neuen Update bekomme ich einen Fehler, wenn ich versuche, die FTP-User zu verwalten. Klicke ich auf einen alten oder neuen FTP-User, wird dieser angezeigt, klicke ich auf Optionen, funktioniert auch noch alles, klicke ich dann wieder auf den Tab "FTP-User" kommt dann der Fehler
    "You have no permission for this domain."

    Durch debuggen habe ich herausgefunden, dass die Domain ID nicht ankommt.
    Auf der ersten Seite wird sie über GET übertragen, danach über POST, aber über POST steht dann als Domain_ID = 0....

    Gibt es eine schnelle Lösung dafür?
    Wenn nicht, ist es leicht möglich, auf die vorherige Version (über das Backup) downzugraden?
    Lg
     
  2. lordimac

    lordimac New Member

    Ist bereits im Bugtracker aufgenommen und als Fixed gekennzeichnet. Weiß jemand wann das im SVN landet oder wie das Problem behoben wurde?

    edit: http://bugtracker.ispconfig.org/index.php?do=details&task_id=3089

    edit2: Okay, ich war einfach zu doof für SVN. Über svn.ispconfig.org/ispconfig/branches findet man die Änderungen sowie den Fix.

    /var/www/ispconfig/sites/ftp_user_edit.php bearbeiten

    Zeile 94/95 suchen, Inhalt:

    Zeile davor einsetzen:

    Zeile danach einsetzen:

     
    Zuletzt bearbeitet: 14. Aug. 2013
  3. yato

    yato New Member

    That did it :)
    Danke für die schnelle Antwort!
     

Diese Seite empfehlen