ISPConfig 3.1: /etc/php5/cgi/php.ini wird nicht mehr eingebunden (Bug?)

Dieses Thema im Forum "Allgemein" wurde erstellt von titanium, 4. Okt. 2016.

  1. titanium

    titanium New Member

    Hallo,
    ich habe am Wochenende ISPConfig auf meinen Servern auf Version 3.1 aktualisiert und für alle vhosts einen Resync durchgeführt. Seitdem werden in den vhosts php-Fehlermeldungen (Notices/Warnings usw.) ausgegeben, wo vorher keine waren. In der php.ini unter /etc/php5/cgi/php.ini ist "display_errors = Off" konfiguriert - diese Einstellung wird seit dem Update offensichtlich nicht mehr beachtet.

    Vermutete Ursache: Vor dem Update waren in den Verzeichnissen /var/www/conf/webXXX/ (XXX = jeweilige vhost-ID) umfangreiche php.ini Dateien enthalten, die praktisch jeweils eine Kopie der Datei unter /etc/php5/cgi/php.ini waren, am Ende ergänzt durch die Einstellungen, die in der ISPConfig-Oberfläche (unter "Individuelle php.ini Einstellungen") vorgenommen wurden. Jetzt sind in diesen php.ini noch die Einträge enthalten, die über die ISPConfig-Oberfläche gemacht wurden.

    Der Fehler besteht also darin, dass die in /etc/php5/cgi/php.ini gesetzten globalen Standard-Einstellungen insgesamt außer Kraft geraten, sobald in ISPConfig "individuelle php.ini Einstellungen" aktiviert werden. Das war in 3.0 nicht so.

    Ist dieses Problem bereits bekannt? Ich habe dazu nichts im Forum gefunden.
     
    Zuletzt bearbeitet: 4. Okt. 2016
  2. Till

    Till Administrator

    Ist noch nicht bekannt, konnte ich aber hier reproduzieren. Ich füge es im Bugtracker nachher ein wenn er nach dem Systemupdate wieder online ist.
     

Diese Seite empfehlen