Ispconfig 3.1 ?

Dieses Thema im Forum "Smalltalk" wurde erstellt von mzips, 24. Feb. 2016.

  1. mzips

    mzips Member

    Hallo zusammen !

    Ich würde zu Ispconfig 3 wechsel nun warte ich aber auf die v 3.1 die auf der Roadmap zu 98% fertig ist, kann man schon abschätzen wann es so weit ist oder geht die erstmal in die beta ectpp. ?
    Vielen dank im Voraus
     
  2. Till

    Till Administrator

    Es wird erstmal eine Alpha in ein paar tagen geben. Das Update von 3.0.5.x auf 3.1 ist ein ganz normales Update, es macht keinen Sinn mit einer Installation auf 3.1 final zu warten da Du keinen Vorteil bei einer frischen Installation gegenüber einem Update hast, das update führt den gleichen Code zur Systemkonfiguration aus wie der Installer.
     
  3. nut

    nut New Member

    Hallo zusammen!

    Ich brauche für einen neuen Server die Let's Encrypt Funktionalität.
    Aktuell läuft ISPConfig Version: 3.0.5.4p8, ich überlege nun ob ich und welche Version ich installieren soll.
    3.1 dev mit Let's Encrypt (gibt es da eine Anleitung?)
    oder
    Let's Encrypt Erweiterung (Wo kann ich die neuste finden?)

    Was macht mehr Sinn?

    Ich möchte mir möglichst keine Probleme einhandeln, bzw. wieder auf den offiziellen Update-Pfad gehen können wenn 3.1 released ist.

    Vielen Dank für die Infos... ;-)

    Edit: Es ist ein Jessie/Apache System.
     
    Zuletzt bearbeitet: 10. März 2016
  4. Till

    Till Administrator

    Das ist schwer zu sagen da die letsencrypt extensions die es für 3.0.5 gibt mit 3.1 kollidueren werden, man müsste sie also vor einem update deinstallieren und da die zertifikate nicht übernnommen werden können vermutlich cuh die zertifikate neu machen.

    An sich ist die version aus dem stable-3.1 branch schon sehr weit, ja nach Anforderung an den Server kann man die durchaus schon mal probieren, wenn man damit leben kann dass vielleicht mal eine Funktion noch nicht 100% läuft oder man unter umständen mal eine zeile in einer config Datei manuell ändertn muss.

    Bislang noch nicht.
     
  5. nut

    nut New Member

    Danke Till,
    dann macht es nur Sinn den stable-3.1 Branch zu nehmen. Und config Dateien sind doch unser täglich Brot... ;-)

    Ich meine nicht eine Anleitung als PDF, sondern wie ich am saubersten von 3.0.5.4p8 zu stable-3.1 wechsle? Und später wieder auf den Release Pfad?
    Was muß ich beachten, evtl. hast Du das schon mal jemand erklärt im Forum?!

    Etwa so:
    git clone https://git.ispconfig.org/ispconfig/stable-3.1.git -> fragt nach nem Passwort :(
    cd stable-3.1/install
    php -q install.php

    Besten Dank
     
  6. Till

    Till Administrator

    Code:
    cd /tmp
    wget -O ispconfig3-dev.tar.gz "https://git.ispconfig.org/ispconfig/ispconfig3/repository/archive.tar.gz?ref=stable-3.1"
    tar xzf ispconfig3-dev.tar.gz
    cd ispconfig3-stable*/install
    php update.php
    Updates dann mit: ispcondig_update.sh, er bietet Dir an ob Du stable (derzeit 3.0.5.4p8), git-stable (derzeit stable-3.1) oder git-master updaten willst. Bis zum release von 3.1 wäre das git-stable, später dann einfach nur stable.

    Zu letsencrypt, die offizielle letsencrypt software musst Du natürlich installiert haben damit ispconfig sie nutzen kann.
     
  7. Till

    Till Administrator

    Ach ja, un bei Updates immer schön ja sagen, wenn er fragt ob er ein backup machen soll, dann kannst Du ggf. jederzeit ein rollback zum vorherigen release machen :) Das Backup enthält immer /usr/local/ispconfig, /etc und die dbispconfig DB, die Verzeichnisse als tar.gz inkl. permissions, also ggf einfach auspacken und an ursprungsort zurück kopieren und alte dbispconfig mit mysql commandline oder phpmyadmin wieder einspielen.
     
  8. mzips

    mzips Member

    Nehmen wir mal an es handelt sich um ein Debian Jessie System, also benutze ich das The Perfect Server - Debian 8 Jessie Tutorial und der Part an dem ispconfig Installiert werden soll können wir das oben gepostete benutzen ?
    Ist in dem Installer bei der frage nach ssl auch schon Lets Encrypt Supported für den Panel Login ?
    Sry für die vielen Fragen aber bin auch dabei weg von den anderen Opensource Lösungen hin zu ispconfig 3, ich sehe hier einfach die langjährigkeit die bisher keine andere Opensource lösung brachte.
     
  9. Till

    Till Administrator

    ja. Halt nur install.php dann.

    Nein, soweit ich weiß ist es bislang nur für Websites implementiert. Du könntest aber ggf. ein zertifikat für ispconfig 'manuell' mit letsencrypt erstellen und dann die Zertifikatsdateien in /usr/local/ispconfig/interface/ssl/ einfach durch symlinks auf die Zertifikate von letsencrypt ersetzen. apache, postfix und co folgen beim cert laden symlinks ohne probleme.
     
  10. nut

    nut New Member

    Perfekte Antwort für mich Till.
    Das war ja einfach...
    Schnell, schönes Design!

    Wenn ich jetzt in eine Webseite gehe, erhalte ich die Meldung:
    "1. SNI für SSL ist auf diesem Server nicht aktiviert. Sie können daher nur ein SSL Zertifikat pro IP Adresse eintragen."
    Und kann dann nicht mehr auf die anderen Reiter wechseln, bis SSL deaktiviert wurde. Das passiert auch bei neu angelegten Websites.

    Kann die Ursache ein "apache ssl defaul host" sein?
    https://www.howtoforge.de/forum/threads/apache-sni-multi-ssl-server.6573/
    a2dissite default-ssl

    Als Zusatzinfo: Bisher ist in diesem "The Perfect Server" ISPConfig der DNSserver deaktiviert. Die IP der Websites ist immer "*". Das DNS Handling macht der Hetzner Robot.
     
  11. nut

    nut New Member

    Waah, jetzt hab ich in der Serverkonfiguration SNI gefunden und aktiviert, jetzt komme ich aber nicht mehr auf die ISPConfog Oberfläche. Let' Encrypt funktioniert bei einer Seite die ich noch vor dem Rauswurf konfiguriert habe.

    Mein vormaliges Post ist somit hinfällig!

    Im Errorlog kommt nun:
    ````
    [ 2016-03-10 15:27:43.9800 1162/7f48d0bfb740 agents/Watchdog/Main.cpp:538 ]: Options: { 'analytics_log_user' => 'nobody', 'default_group' => 'nogroup', 'default_python' => 'python', 'default_ruby' => '/usr/bin/ruby', 'default_user' => 'nobody', 'log_level' => '0', 'max_pool_size' => '6', 'passenger_root' => '/usr/lib/ruby/vendor_ruby/phusion_passenger/locations.ini', 'passenger_version' => '4.0.53', 'pool_idle_time' => '300', 'temp_dir' => '/tmp', 'union_station_gateway_address' => 'gateway.unionstationapp.com', 'union_station_gateway_port' => '443', 'user_switching' => 'true', 'web_server_passenger_version' => '4.0.53', 'web_server_pid' => '1141', 'web_server_type' => 'apache', 'web_server_worker_gid' => '33', 'web_server_worker_uid' => '33' }
    [ 2016-03-10 15:27:44.1653 1165/7fb53ac71740 agents/HelperAgent/Main.cpp:650 ]: PassengerHelperAgent online, listening at unix:/tmp/passenger.1.0.1141/generation-0/request
    [ 2016-03-10 15:27:44.1931 1173/7faff8463780 agents/LoggingAgent/Main.cpp:321 ]: PassengerLoggingAgent online, listening at unix:/tmp/passenger.1.0.1141/generation-0/logging
    [ 2016-03-10 15:27:44.1933 1162/7f48d0bfb740 agents/Watchdog/Main.cpp:728 ]: All Phusion Passenger agents started!
    AH00016: Configuration Failed
    ````
    .... Und nix geht mehr, keine Domain ist erreichbar.

    Ergänzung:
    Apache wollte nicht mehr starten, weil ein Zertifikat Probleme bereitet hat.
    Was mich auf die Spur gebracht hat war das: http://www.randomhacks.co.uk/apache-2-4-failed-to-start-ah00016-configuration-failed/
     
    Zuletzt bearbeitet: 10. März 2016
  12. Till

    Till Administrator

    Ich nutze kein python, daher kann ich Dir zu den Python Fehlern nicht allzu viel sagen.
     
  13. nut

    nut New Member

    Wie kann ich die Zertifikate von Let's Encrypt nutzen?
    Immer wenn ich ein Zertifikat (mit Let's Encrypt) für eine Website erstelle, dann nutzt er das Zertifikat der nächst besten bzw. irgend einer anderen Website? (übrigens selbiges Verhalten wenn ich HTTPS nutze obwohl ssl aus ist)
    Im SSL Reiter sind auch nur SSL-Request und SSL-Zertifikat befüllt.
    Ohne "Let's Encrypt SSL" werden wie gehabt selv signed Zertifikate erstellt und genutzt.
    letsencrypt ist in /opt/letsencrypt installiert. Ich habe dann einfach mal den Befehl: ./letsencrypt-auto --help all aufgeführt.


    Ist evtl. mein Vorgehen falsch?
    1. "SSL" + "Let's Encrypt SSL" -> beide aktivieren
    2. Im Reiter SSL Oben die Werte eintragen (Bundesland, Ort, Firma, Abteilung, Land, SSL Domain)
    3. Im Reiter SSL "SSL-Aktion" -> "Zertifikat erstellen" wählen.
    4. Speichern
     
  14. Croydon

    Croydon Super-Moderator

    Hallo,
    zuerst einmal muss LetsEncrypt korrekt installiert sein. Das geschieht aber normalerweise, indem man einfach einmalig letsencrypt-auto (als root oder via sudo) ohne Parameter aufruft. Dabei sollte er dann alle Voraussetzungen installieren.
    Danach ist das Vorgehen so:
    SSL aktivieren und Lets Encrypt SSL aktivieren und speichern. Im SSL Tab NICHTS machen, sonst überschreibt man das LE-SSL sofort wieder.
    ISPConfig fordert dann automatisch das Zert für alle Aliasdomains/Subdomains und die Hauptdomain der Webseite an.
     
  15. nut

    nut New Member

    Danke Croydon,
    wenn ich ./letsencrypt-auto aufrufe, dann werde ich gefragt, für welche Domains ich HTTPS aktivieren möchte.
    Soll ich das für die gewünschten oder alle Domains bejahen? Anders gefragt, löst die cert Erstellung über Let's Encrypt nicht eigentlich ISPConfig aus?

    Richtiges Vorgehen danach in ISPConfig 3.1:
    1. "SSL" + "Let's Encrypt SSL" -> beide aktivieren
    2. Speichern
     
  16. Croydon

    Croydon Super-Moderator

    Beim Aufruf von letsencrypt-auto geht es nur darum, dass LE initialisiert wird. Generiert muss da nichts werden. Die Erstellung löst ISPconfig aus, dafür ist aber eine korrekte Installation von LE notwendig, die durch den ersten Aufruf von letsencrypt-auto eigentlich gemacht wird.
    Das Vorgehen ist in 3.1 so korrekt, ja.
     
  17. mzips

    mzips Member

    Habe jetzt mal die 3.1 Installiert läuft soweit echt gut aber beim Installer bekomme ich folgendes:
    [WARN] autodetect for Postgrey failed
    [WARN] autodetect for Mailman failed
    [WARN] autodetect for Metronome XMPP Server failed
    [WARN] autodetect for Ubuntu Firewall failed
    [WARN] autodetect for Bastille Firewall failed
    [WARN] autodetect for OpenVZ failed
    postconf: warning: unmatched request: "maildrop.unix"

    Muss Postgrey nur via apt Installiert werden ?
    Was hat es mit den Firewalls aufsich ist jetzt garkeine aktiv für ispconfig ?
    mailmann und openvz ist klar ist ja nicht drauf :D
    Gibt es ein HowTo für Metronome XMPP Server ?

    LG
     
  18. robotto7831a

    robotto7831a Member

    Postgrey wird per apt installiert.

    apt-get install postgrey
     
  19. florian030

    florian030 Member

    Die Warnungen zeigen Dir nur die Pakete an, die der Installer nicht gefunden hat.

    Die Warnung von postconf verstehe ich gerade aber nicht. Welche Postfix-Version und welches OS ist das denn? Hast Du in der master.cf "maildrop unix" ?
     
  20. mzips

    mzips Member

    Die dist ist Debian 8 und Postfix version 2.11.3 in der master.cfg steht nichts von "maildrop unix"
     

Diese Seite empfehlen