ISPConfig 3 / Apache (HTTPS) Owncloud Uploadprobleme

bigt

New Member
#1
Hallo liebe Kollegen...

nachdem ich mir einen Ubuntu 12.04 LTS Server mit ISPConfig 3 und Apache installiert habe, wollte ich mir auch gleich die OwnCloud 5 einrichten.

Leider habe ich dabei einige Probleme, die ich zuvor auf einem herkömmlichen Test-XAMPP Webserver nicht hatte :-/

Situation:
Einrichtung der Cloud mit Verwendung von SSL/HTTPS


Direkt nach der Installation in das root web Verzeichnis (Ohne owncloud Unterverzeichnis) erhielt ich eine Meldung:

Dein Web-Server ist noch nicht für Datei-Synchronisation bereit, weil die WebDAV-Schnittstelle vermutlich defekt ist. Bitte prüfe die Instalationsanleitungen.
Tatsächlich habe ich Probleme, Ordner werden über die Client Apps wunderbar synchronisiert, Dateien aber nicht. Ich konnte jedoch direkt auf die WebDAV Schnittstelle per Browser zugreifen und Musik Titel von Hand reinkopieren. Aber auch diese kamen nicht über die Client App an.

Nachdem ich die Cloud mal mit ihrem gewünschten Unterverzeichnis /owncloud installiert habe, kamen keine Fehler bei der Einrichtung. Das Resultat war aber das gleiche. CloudLog Ausgabe:

Code:
Warning     core     isWebDAVWorking: NO - Reason: exception 'Sabre_DAV_Exception' with message '[CURL] Error while making request: SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed (error code: 60)' in /var/www/clients/client2/web4/web/owncloud/3rdparty/Sabre/DAV/Client.php:410 Stack trace: #0 /var/www/clients/client2/web4/web/owncloud/3rdparty/Sabre/DAV/Client.php(179): Sabre_DAV_Client->request('PROPFIND', '', '<?xml version="...', Array) #1 /var/www/clients/client2/web4/web/owncloud/lib/util.php(599): Sabre_DAV_Client->propFind('', Array) #2 /var/www/clients/client2/web4/web/owncloud/settings/admin.php(34): OC_Util::isWebDAVWorking() #3 /var/www/clients/client2/web4/web/owncloud/lib/route.php(113) : runtime-created function(1): require_once('/var/www/client...') #4 [internal function]: __lambda_func(Array) #5 /var/www/clients/client2/web4/web/owncloud/lib/router.php(127): call_user_func('?lambda_254', Array) #6 /var/www/clients/client2/web4/web/owncloud/lib/base.php(610): OC_Router->match('/settings/admin') #7 /var/www/clients/client2/web4/web/owncloud/index.php(28): OC::handleRequest() #8 {main}     09.06.2013 15:13:00
Warning     PHP     curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set at /var/www/clients/client2/web4/web/owncloud/3rdparty/Sabre/DAV/Client.php#462     09.06.2013 15:13:00
Warning     search_lucene     failed to extract meta information for /administrator/files/clientsync/bilder: Could not open "/var/www/clients/client2/web4/web/owncloud/data/administrator/files/clientsync/bilder" (does not exist, or is not a file)     09.06.2013 15:10:10
Warning    PHP    curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set at /var/www/clients/client2/web4/web/owncloud/3rdparty/Sabre/DAV/Client.php#462    09.06.2013 15:13
Warning    search_lucene    failed to extract meta information for /administrator/files/clientsync/bilder: Could not open "/var/www/clients/client2/web4/web/owncloud/data/administrator/files/clientsync/bilder" (does not exist, or is not a file)    09.06.2013 15:10
Jetzt habe ich die Cloud ohne SSL eingerichtet.
Und siehe da, die Datei Synchronisation klappt auch soweit. Allerdings kann ich die maximale Upload Größe der Dateien nicht erhöhen, sie steht auf 2 MB. Wenn ich das ändere, wird der Wert einfach wieder auf 2 MB zurück gesetzt. Im CloudLog finde ich folgende Einträge:

Code:
Warning    PHP    curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set at /var/www/clients/client2/web3/web/owncloud/3rdparty/Sabre/DAV/Client.php#462    09.06.2013 14:01
Warning    PHP    xcache_isset(): xcache.var_size is either 0 or too small to enable var data caching at /var/www/clients/client2/web3/web/owncloud/lib/cache/xcache.php#39    09.06.2013 13:50
Warning    PHP    xcache_set(): xcache.var_size is either 0 or too small to enable var data caching at /var/www/clients/client2/web3/web/owncloud/lib/cache/xcache.php#34    09.06.2013 13:50
Warning    PHP    xcache_get(): xcache.var_size is either 0 or too small to enable var data caching at /var/www/clients/client2/web3/web/owncloud/lib/cache/xcache.php#27    09.06.2013 13:50
Frage:
Woran könnten meine 2 Probleme liegen?
1. Keine Datensynchronisation bei SSL möglich
2. Maximale Upload-Größe 2 MB lässt sich nicht erhöhen

Zu Analysezwecken bitte einfach nach Einstellungen oder Ausgaben fragen. Momentan bin ich noch überfragt, an welcher Stelle ich nach Fehlern, bzw. Konfigurationen schauen soll.

Vielen Dank für eure Unterstützung!

Gruß
Tobi
 

nowayback

Well-Known Member
#2
Hi,

Warning PHP curl_setopt_array(): CURLOPT_FOLLOWLOCATION cannot be activated when safe_mode is enabled or an open_basedir is set at /var/www/clients/client2/web3/web/owncloud/3rdparty/Sabre/DAV/Client.php#462 09.06.2013 14:01
In den Optionen der Website bei PHP open_basedir "none" eingeben

2. Maximale Upload-Größe 2 MB lässt sich nicht erhöhen
In den Optionen der Website bei individuelle php.ini Einstellungen:
upload_max_filesize = 1G
post_max_size = 1G

Achtung: Hier nicht mehr als 2G eingeben.

Tatsächlich habe ich Probleme, Ordner werden über die Client Apps wunderbar synchronisiert, Dateien aber nicht. Ich konnte jedoch direkt auf die WebDAV Schnittstelle per Browser zugreifen und Musik Titel von Hand reinkopieren. Aber auch diese kamen nicht über die Client App an.
Ich habe eine Subdomain erstellt und direkt dadrin meine owncloud laufen ohne Probs. Funktioniert mit und ohne SSL.

Grüße
nwb
 
#3
Hi,

super! Vielen Dank für die präzisen Antworten. Und alle Probleme sind behoben :)

Eine Sache steht noch im Log:

Code:
Warning     PHP     xcache_get(): xcache.var_size is either 0 or too small to enable var data caching at /var/www/clients/client2/web4/web/owncloud/lib/cache/xcache.php#27     10.06.2013 10:40:02
Warning     PHP     xcache_set(): xcache.var_size is either 0 or too small to enable var data caching at /var/www/clients/client2/web4/web/owncloud/lib/cache/xcache.php#34     10.06.2013 10:40:02
Warning     PHP     xcache_isset(): xcache.var_size is either 0 or too small to enable var data caching at /var/www/clients/client2/web4/web/owncloud/lib/cache/xcache.php#39     10.06.2013 10:40:02
Klingt nach einer Performance Sache. Wie wirkt sich das genau aus? Was könnte ich hier tun?

Viele Grüße
Tobi
 
#5
Die Upload-Begrenzung kannst du auch direkt über die .htaccess anpassen:

meine ownCloud .htaccess sieht so aus:

Code:
<IfModule mod_fcgid.c>
<IfModule mod_setenvif.c>
<IfModule mod_headers.c>
SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1
RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION
</IfModule>
</IfModule>
</IfModule>
ErrorDocument 403 /core/templates/403.php
ErrorDocument 404 /core/templates/404.php
<IfModule mod_php5.c>
php_value upload_max_filesize 1000M
php_value post_max_size 1000M
php_value memory_limit 999M
<IfModule env_module>
  SetEnv htaccessWorking true
</IfModule>
</IfModule>
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]
RewriteRule ^.well-known/carddav /remote.php/carddav/ [R]
RewriteRule ^.well-known/caldav /remote.php/caldav/ [R]	
RewriteRule ^apps/calendar/caldav.php remote.php/caldav/ [QSA,L]
RewriteRule ^apps/contacts/carddav.php remote.php/carddav/ [QSA,L]
RewriteRule ^apps/([^/]*)/(.*\.(css|php))$ index.php?app=$1&getfile=$2 [QSA,L]
RewriteRule ^remote/(.*) remote.php [QSA,L]
</IfModule>
<IfModule mod_mime.c>
AddType image/svg+xml svg svgz
AddEncoding gzip svgz
</IfModule>
AddDefaultCharset utf-8
Options -Indexes
siehe:

Code:
php_value upload_max_filesize 1000M
php_value post_max_size 1000M
php_value memory_limit 999M
PS: ich muss dazu sagen, dass ich die ownCloud kaum zum File-sycen benutze, da der native Mac Client einfach überhaupt nix taugt ...
Als Apple iCloud Alternative zur Cal/CardDAV Synchronisierung mit Mac iCal/Kontakte und Outlook per iCal4OL ist es ok ...
 
Zuletzt bearbeitet:
#6
den Fehler mit Xcache hatte ich auch

probiere mal das

/etc/php5/conf.d/20-xcache.ini

# den Pfad so ändern
xcache.mmap_path = "/tmp/xchache"
 

Till

Administrator
#7
Zu folgendem Fehler, den ich gerade auch bei einer Owncloud Installation in ISPConfig hatte:

Dein Web-Server ist noch nicht für Datei-Synchronisation bereit, weil die WebDAV-Schnittstelle vermutlich defekt ist. Bitte prüfe die Instalationsanleitungen.
Man muss Webdav für das web Verzeichnis deaktivieren, das geht miitels apache direktiven Feld in ispconfig:

Code:
<Directory /var/www/clients/client1/web1/web>
Dav Off
</Directory>
<Directory /var/www/owncloud.domain.tld/web>
Dav Off
</Directory>
 
#8
Seltsam, ich hatte die Meldung auch jedoch lag dieses an dem self-signed SSL Zertifikat.

Bei mir hat
'check_for_working_webdav' => false,
innerhalb von config/config.php das Problem gelöst.
 

Werbung