ISPConfig 3 - Postgrey

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von hahni, 24. Jan. 2013.

  1. hahni

    hahni Active Member

    Hallo zusammen,

    auf einem Kundenserver läuft Ubuntu 12.04 LTS mit ISPConfig 3. Auf Ubuntu 10.04 LTS lief Postgrey noch mit Port 10024.

    Allerdings nicht seit der Umstellung. Wenn ich die Policy in der main.cf aktiviere, werden alle eingehenden Nachrichten abgewiesen.

    Erklären kann ich mir das nicht. Bei Recherchen habe ich gelesen, dass es möglicherweise mit der IPv6-Unterstützung zusammenhängen könnte.

    Leider aber weiß ich nicht und verstehe auch nicht so recht, an welcher Stelle ich was umstellen muss. Hat jemand damit Erfahrung?

    Viele Grüße

    Hahni
     
  2. Till

    Till Administrator

    Der Postgry Port ist falsch, Port 10024 ist bereits in Benutzung. Ändere den Postgrey port in main.cf und postgrey Konfigurationsdatei auf einen anderen Wert, z.B. 6000
     
  3. hahni

    hahni Active Member

    So easy war es leider nicht :(!

    Nun steht wieder im Log folgendes:

    --
    Jan 24 13:40:21 server postfix/smtpd[1008]: warning: problem talking to server 127.0.0.1:6000: Connection refused
    --
     
  4. Till

    Till Administrator

    Schau mal mit netstat -tap, ob postgrey gestart ist und ob er auf Port 6000 läuft.
     
  5. hahni

    hahni Active Member

    Unter anderem:

    --
    tcp 0 0 server:10023 *:* LISTEN 1056/postgrey.pid -
    --

    Muss ich da ggf. den Port noch im Postgrey anpassen?
     
  6. Till

    Till Administrator

    Hatte ich ja oben geschrieben, in main.cf und postgrey config anpassen. Unter Debian steht der postgrey port in /etc/default/postgrey wenn ich mich recht erinnere.
     
  7. hahni

    hahni Active Member

    Nach dem Reboot scheint postgrey nicht mehr in der netstat-liste. Aber im Mail-Log steht - vermutlich weil der Dienst nicht läuft - folgender Fehler:

    --
    Jan 24 14:21:28 server postfix/smtpd[3805]: warning: connect to 127.0.0.1:6000: Connection refused
    --

    Und in der Prozess-Liste steht folgendes:

    --
    1061 ? Ss 0:00 /usr/sbin/postgrey --pidfile=/var/run/postgrey.pid --daemonize --inet=6000
    --

    netstat -tulpen
    --
    tcp6 0 0 ::1:6000 :::* LISTEN 0 9224 1061/postgrey.pid -
    --
     
    Zuletzt bearbeitet: 24. Jan. 2013
  8. hahni

    hahni Active Member

    Kann es sein, dass deswegen nichts geht, weil offensichtlich nu auf IPv6 gelauscht wird?
     
  9. hahni

    hahni Active Member

Diese Seite empfehlen