ISPConfig 3 Web interface wird nicht angezeigt

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von RaSi, 17. Aug. 2015.

  1. RaSi

    RaSi New Member

    Hallo,
    ich bin neu hier und habe gleich mal eine Frage.
    Ich habe einen neuen Server (Debian 8) aufgesetzt und die meisten der für ISPConfig 3 erforderlichen Abhängigkeiten installiert.
    Mir geht es lediglich darum eine webbasierte Verwaltungskonsole zu haben, auf der ich viele Domains verwalten kann. FTP, Mail und sonstiges brauche ich nicht.
    Der Server steht im internen Netz und wird von aussen auch nicht erreichbar sein. Es sollen ca 150 Test-Domains drauf laufen.

    Nun zu meinem Problem
    ISPConfig 3 läuft wohl, aber beim Aufruf von <Servername>:8080 bekomme ich statt der erhofften Config-Seite die Standard-Seite von Apache angezeigt.
    Diese Seite liegt bekanntlich in /var/www/html
    Ich habe mir die drei Dateien in /etc/apache2/sites-enabled angesehen. Da steht nix von /var/www/html drin.
    Wo zum Teufel holt sich der Server den Standard-Content her?
    Bzw. was muss ich tun, damit ich das ISPConfig-Dashboard angezeigt bekomme?

    Herzlichen Dank vorab.
    Wenn weitere Infos benötigt werden... immer gerne.

    RaSi
     
  2. Till

    Till Administrator

    Welches Tutorial hast Du verwendet und hast Du alle dort gelisteten Pakete installiert?
     
  3. RaSi

    RaSi New Member

    Hallo Till,
    ich habe die wohl offizielle Anleitung verwendet.
    (Hier kommt ein verbotener Link)/perfect-server-debian-8-jessie-apache-bind-dovecot-ispconfig-3/

    Aber ich habe nicht alle Pakete installiert, weil ich zu dem Zeitpunkt nicht alle Pakete verwenden wollte. Und ich bin ein Freund davon, nur so viel zu installieren, wie man wirklich braucht.
    Nun haben sich aber die Anforderungen geändert und ich werde den Server komplett neu aufsetzen.
    Es handelt sich um einen Webserver, der ausschließlich vom internen Netz aus erreichbar sein wird. Dort haben nur Entwickler Zugriff und es sollen ca. 350 Domains drauf. Leider gibt es bei Apache 2.5 gegenüber 2.2 einige Änderungen.
    Vorher hatte ich eine VirtualHosts.conf, in der alle 350 Domains drin waren. Ob das wieder so klappt....?
    Auf jeden Fall stimmt mein bisheriger Syntax nicht mehr.
     
  4. RaSi

    RaSi New Member

    So! Nun habe ich den Server neu und streng nach Vorgabe eingerichtet. ISPConfig läuft.
    Der Server heißt kappa
    Die Domain ist dd
    Rufe ich <hatetepedoppelpunktdoppelslash>kappa.dd auf, wird mir die Standard Apache Seite (It works) angezeigt.
    Nun habe ich eine erste Domain nds angelegt.
    Beim Aufruf von <hatetepedoppelpunktdoppelslash>nds.kappa.dd erhalte ich: Der Server unter nds.kappa.dd konnte nicht gefunden werden
    Die Domain ist unter /etc/apache2/sites-enabled zu finden.
    Übrigens: Der Server steht im lokalen Netz, soll auch nur intern erreichbar sein, DNS macht der Win-DC <*.company.local> und es gibt eine DNS-Weiterleitung auf einen Linux-Derver für die TLD .dd
    Ping auf kappa.dd und kappa.company.local geht.
    Hat jemand eine Idee, wo ich hingreifen muss?

    PS: Ich darf keine Links einfügen. Daher: <hatetepedoppelpunktdoppelslash>
    Herzlichen Dank
    RaSi
     
  5. reSh

    reSh Member

    Hello,

    ich hatte mal das selbe Problem. Nach einige Recherche ist mir aufgefallen, dass php-cgi nicht installiert/aktiviert war. Der korrekte docroot wird ja nur verwendet, wenn php-cgi da ist ansonsten /var/www/html.

    Ich hatte auch das Problem, dass einige Apache Module nicht installiert oder aktiviert waren - suexec z.B..

    mfg reSh
     

Diese Seite empfehlen