ISPconfig installiert, webseite aber nicht erreichbar

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von pilgrimm, 28. Nov. 2008.

  1. pilgrimm

    pilgrimm New Member

    Hallo!

    Habe es geschaft ISPconig 2.2.27 zu installieren. Es stand da
    sie können sich unter https://www.blabla:81 einloggen. Geht aber leider nicht. Ich bekomme die Fehlermeldung Verbindung fehlgeschlagen.

    Kann mir jemand weiterhelfen? Weiß nichtmal wo der zusätzliche apache installiert ist und wo ich jetzt nachschauen soll.

    mfg
    philipp
     
  2. Till

    Till Administrator

    Verweist denn die Domain www.blala auf Deinen Server?
     
  3. pilgrimm

    pilgrimm New Member

    Hallo Till!

    Ja die Domain stimmt. Hab Sie hier im Forum allerdings nicht richtig angegeben ;-)

    Ich habe auch inzwischen durch stöbern im Forum und durch genaues lesen der Fehlermeldung herausbekommen, dass es am 64bit System liegt.

    Bekomme die Fehlermeldung:

    Code:
    checking for OpenSSL support... yes
    checking for Kerberos support... no
    checking for DSA_get_default_method in -lssl... yes
    checking for pkg-config... no
    configure: error: Cannot find OpenSSL's libraries
    ERROR: Could not configure PHP
    
    Ich habe alle 64 und 32 bit openssl libraries mit yast installiert. Ja, ich nutze OpenSuse 11 64bit. Kann auch auf Debian 4.0 64bit oder Suse 10.3 64bit wechseln.
    Das scheint aber egal, da alle 64bit Systeme Probleme haben mit den openssl bibliotheken. Zumindest hab ich den eindruck nach dem lesen von diesem Post:

    http://www.howtoforge.de/forum/showthread.php?t=76&highlight=Cannot find OpenSSL's libraries

    Komisch finde ich das die installation trotz der Fehler nicht abbricht.
    Hat jemand inzwischen ein lauffähiges 64bit System und kann mir helfen? Ich kann nämlich nur 64bit Systeme auswählen bei meinem Provider.

    vg
    philipp
     
  4. Till

    Till Administrator

    Also Probleme mit OpenSSL Bibliotheken unter 64Bit hat nur SuSE. Debian, Ubuntu, Fedora, Centos und Mandriva sind davon nicht betroffen.

    Die Installation ist doch abgebrochen, wie der Fehler zeigt.

    Ich würde Dir zu einem Debian System raten, ist am stabilsten insbesondere auch bei Updates wo SuSE gerne mal was kaputt macht.
     
  5. pilgrimm

    pilgrimm New Member

    Normalerweise steht da doch:

    ..
    ...
    ....installation wird hier abgebrochen

    bei mir lief die allerdings bis zum ende mit einigen fehlermeldungen. vielleicht ist es ja doch ein anderes problem(iptables oder so), hab aber alles nach anleitung gemacht.

    ich werde morgen mal den kompletten fehler posten, mach jetzt erstmal feierabend :)

    ist aber schonmal gut zu hören das es mit ner anderen distri funktioniert...freu

    vg
     
  6. pilgrimm

    pilgrimm New Member

    hallo!

    hab hier nochmal die komplette Fehlermeldung am Schluss der installation.

    Vielleicht kann mir jemand sagen wo genau der hacken ist.

    Code:
    Bitte wählen Sie aus, über welches Protokoll (http oder https (SSL-Verschlüsselung)) Ihr ISPConfig-System erreichbar sein soll:
    1) HTTPS
    2) HTTP
    Ihre Wahl: 1
    
    ./setup2: line 1090: mysql_config: No such file or directory
    ./setup2: line 1091: httpd: No such file or directory
    ./setup2: line 1092: httpd2: No such file or directory
    ./setup2: line 1093: httpd2: No such file or directory
    ./setup2: line 1103: ip_addresses: No such file or directory
    ./setup2: line 1105: /root/ispconfig/php/php: No such file or directory
    ./setup2: line 1106: /root/ispconfig/dist.info: No such file or directory
    chmod: cannot access `/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper': No such file or directory
    ./setup2: line 1119: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
    ./setup2: line 1120: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
    Neustart einiger Dienste...
    which: no apachectl in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    which: no w3m in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/local/libexec)
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down mail service (Postfix)                                  done
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting mail service (Postfix)                                       done
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down mail service (Postfix)                                  done
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting mail service (Postfix)                                       done
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ProFTPD Server:                                         done
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ProFTPD Server:                                              done
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ProFTPD Server:                                         done
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ProFTPD Server:                                              done
    ./setup2: line 1163: /etc/init.d/ispconfig_server: No such file or directory
    Herzlichen Glueckwunsch! Ihr ISPConfig-System ist jetzt installiert. Falls Sie Quota nachinstalliert haben, fuehren Sie noch die in der Installationsanleitung beschriebenen Schritte durch. Ansonsten ist Ihr System jetzt ohne Reboot einsatzbereit.
    Bitte gehen Sie mit Ihrem Browser auf
    
    https://xxxxx.stratoserver.net:81
    
    und loggen sich ein:
    Benutzername: admin
    Passwort: admin
    
    ./setup2: line 1189: cd: /tmp/install_ispconfig/compile_aps/../..: No such file or directory
    You have new mail in /var/mail/root
    
    vg
    philipp
     
  7. Till

    Till Administrator

    In elchem Verzeichnis hast Du ISPConfig heruntergeladen und ausgeführt?
     
  8. pilgrimm

    pilgrimm New Member

    unter /tmp/install_ispconfig
    mit root rechten
     
    Zuletzt bearbeitet: 3. Dez. 2008

Diese Seite empfehlen