ispConfig legt keine Webs mehr an

Dieses Thema im Forum "Installation und Konfiguration" wurde erstellt von NaTzoR, 16. Jan. 2009.

  1. NaTzoR

    NaTzoR New Member

    Hallo Till,

    wie schon im Titel beschrieben, weigert sich ispConfig neue Webordner anzulegen.

    Ich vermute, dass ich durch irgendwelche Spielereien die Rechtevergabe des Ordners /var/www verhunzt habe.

    Aber auch das setzen der Rechte für den gesamten Ordner "www" (steht so bei mir in der Administration als User und Gruppe eingetragen) auf "www-data.www-data" bietet keine Abhilfe.

    Könntest du mir evtl. sagen, welcher User/Gruppe darauf Zugriff haben muss oder woran es sonst liegen könnte?

    Gruß
    David aka NaTzoR
     
  2. Till

    Till Administrator

    Also an den Rechten kann es nicht liegen, der ISPConfig Server Prozess läuft als root.

    Schau mal in die Datei /home/admispconfig/ispconfig/ispconfig.log, ob da irgendwelche Fehler drin stehen und starte ispconfig mal neu, falls der server prozess "gestorben" ist.
     
  3. NaTzoR

    NaTzoR New Member

    Danke für die schnelle Antwort, Till.

    Die Log-Datei hat von keinem Fehler berichtet. ISPConfig habe ich auch mal neugestartet, leider mit dem gleichen Erfolg oder eher Nicht-Erfolg.

    Noch irgendwelche Ideen, wieso er keine Ordner mehr anlegt?
     
  4. Till

    Till Administrator

    Führe mal den folgenden Befehl als root user aus:

    /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

    Erhältst Du irgendwelche Fehlermeldungen?
     
  5. NaTzoR

    NaTzoR New Member

    Keine Fehler, er hat -denke ich mal- nur die unbenutzten User gelöscht....
     
  6. Till

    Till Administrator

    Ok. Dann lege nochmal ein neues web an und führe dann den obigen Befehl aus. Danach schau bitte ins ispconfig.log und Poste alle Zeilen die neu hinzugekommen sind.
     
  7. NaTzoR

    NaTzoR New Member

    Alles klar, habe das mal gemacht. Mit dem Befehl scheint er wohl auch den Ordner anzulegen!

    Allerdings musste ich danach ein Web wieder löschen im ISPConfig, was er dann nicht gemacht hat (also den Ordner)
     
  8. Till

    Till Administrator

    Ok. das ist aber was ganz anderes als das was Du oben beschrieben hast. Bitte immer genau sagen, was das Problem ist.

    1) Wenn Du eine Webseite mit der gleichen Domain wieder anlegen willst, musst Du vorher den Papierkorb leeren.
    2) Ordner werden von Zeit zu Zeit per Cronjob entfernt, wenn diese nicht mehr notwendig sind.
     
  9. NaTzoR

    NaTzoR New Member

    Alles klar, da habe ich mich wohl falsch ausgedrückt.

    Beachte einfach den von dir zitierten Satz nicht. Das obige Problem besteht dafür nach wie vor.

    Ich lege mit ISPConfig ein neues Web an. Dieses erscheint dann dort auch im ISP-Bereich. Allerdings legt er beim Rootserver dann diesen Ordner nicht an, sondern erst, wenn ich deinen Befehl ausführe!
     
  10. Till

    Till Administrator

    Dann läuft der ISPConfig Daemon nicht. Ruf mal auf:

    /etc/init.d/ispconfig_server restart
     
  11. NaTzoR

    NaTzoR New Member

    Tatsache, es klappt. Dankeschön!

    Dann hätt ich noch eine Frage. Ich habe ja jetzt durch meine chown-Befehle alle Webordner dem falschen User zugeteilt.

    Gibts dafür auch einen Befehl um dies wieder zu berichtigen, da ich sonst ja alle per Hand machen müsste, was auch kein großes Problem wäre, doch so, kann ich ja via FTP nix mehr löschen oder neuerstellen etc.

    Gruß und Danke
    NaTzoR
     

Diese Seite empfehlen