ispConfig legt keine Webs mehr an

#1
Hallo Till,

wie schon im Titel beschrieben, weigert sich ispConfig neue Webordner anzulegen.

Ich vermute, dass ich durch irgendwelche Spielereien die Rechtevergabe des Ordners /var/www verhunzt habe.

Aber auch das setzen der Rechte für den gesamten Ordner "www" (steht so bei mir in der Administration als User und Gruppe eingetragen) auf "www-data.www-data" bietet keine Abhilfe.

Könntest du mir evtl. sagen, welcher User/Gruppe darauf Zugriff haben muss oder woran es sonst liegen könnte?

Gruß
David aka NaTzoR
 

Till

Administrator
#2
Also an den Rechten kann es nicht liegen, der ISPConfig Server Prozess läuft als root.

Schau mal in die Datei /home/admispconfig/ispconfig/ispconfig.log, ob da irgendwelche Fehler drin stehen und starte ispconfig mal neu, falls der server prozess "gestorben" ist.
 
#3
Danke für die schnelle Antwort, Till.

Die Log-Datei hat von keinem Fehler berichtet. ISPConfig habe ich auch mal neugestartet, leider mit dem gleichen Erfolg oder eher Nicht-Erfolg.

Noch irgendwelche Ideen, wieso er keine Ordner mehr anlegt?
 

Till

Administrator
#4
Führe mal den folgenden Befehl als root user aus:

/root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php

Erhältst Du irgendwelche Fehlermeldungen?
 

Till

Administrator
#6
Ok. Dann lege nochmal ein neues web an und führe dann den obigen Befehl aus. Danach schau bitte ins ispconfig.log und Poste alle Zeilen die neu hinzugekommen sind.
 
#7
Alles klar, habe das mal gemacht. Mit dem Befehl scheint er wohl auch den Ordner anzulegen!

18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1093: cp -fr /root/ispconfig/isp/error_de /var/www/web17/web/error
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1101: cp -fr /root/ispconfig/isp/standard_index.html_de /var/www/web17/web/index.html
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1133: ln -s /var/www/web17 /var/www/www.tmcp.die-maniacs.de
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 96: setquota -g web17 0 0 0 0 -a &> /dev/null
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 97: setquota -T -g web17 604800 604800 -a &> /dev/null
18.01.2009 - 10:59:05 => INFO - USER:
web17_admin:x:10017:10017:rcpX:/var/www/web17:/bin/false
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 664: cp -fr /root/ispconfig/isp/user_standard_index.html_de /var/www/web17/user/web17_admin/web$
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 720: setquota -u web17_admin 0 0 0 0 -a &> /dev/null
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 721: setquota -T -u web17_admin 604800 604800 -a &> /dev/null
18.01.2009 - 10:59:05 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /var/www/web17/.forward
18.01.2009 - 10:59:06 => INFO - maildirmake /var/www/web17/user/web17_admin/Maildir &> /dev/null, Line 110: maildirmake /var/www/web17/user/web17_admin/Maildir &> /dev/null
18.01.2009 - 10:59:06 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 117: symlink /var/www/web17/Maildir
18.01.2009 - 10:59:06 => INFO - chown web17_admin:web17 /var/www/web17/user/web17_admin/.spamassassin
18.01.2009 - 10:59:06 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
18.01.2009 - 10:59:06 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
18.01.2009 - 10:59:07 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: postmap hash:/etc/postfix/virtusertable
18.01.2009 - 10:59:07 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1265: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.con$
18.01.2009 - 10:59:07 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2601: . /etc/apache2/envvars && httpd -t &> /dev/null
18.01.2009 - 10:59:07 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2611: httpd syntax ok
18.01.2009 - 10:59:08 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 reload &> /dev/null
18.01.2009 - 10:59:09 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
18.01.2009 - 10:59:10 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
18.01.2009 - 10:59:10 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2067: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
18.01.2009 - 10:59:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2663: rm -fr /var/www/www.rcp.die-maniacs.de
18.01.2009 - 10:59:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2664: rm -fr /var/www/web9
18.01.2009 - 10:59:11 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2669: WARNING: could not setquota -g web9 0 0 0 0 -a &> /dev/null
18.01.2009 - 10:59:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2663: rm -fr /var/www/www.rcp4.die-maniacs.de
18.01.2009 - 10:59:11 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2664: rm -fr /var/www/web10
Allerdings musste ich danach ein Web wieder löschen im ISPConfig, was er dann nicht gemacht hat (also den Ordner)
 

Till

Administrator
#8
Allerdings musste ich danach ein Web wieder löschen im ISPConfig, was er dann nicht gemacht hat (also den Ordner)
Ok. das ist aber was ganz anderes als das was Du oben beschrieben hast. Bitte immer genau sagen, was das Problem ist.

1) Wenn Du eine Webseite mit der gleichen Domain wieder anlegen willst, musst Du vorher den Papierkorb leeren.
2) Ordner werden von Zeit zu Zeit per Cronjob entfernt, wenn diese nicht mehr notwendig sind.
 
#9
Alles klar, da habe ich mich wohl falsch ausgedrückt.

Beachte einfach den von dir zitierten Satz nicht. Das obige Problem besteht dafür nach wie vor.

Ich lege mit ISPConfig ein neues Web an. Dieses erscheint dann dort auch im ISP-Bereich. Allerdings legt er beim Rootserver dann diesen Ordner nicht an, sondern erst, wenn ich deinen Befehl ausführe!
 
#11
Tatsache, es klappt. Dankeschön!

Dann hätt ich noch eine Frage. Ich habe ja jetzt durch meine chown-Befehle alle Webordner dem falschen User zugeteilt.

Gibts dafür auch einen Befehl um dies wieder zu berichtigen, da ich sonst ja alle per Hand machen müsste, was auch kein großes Problem wäre, doch so, kann ich ja via FTP nix mehr löschen oder neuerstellen etc.

Gruß und Danke
NaTzoR
 

Werbung

Top