ISPConfig löscht E-Mail Account nach Update

#1
Hallo :),

ich habe ISPConfig als Multi-Server Installation am laufen.

Der Mailserver wurde von Cyrus auf Dovecot Migriert, was einwandfrei geklappt hat.

Möchte man jetzt aber z.B. den Speicherplatz eines Postfachs ändern, dann löscht ISPConfig beim nächsten Update einfach den kompletten Ordner samt E-Mails, Ordner, Flilter u.s.w

Beispiel:
/srv/vmail/testdomain.de/meinetestemail@testdomain.de/Maildir

Der Ordner "meinetestemail@testdomain.de" ist dann einfach weg, wird aber neu angelegt sobald das Postfach abgefragt wird.

Lege ich per ISPConfig eine neue E-Mail adresse an, die also nicht Migriert wurde, einfach komplett neu, dann kann ich soviel ändern wie ich will, klappt wunderbar.


Ich habe jetzt jede Datei verglichen, absolut identisch. MySQL verglichen, genau das gleiche.

Datei Rechte alles genau gleich.

Was mir aufgefallen ist:

Ich verschieb vorher meinen Ordner "meinetestemail@testdomain.de", mach dann ein Update. (Ordner kann also nicht gelöscht werden, ist ja verschoben), schiebe es danach wieder an die richtige stelle, kann ich soviel Updaten wie ich will. Ist dann kein problem mehr.

Verschieb ich "meinetestemail@testdomain.de", erstelle den Ordner manuell neu, mach ein Update, wird er auch gelöscht. (Der angelegte Ordner)


Also zusammengefasst: ISPConfig löscht den Ordner, außer er ist direkt von ISPConfig selber angelegt worden.


Ich habe wie gesagt, alles doppelt und dreifach verglichen, finde keinen Fehler.


Vielen Dank für eure Hilfe!

Schöne Grüße
Holger
 

Till

Administrator
#2
Ein ordner wird nur gelöscht wenn das maildir nicht vollständig ist. Das von dir genannte beispiel ist auch kein nomaler maildir pfad in idpconfig. Der pfad muss lauten:

/var/vmail/domain.tld/user/Maildir

Und im maildir müssen die richtigen unterordner und dtien vorliegen.
 
#3
Hallo Till,

dass mit dem Pfad passt schon. umgenau zu sein ist er: /srv/vmail/domain.de/user01 (E-Mail Verkehr geht auch, also wird er richtig sein)

Exakt so liegt er auch auf Datei Ebene.

Was ich nicht verstehe, wenn ISPConfig sein Update gemacht hat, Ordner ist weg, ich dann ein Backup vom gelöschten Ordner zurückspiele, kann ich Updaten soviel ich will. Aber da sind dann die Datei genau so wenig vorhanden wie vor dem ersten Update.

Selbst wenn ich zwei Ordner habe (User01(Migirert von Cyrus) und User02(Von ISPConfig angelegt)). Dann den User02 Ordner über den User01 Ordner drüberkopiere, dann sind auch alle Fehleden Datein vorhanden, wird er trotzdem gelöscht.


Was muss den alles vorhanden sein damit ISPConfig den als "Richtig" erkennt und nicht löscht?
 

Till

Administrator
#4
umgenau zu sein ist er: /srv/vmail/domain.de/user01 (E-Mail Verkehr geht auch, also wird er richtig sein)
Das ist ok, Du hattest oben ein anderes Schema gepostet.

Was muss den alles vorhanden sein damit ISPConfig den als "Richtig" erkennt und nicht löscht?
Unter Dovecot müssen folgende Ordner vorhanden sein:

/srv/vmail/domain.de/user01/Maildir/new
/srv/vmail/domain.de/user01/Maildir/cur
 
#5
Sind alle vorhanden:
cur
dovecot.index
dovecot.index.cache
dovecot.index.log
dovecot-uidlist
dovecot-uidvalidity
dovecot-uidvalidity.511915fb
new
tmp


Das Komische ist ja auch, wenn ich den Ordner aus dem Backup zurückkopieren, müsste er den Account wieder löschen wenn was fehlen sollte, dann geht es aber Einwandfrei...


Wenn ich in ISPConfig ein Konto geöffnet habe und mich durch die Reiter oben klicke " E-Mail Konto Autoresponder E-Mail Filter eigene Regeln", wird sofort, ohne das was verändert wurde, ein Update eingetragen und dann natürlich innerhalb der nächsten 60 Sekunden durchgeführt. Das Passiert auch nur ein mal.


Ich habe irgendwie das Gefühl, dass irgendwo in der Datenbank etwas Fehlt und erst beim Update richtig gestellt wird. In der Tabelle "mail_user" verändert sich aber rein gar nichts.
 

Till

Administrator
#6
Wenn ich in ISPConfig ein Konto geöffnet habe und mich durch die Reiter oben klicke " E-Mail Konto Autoresponder E-Mail Filter eigene Regeln", wird sofort, ohne das was verändert wurde, ein Update eingetragen und dann natürlich innerhalb der nächsten 60 Sekunden durchgeführt. Das Passiert auch nur ein mal.
Dann ist vielleicht beim iportieren was schief gegangen und z.B. der Pfad in der mailbox steht nicht richtig in der DB oder ähnliches. Ein Update beim wechseln der Reiter wird nur ausgeführt wenn der datensatz in der DB (Tabelle mail_user") vor und nach dem Reiterwechsel nicht identisch ist. Da doe Prüfung des maildirs auch auf den Pfad in der DB zurückgreift, würde ich darauf tippen dass dort beim importieren nicht der richtige Pfad eingetragen wurde.
 

Werbung

Top