ispconfig und suphp

#1
Hallo erstmal,
erstmal ein Lob dafür das es solche Community gibt wie diese:)
Ich hab gegoogelt sufu benutzt und bin kurz vorm zusammen brechen.
Deshalb seid ihr hier meine letzte Hoffnung.
Debian Etch 4.0 php5
Alles installiert nach howto.
Hab nun auch suphp installiert.
alles ohne Fehlermeldung.
Nur leider zeigt er mir keine phpinfo.php an.
meine vhost schaut so aus:
<VirtualHost xx.xx.xx.xx:80>
SuexecUserGroup nobody web1
ServerName www.xxxxx.de:80
ServerAdmin webmaster@xxxxx.de
DocumentRoot /var/www/web1/web
ServerAlias xxxxx.de
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
Alias /cgi-bin/ /var/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Directory /var/www/web1/web>
suPHP_Engine on
suPHP_UserGroup nobody web1
AddHandler x-httpd-php .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-php
SetEnv php_safe_mode On
</Directory>
Das versteh ich nicht wirklich.
Hoffe ich konnte das hier einigermassen erkären und hoffe auf eure Hilfe.

Gruß und Danke im voraus

undercover
 
Zuletzt bearbeitet:
#3
phpinfo

Wenn ich die phpinfo.php aufgerufen habe zeigte er mir das:

<?php phpinfo();
php?>

:D
Aber das hat sich schon erledigt , hab es hinbekommen.
Danke für die Antwort.

Ich komm auch bestimmt wieder mit den nächsten Problem^^
Ganz bestimmt sogar.
 
#6
ispconfig mit suphp

Stimmt natürlich:)

Der Fehler lag wie schon vermutet von Planet_Fox in der suphp.conf

Im tutorial ist der code wie sie aussehen soll etwas unglücklich dargestellt.
Hab die suphp nochmal überarbeitet und schon ging es.
MfG
undercover
 

Werbung

Top